Subject: [Ietf-and-github] New draft, and proposal for BoF at IETF 103

From: Paul Hoffman <[email-masked]>
Date: Sat, 15 Sep 2018 00:08:53 +0000

Greetings again. Alissa and I have started a new draft:
   https://datatracker.ietf.org/doc/draft-cooper-wugh-github-wg-configuration/

The purpose of the draft is to design tooling in the IETF for WGs to start using GitHub if they aren't already, and to help individuals within WGs as well. It is definitely *not* to standardize GitHub interactions in WGs.

And, to this end, we have proposed a BoF for IETF 103 in Bangkok to discuss the ideas and see if there is community interest.
   https://trac.tools.ietf.org/bof/trac/wiki#WGsUsingGitHub

Comments on either or both of these are welcome.

--Paul Hoffman

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 19 Sep 2018 08:43:24 -0400

> On Sep 14, 2018, at 8:08 PM, Paul Hoffman <[email-masked]> wrote:
> 

There have been no comments on this. Does that mean the proposals in the doc are uncontroversial, and we should skip the BOF and just proceed to working with the tools team and secretariat? Or does it mean people are busy, or not paying attention? It would be helpful to get a few answers to those questions to help figure out whether we need BOF time for this or not.

Thanks,
Alissa

> _______________________________________________
> Ietf-and-github mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-and-github

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Sep 2018 09:00:51 -0400

Hi,

> There have been no comments on this. Does that mean the proposals in the doc are uncontroversial, and we should skip the BOF and just proceed to working with the tools team and secretariat? Or does…

no offense, but there isn't really anything non-obvious in draft-cooper-wugh-github-wg-configuration. IMO draft-thomson-github-bcp-00 is quite a bit more practically useful. Is that also in scope for discussion?

As for the BOF, I'm not personally missing much integration on the IETF side. I would like more integration on the GitHub side, but that we can't directly influence. But if others have ideas for what might be useful to do on our side, sure.

Lars

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 19 Sep 2018 14:14:39 +0000

I sent a private note to Paul supporting this.  I would gladly join the BOF.  One of my main motivations is consistent naming so that things are more easily discoverable by the general public, such as implemented in the scripts I wrote.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 20 Sep 2018 08:57:38 +1200

Alissa,

Since I won't be in Bangkok I don't have a strong view on whether
a BOF is needed or not. I think we need draft(s) on how to do things
and we need discussion on how the use of github fits into the open
consensus process. Personally I find the stream of consciousness
messages from a git issue tracker pretty indigestible, for example.
Actual decisions on substantive changes seem to need normal human-generated
emails.

Regards
   Brian

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 20 Sep 2018 14:12:12 -0400

> On Sep 19, 2018, at 9:00 AM, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
> 

I think it certainly could be, especially if people think the outcome would be different from the last BoF discussion of it.

Alissa

---

From: Martin Thomson <[email-masked]>
Date: Sat, 22 Sep 2018 10:05:47 -0700

> I think it certainly could be, especially if people think the outcome would be different from the last BoF discussion of it.

FWIW, I'm happy to work with Alissa and Paul (or anyone else) to get
that doc in better shape if people believe that to be the right
answer.  I have a -01 that includes a bunch of feedback already, but I
didn't get around to pushing it.

When I talked to Alissa about this draft, I got the impression that
the idea was to go for something less comprehensive, which would be
more incremental in nature.  In terms of steps, these are good steps,
but I take Lars' point here: as a community, we're already well past
those baby steps and we might want to codify some more of the process.

I'm happy to join a discussion in Bangkok about this.  I think that
we've only really talked about the benefits/processes a few times in
the past.  If the intent here is to make the processes more concrete
and to gain some amount of official support for those processes, that
is worth discussing.

(BTW, I'm having similar discussions about congealing work practices
in my day job.  Supporting diverse work practices can be expensive,
and there is always some tension between wanting to find more
efficiency through supporting fewer options and supporting the highly
efficient and specialized practices that individuals or groups might
have developed over time.  It's a fun discussion.)

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 22 Sep 2018 20:22:03 +0000

> have developed over time.  It's a fun discussion.)

If the BoF gets approved and scheduled for a 1.5 hour slot, we should have time to also have a discussion of current practices and their effects on WG processes.

--Paul Hoffman

---

From: Jari Arkko <[email-masked]>
Date: Tue, 25 Sep 2018 12:04:09 +0800

I have read the draft and think it proposes reasonable things. I like the focus on incremental small steps. But it is also true that there wasn’t anything that’s hugely controversial (even if one might have different suggestions — see below). If there’s a BOF then it should focus on progressing concrete work rather than grand visions or debate. Bofakathon…?

I saw that the draft focused quite a bit on data tracker operations to request the creation of various things. I think that’s useful, but even more useful would be the ability for the data tracker (and tools pages) to point to the relevant GitHub repos for specific WGs and drafts. I don’t think that currently exists, and providing pointers to users of GitHub would be perhaps more frequently used feature than providing tools to create the repos etc.

Jari

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 25 Sep 2018 12:35:13 +0000

I think the "user" structure in DataTracker should have an additional (set of) attributes, mapping users to external accounts, like
	Rich Salz
	[email-masked], [email-masked] , ...
	github: richsalz, gitlab: rsalz, ...