Subject: [Ietf-and-github] git push not working

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 6 Oct 2021 09:22:01 -0500

Hi all,

We are collaboratively writing a draft on Github  and the Github repository
is in my Github account.
We agreed on a .md file version, I pulled it to my local machine (MacOS),
ran kramdown and xml2rfc to generate .xml and .txt file.
When I do
git push
to push the generated files to Github, it asks my user name and password.
Then it says:

remote: Support for password authentication was removed on August 13, 2021.
Please use a personal access token instead

Please help.

Behcet

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 6 Oct 2021 14:23:42 +0000

https://docs.github.com/en/authentication/keeping-your-account-and-data-secure/creating-a-personal-access-token

  *   remote: Support for password authentication was removed on August 13, 2021. Please use a personal access token instead

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 8 Oct 2021 16:39:53 -0500

Hi all,

Yes I created an access token for my repo changes.
Now I got into this problem: like before, I pulled .md file from Github
repo and then generated .xml, .txt files.
Next I did

git push --repo https://github.com/myaccount/myrepo

after entering the access token I get:

Everything up-to-date

Why?

My solution is to manually upload the files from my laptop, but is that the
point with Git?

Behcet

On Wed, Oct 6, 2021 at 9:23 AM Salz, Rich <[email-masked]> wrote:

>    - remote: Support for password authentication was removed on August
>    13, 2021. Please use a personal access token instead
>
>
>

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 9 Oct 2021 01:34:36 +0000

If you have the MD file, then the XML isn’t normally stored in the repository. If you want to do that, you will have to “git add” the file.

I am sorry you are having problems and confusion.

  *   My solution is to manually upload the files from my laptop, but is that the point with Git?

Manually update where?  To datatracker or somewhere else?

I’m away for the next few days.  Good luck.