Subject: [Ietf-message-headers] X-Content-Type-Options

From: Anne van Kesteren <[email-masked]>
Date: Mon, 15 May 2017 09:40:01 +0200

Header field name: X-Content-Type-Options

Applicable protocol: http

Status: standard

Author/Change controller: WHATWG

Specification document(s):
https://fetch.spec.whatwg.org/#x-content-type-options-header

Related information: N/A

-- 
https://annevankesteren.nl/

---

From: Ted Hardie <[email-masked]>
Date: Wed, 17 May 2017 14:56:00 -0400

Hi Anne,

https://tools.ietf.org/html/rfc6648 suggests avoiding the x- construct
wherever possible.  Is it possible to go to Content-Type-Options, without
the X-?

regards,

Ted Hardie

On Mon, May 15, 2017 at 3:40 AM, Anne van Kesteren <[email-masked]> wrote:

> _______________________________________________
> Ietf-message-headers mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-message-headers
>

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 18 May 2017 11:55:20 +1000

It's already widely-deployed, so it's grandfathered in, I think.

https://msdn.microsoft.com/library/gg622941(v=vs.85).aspx

> On 18 May 2017, at 4:56 am, Ted Hardie <[email-masked]> wrote:
> 
> Hi Anne,
> 
> https://tools.ietf.org/html/rfc6648 suggests avoiding the x- construct wherever possible.  Is it possible to go to Content-Type-Options, without the X-?
> 
> regards,
> 
> Ted Hardie
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Anne van Kesteren <[email-masked]>
Date: Thu, 18 May 2017 06:00:53 +0200

> https://msdn.microsoft.com/library/gg622941(v=vs.85).aspx

That is exactly it. I think everyone knows better now, so I wouldn't
expect much more of these, but it's also not worth the effort of
trying to get rid of the prefix and adding all the complexity of
supporting two headers meanwhile.