Subject: [Ilc] New Non-WG Mailing List: Ilc -- Discussion of mechanisms and applications for Internet-level consensus.

From: IETF Secretariat <[email-masked]>
Date: Fri, 10 Feb 2017 11:39:45 -0800

A new IETF non-working group email list has been created.

List address: [email-masked]
Archive: https://mailarchive.ietf.org/arch/search/?email_list=ilc
To subscribe: https://www.ietf.org/mailman/listinfo/ilc

Purpose:

Several applications depend on Internet-wide consensus to secure an append-only log, provide tamper-resistant timestamps, and atomically commit transactions across mutually distrustful parties with no preexisting relationship. Examples include: 

* The IETF trans working group is specifying data structures and operational mechanisms for providing secure logging and auditing of TLS server certificates, but lacks a mechanism for determining consensus among logs (or consensus about whether or not a resource should be logged). These functions are currently served by an experimental gossip protocol that can potentially be strengthened through global consensus. 

* The Stellar payment network, is used by remittance companies to trade currencies and send payments across the Internet. 

* UCSD's SPAM (Secure PAckage Manager) project relies on a secure global log both to enable revocation of previously published vulnerable software packages and to guarantee that a particular software release has been publicly available for audit (somewhat like certificate transparency). 

* Stellar has an ongoing secure naming project that aims to allow domain name owners to assign human-readable names to end-user public keys without retaining the ability to lie about those public keys undetected. 

This list is to discuss such applications, the mechanisms that can meet their consensus needs, and a potential role of the IETF in devising a stable specification for an Internet-level consensus mechanism. 

For additional information, please contact the list administrators.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Sun, 12 Feb 2017 14:19:04 +0100

On Fri, Feb 10, 2017 at 11:39:45AM -0800,
 IETF Secretariat <[email-masked]> wrote 

> A new IETF non-working group email list has been created.

Congratulations for managing not to spell "blockchain" even once :-)

> The Stellar payment network

Good, I own 400 lumens :-)

> Stellar has an ongoing secure naming project that aims to allow
> domain name owners to assign human-readable names to end-user public
> keys

Is it a reference to
<https://www.stellar.org/developers/guides/concepts/federation.html>?

---

From: David Mazieres <[email-masked]>
Date: Sun, 12 Feb 2017 17:04:26 -0800

> Congratulations for managing not to spell "blockchain" even once :-)

Thanks.

> Good, I own 400 lumens :-)

Obviously this list isn't about Stellar or Bitcoin.  But those systems
are an existence proof of consensus technologies not currently in use by
any IETF protocols.  So to the extent there may be an unmet need, they
are worth exploring.

> <https://www.stellar.org/developers/guides/concepts/federation.html>?

It's an internal project that could maybe be viewed as v2 of that.  But
the larger point is that, in the IETF context, such a system would face
an unmet need for global consensus.

E.g., if I'm an email provider with a domain name, I have no standard
way to certify my users' public keys for end-to-end email encryption
that gets me out of the trust loop.  There are proposals (e.g., CONIKS,
the Google/Yahoo end-to-end email encryption system), etc., but they
would be strengthened by a global append-only log.

David