Subject: [EAI] CONSENSUS CALL: Header format for alt-addr

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 26 Jan 2007 11:05:28 +0100

I think it's time we settled the issue of the format of email addresses in 
UTF8SMTP headers for this round.

PROPOSED RESOLUTION:

The representation of an internationalized email address with an alternate 
ASCII address in an UTF8SMTP message is

   <eai@address <ascii@address>>

A pure EAI address and a pure ASCII address are both encoded without the 
extra field: as <email@address>.
Details of ABNF to be worked out after a draft with this syntax has been 
emitted.

POSSIBLE RESPONSES:

1. I agree with this resolution
2. I disagree with this resolution, for the following technical reason:
3: I have another opinion, which is:

RESPOND:

- To the list, if you want to present an argument or just want to make your 
position visible at once
- To the chairs, if you don't want to respond on-list.

The deadline for responses is THURSDAY, FEBRUARY 1, 23:59 GMT
The chairs will prepare a summary, with names listed for each position, 
hopefully on Friday, Feb 2.

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Tony Finch <[email-masked]>
Date: Fri, 26 Jan 2007 10:53:45 +0000

On Fri, 26 Jan 2007, Harald Tveit Alvestrand wrote:
> A pure EAI address and a pure ASCII address are both encoded without the extra
> field: as <email@address>.

Nice and uncluttered and does not use non-special characters for syntactic
delimiters like some previous suggestions.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
FAIR ISLE: NORTHWEST 6 TO GALE 8, DECREASING 5 OR 6. ROUGH OR VERY ROUGH.
ISOLATED SHOWERS. GOOD.

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 26 Jan 2007 13:18:56 +0100

> 1. I agree with this resolution

It doesn't introduce new delimiters, and it's not
worse than square backets wrt future mailto URLs.

Frank

---

From: "Charles Lindsey" <[email-masked]>
Date: Fri, 26 Jan 2007 17:25:23 -0000

On Fri, 26 Jan 2007 10:05:28 -0000, Harald Tveit Alvestrand  
<[email-masked]> wrote:

> I think it's time we settled the issue of the format of email addresses  
> in UTF8SMTP headers for this round.
>
> PROPOSED RESOLUTION:
>
> The representation of an internationalized email address with an  
> alternate ASCII address in an UTF8SMTP message is
>

Note that if some technical reason why '[...]' is superior to '<...>'  
should subsequently appear, it could easily be changed to that. But no  
such technical reason has appeared to date, hence '<....>' is preferred as  
a matter of appearance.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Kari Hurtta <[email-masked]>
Date: 26 Jan 2007 19:50:55 +0200

Harald Tveit Alvestrand <[email-masked]> writes in gmane.ietf.ima:

> I think it's time we settled the issue of the format of email
> addresses in UTF8SMTP headers for this round.
> 
> PROPOSED RESOLUTION:
> 
> A pure EAI address and a pure ASCII address are both encoded without
> the extra field: as <email@address>.
> Details of ABNF to be worked out after a draft with this syntax has
> been emitted.
>

---

From: Chris Newman <[email-masked]>
Date: Fri, 26 Jan 2007 21:57:03 -0800

I agree with this resolution.

                - Chris

---

From: Yangwoo Ko <[email-masked]>
Date: Sat, 27 Jan 2007 15:36:32 +0900

> 1. I agree with this resolution

+1

I like recycling <>

---

From: "william(at)elan.net" <[email-masked]>
Date: Fri, 26 Jan 2007 22:53:12 -0800 (PST)

>> 1. I agree with this resolution

I like it too.

One possible issue is all those scripts designed to process emails
and extra address from From field. Its kind of both good and bad - 
on one side we may want those old scripts to still work and reliably
get ascii address (that its UTF8 maybe less of an issue, libraries
and interpreters like perl take care of conversions and allow strings
to be either ascii or utf8). On the other hand we may purpose want
those scripts to fail since its a new type of address.

-- 
William Leibzon
Elan Networks
[email-masked]

---

From: [email-masked]
Date: Wed, 31 Jan 2007 21:15:52 +0900 (JST)

> From: Harald Tveit Alvestrand <[email-masked]>

--
Kazunori Fujiwara, JPRS

---

From: Yoshiro YONEYA <[email-masked]>
Date: Thu, 1 Feb 2007 07:33:53 +0900

-- 
Yoshiro YONEYA <[email-masked]>

---

From: Yoshiro YONEYA <[email-masked]>
Date: Thu, 1 Feb 2007 07:33:53 +0900