Subject: [EAI] INTERMEDIATE POLL RESULTS on the "what MIME type" question

From: Harald Alvestrand <[email-masked]>
Date: Wed, 27 Jun 2007 08:59:41 +0200

This is an intermediate poll result report. The poll closes on Friday, 
12:00 GMT.
Apart from my opinion, all of the opinions listed below have been posted 
to the list. Not all respondents responded to all questions.

This is a chance to comment on the reporting format, and to check for 
errors.
We will draw no conclusions before Friday's deadline has passed.

QUESTION 1: Should there be a new MIME type for UTF8SMTP messages when
carried inside messages in an UTF8SMTP environment?

A: No, message/rfc822 can be used.
   Kari Hurtta (very slight preference)
   Charles Lindsey
B: Yes.
   Harald Alvestrand
   Chris Newman
   John Klensin
   Yangwoo Ko
   Martin Duerst
   Kazunori Fujiwara
   Mao Wei
   Randall Gellens
   Yao Jiankang
   Tony Hansen
   Jaeyoun Kim
   Abel Yang
C: I have another opinion, which is....

QUESTION 2: Should the same MIME type be used to carry UTF8SMTP messages 
in a SMTP environment (without the UTF8SMTP extension, and without 
requiring the 8BITMIME extension)?
This implies that it's possible to encode the message.

A: Yes.
   Harald Alvestrand
   Chris Newman
   John Klensin
   Yangwoo Ko
   Martin Duerst
   Kazunori Fujiwara
   Mao Wei
   Randall Gellens
   Yao Jiankang
   Tony Hansen
   Jaeyoun Kim
   Abel Yang
B: No, that should not be allowed.
C: I have another opinion, which is....
   Kari Hurtta
   Charles Lindsey

QUESTION 3: Should the new type be a subtype of Message/?

A: Yes
   Harald Alvestrand
   Chris Newman (slight preference)
   John Klensin
   Yangwoo Ko
   Martin Duerst
   Kazunori Fujiwara
   Mao Wei
   Randall Gellens
   Tony Hansen
   Abel Yang
B: No, it should be application/something
C: I have another opinion, which is....
   Kari Hurtta
   Charles Lindsey

QUESTION 4: What should the new MIME type be called?

On this question, people tended to list "good" and "bad" names, with 
some left unmentioned. This is reflected in the reporting format; 
however, this format loses distinctions present in the original 
responses, such as preferences between the "good" types.

A: Message/utf8smtp
   Good: Martin Duerst, Kazunori Fujiwara, Charles Lindsey, Abel Yang
   Bad: Chris Newman, John Klensin
B: Message/i18n
   Good: Yangwoo Ko, Yao Jiankang, Tony Hansen
   Bad: Martin Duerst
C: Message/international
   Good: Chris Newman, Yangwoo Ko, Mao Wei, Randall Gellens, Tony Hansen,
        Jaeyoun Kim
   Bad: Martin Duerst
D: Message/global
   Good: Mao Wei, Randall Gellens, Yao Jiankang, Tony Hansen,
         Jaeyoun Kim
   Bad: Martin Duerst
E: Message/rfcxxxx (to be assigned)
   Bad: Chris Newman, John Klensin, Martin Duerst
F: Message/rfc822 (consistent with an "A" answer on question 1)
   Good: Kari Hurtta
   Bad: Chris Newman, John Klensin, Martin Duerst
G: Message/utf8
   Good: Chris Newman, Abel Yang
   Bad: John Klensin, Martin Duerst
H: Message/rfc822u
   Good: Martin Duerst
   Bad: Chris Newman, John Klensin
I: Message/mail
   Good: John Klensin, Martin Duerst, Randall Gellens
J: Message/i18n-email
   Good: Yangwoo Ko, Martin Duerst, Charles Lindsey, Yao Jiankang
K: Message/eai
   Good: Yangwoo Ko, Martin Duerst, Kazunori Fujiwara, Tony Hansen,
         Abel Yang
L: Message/smtp
   Bad: Chris Newman, John Klensin, Martin Duerst
M: Message/smtp8
   Good: Martin Duerst
   Bad: Chris Newman, John Klensin
N: Message/utf8eai
   Good: Martin Duerst, Kari Hurtta, Yao Jiankang, Abel Yang
O: Message/utf8-headers
   Good: Martin Duerst, Charles Lindsey
   Bad: Chris Newman, John Klensin
P: Message/utf8-email
   Good: Martin Duerst, Kari Hurtta, Jaeyoun Kim
Q: Message/ima
   Good: Yangwoo Ko, Martin Duerst
R: Message/intl-email
   Good: Martin Duerst, Mao Wei, Charles Lindsey
S: I have another opinion, which is....
   Kari Hurtta (application/utf8-email, message-eai-email,
                application/eai-email)
   Yao Jiankang (message/i-address)

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 27 Jun 2007 16:09:28 -0400

> carried inside messages in an UTF8SMTP environment?

"B", yes

> requiring the 8BITMIME extension)?

"A", yes

> QUESTION 3: Should the new type be a subtype of Message/?

"A", yes

> QUESTION 4: What should the new MIME type be called?

Given the arguments I have seen, I now don't care.  My guess is that
anyone who cares is going to have to end up looking in the Fine
Manual anyway. 

A

-- 
----
Andrew Sullivan                         204-4141 Yonge Street
Afilias Canada                        Toronto, Ontario Canada
<[email-masked]>                              M2P 2A8
                                        +1 416 646 3304 x4110