Subject: Re:[EAI] POLL: on the "what MIME type" question

From: "MAO Wei" <[email-masked]>
Date: Mon, 25 Jun 2007 18:41:53 +0800

>From: Harald Alvestrand <[email-masked]>
>Reply-To: 
>To: EAI WG <[email-masked]>
>Subject: [EAI] POLL: on the "what MIME type" question
>Date:Fri, 22 Jun 2007 08:15:49 +0200
>
>This is a poll to determine if there is a WG consensus on the various 
> issues surrounding the MIME type for carrying UTF8SMTP messages.
> 
> To reply to the poll, send a message to the list, or to both WG chairs, 
> before JUNE 29, 2007, 12:00 GMT. The chairs will tally the responses and 
> report the results; names of respondents will be included in the tally.
> 
> This poll asks questions about the carriage of messages that make use of
> the extensions described in draft-ietf-eai-utf8hdrs, when they are part 
> of another message. In the text below, we call them UTF8SMTP messages, 
> without prejudice to what we end up naming them.
> 
> The questions below are not unrelated; the poll is intended to show 
> strong preferences, it is not a replacement for informed debate.
> 
> QUESTION 1: Should there be a new MIME type for UTF8SMTP messages when
> carried inside messages in an UTF8SMTP environment?
> 
> A: No, message/rfc822 can be used.
> B: Yes.
> C: I have another opinion, which is....

B

> 
> QUESTION 2: Should the same MIME type be used to carry UTF8SMTP messages in
> a SMTP environment (without the UTF8SMTP extension, and without requiring
> the 8BITMIME extension)?
> This implies that it's possible to encode the message.
> 
> A: Yes.
> B: No, that should not be allowed.
> C: I have another opinion, which is....

A

> 
> QUESTION 3: Should the new type be a subtype of Message/?
> 
> A: Yes
> B: No, it should be application/something
> C: I have another opinion, which is....

A

> 
> QUESTION 4: What should the new MIME type be called?
> 
> A: Message/utf8smtp
> B: Message/i18n
> C: Message/international
> D: Message/global
> E: Message/rfcxxxx (to be assigned)
> F: Message/rfc822 (consistent with an "A" answer on question 1)
> G: Message/utf8
> H: Message/rfc822u
> I: Message/mail
> J: Message/i18n-email
> K: Message/eai
> L: Message/smtp
> M: Message/smtp8
> N: Message/utf8eai
> O: Message/utf8-headers
> P: Message/utf8-email
> Q: Message/ima
> R: Message/intl-email
> S: I have another opinion, which is....

C, D or R

> 
> 
> _______________________________________________
> EAI-DT mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/eai-dt
> 
> 
> 
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ima
>

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: "YAO Jiankang" <[email-masked]>
Date: Tue, 26 Jun 2007 16:10:50 +0800

----- Original Message ----- 
From: "Harald Alvestrand" <[email-masked]>
To: "EAI WG" <[email-masked]>
Sent: Friday, June 22, 2007 2:15 PM
Subject: [EAI] POLL: on the "what MIME type" question

> C: I have another opinion, which is....

B.

> C: I have another opinion, which is....

A.

> C: I have another opinion, which is....
Bothe A and B are ok for me.

> S: I have another opinion, which is....

I prefer D and N. 
B J S are also ok .

S: Message/i-address   (internationalized address)

YAO Jiankang