Subject: [EAI] Re: [ietf-dkim] Jim's issues - one more try

From: "Charles Lindsey" <[email-masked]>
Date: Tue, 12 Jun 2007 13:52:04 +0100

On Tue, 12 Jun 2007 01:28:05 +0100, Douglas Otis <[email-masked]>  
wrote:

>   So when wildcard records are not used,
>   after receiving a message considered not signed:
>
>    - When neither an MX (or A) record are found, refuse the message.
>    - When an MX (or A) record are found, query for a policy record.
>    - When no policy is found, there is no policy. (Searching not  
> required.)
>    - When policy requires DKIM signatures, refuse the message.

That works for the domain that "never sends mail"
                                "never receives mail"

But what about the domain that receives, but never sends?

In that case you will publish several MX records (with assorted  
preferences) as usual. But then you also publish an extra MX record with a  
ridiculously low preference (99 say) which points to something  
unresolvable (e.g. nomail,invalid).

By convention, that means "sends no mail". So if you are a receiving site  
considering whether some message can be discarded, you just ask to see the  
MX records for the domain, and see if they include one pointing to  
nomail.invalid.

I reckone there would be no need then to depracate A records where |MX was  
absent, or anything like that.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Tue, 12 Jun 2007 15:02:27 +0200

Charles Lindsey writes:
> By convention, that means "sends no mail".

So could you please write an internet-draft summing up these conventions 
and get it published as RFC? You can hardly expect average IMA document 
readers to know about them. If they should have any influence on IMA 
documents, you'd better write them up as an RFC.

Arnt

---

From: John C Klensin <[email-masked]>
Date: Tue, 12 Jun 2007 13:13:05 -0400

Charles,

These comments seem appropriate as part of a discussion of DKIM, 
either on that WG list, or on Last Call of the DKIM overview 
document, or as a separate discussion, written up in an I-D in 
enough coherent detail that people can understand it.  There is 
nothing about them that seems unique to EAI -- other than that 
that DKIM doesn't address internationalization issues.

Please take it somewhere else.
    john

--On Tuesday, June 12, 2007 13:52 +0100 Charles Lindsey 
<[email-masked]> wrote:

> On Tue, 12 Jun 2007 01:28:05 +0100, Douglas Otis
> <[email-masked]> wrote:
>
>
>>    - When neither an MX (or A) record are found, refuse the
>>    message. - When an MX (or A) record are found, query for a
>>    policy record. - When no policy is found, there is no
>>    policy. (Searching not   required.)
> In that case you will publish several MX records (with
> assorted preferences) as usual. But then you also publish an
> extra MX record with a ridiculously low preference (99 say)
> which points to something unresolvable (e.g. nomail,invalid).
>
> By convention, that means "sends no mail". So if you are a
> receiving site considering whether some message can be
> discarded, you just ask to see the MX records for the domain,
> and see if they include one pointing to nomail.invalid.
>
> I reckone there would be no need then to depracate A records
> where |MX was absent, or anything like that.

---

From: "Charles Lindsey" <[email-masked]>
Date: Wed, 13 Jun 2007 11:46:27 +0100

> On Tue, 12 Jun 2007 01:28:05 +0100, Douglas Otis <[email-masked]>  

Oops! Wrong list. Sorry about that.