Subject: [EAI] POLL: on the "what MIME type" question

From: Harald Alvestrand <[email-masked]>
Date: Fri, 22 Jun 2007 08:15:49 +0200

This is a poll to determine if there is a WG consensus on the various 
issues surrounding the MIME type for carrying UTF8SMTP messages.

To reply to the poll, send a message to the list, or to both WG chairs, 
before JUNE 29, 2007, 12:00 GMT. The chairs will tally the responses and 
report the results; names of respondents will be included in the tally.

This poll asks questions about the carriage of messages that make use of
the extensions described in draft-ietf-eai-utf8hdrs, when they are part 
of another message. In the text below, we call them UTF8SMTP messages, 
without prejudice to what we end up naming them.

The questions below are not unrelated; the poll is intended to show 
strong preferences, it is not a replacement for informed debate.

QUESTION 1: Should there be a new MIME type for UTF8SMTP messages when
carried inside messages in an UTF8SMTP environment?

A: No, message/rfc822 can be used.
B: Yes.
C: I have another opinion, which is....

QUESTION 2: Should the same MIME type be used to carry UTF8SMTP messages in
a SMTP environment (without the UTF8SMTP extension, and without requiring
the 8BITMIME extension)?
This implies that it's possible to encode the message.

A: Yes.
B: No, that should not be allowed.
C: I have another opinion, which is....

QUESTION 3: Should the new type be a subtype of Message/?

A: Yes
B: No, it should be application/something
C: I have another opinion, which is....

QUESTION 4: What should the new MIME type be called?

A: Message/utf8smtp
B: Message/i18n
C: Message/international
D: Message/global
E: Message/rfcxxxx (to be assigned)
F: Message/rfc822 (consistent with an "A" answer on question 1)
G: Message/utf8
H: Message/rfc822u
I: Message/mail
J: Message/i18n-email
K: Message/eai
L: Message/smtp
M: Message/smtp8
N: Message/utf8eai
O: Message/utf8-headers
P: Message/utf8-email
Q: Message/ima
R: Message/intl-email
S: I have another opinion, which is....

_______________________________________________
EAI-DT mailing list
[email-masked]
http://www.alvestrand.no/mailman/listinfo/eai-dt

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Chris Newman <[email-masked]>
Date: Fri, 22 Jun 2007 12:20:20 -0700

> C: I have another opinion, which is....

B

> C: I have another opinion, which is....

A

> C: I have another opinion, which is....

Slight preference for A, no objection to B however.

> S: I have another opinion, which is....

I consider A, F, L, M, O technically flawed choices because the label is 
misleading.  I aesthetically dislike E, H.
Any other choice would be fine although I don't really like any of them.  If I 
had to choose one, I'd choose C with G a close second.

                - Chris

---

From: Tony Finch <[email-masked]>
Date: Fri, 22 Jun 2007 21:26:42 +0100

On Fri, 22 Jun 2007, Chris Newman wrote:
>
> If I had to choose one, I'd choose [message/international] with
> [message/utf8] a close second.

I agree with Chris's comments. How about the slightly punning
message/utf822?

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
MALIN HEBRIDES: NORTHERLY 4 OR 5, OCCASIONALLY 6. SLIGHT OR MODERATE. SHOWERS,
FOG PATCHES. MODERATE OR GOOD, OCCASIONALLY VERY POOR.

---

From: John C Klensin <[email-masked]>
Date: Fri, 22 Jun 2007 18:22:35 -0400

--On Friday, 22 June, 2007 08:15 +0200 Harald Alvestrand
<[email-masked]> wrote:

> The questions below are not unrelated; the poll is intended to
> show strong preferences, it is not a replacement for informed
> debate.
> 

B

> a SMTP environment (without the UTF8SMTP extension, and
> without requiring the 8BITMIME extension)?

A.  Not completely satisfactory, but all other options proposed
so far have been worse.

> C: I have another opinion, which is....

A.   I think that having it as an application/ subtype would
violate the principle of least astonishment and that, in the
long term, people would wonder why we took leave of our sanity.

> S: I have another opinion, which is....

I agree with Chris's "technically flawed" list.  I would add G
to that list: I believe that is technically flawed -- this is
about formats and mail handling, not about a character set, and
would introduce confusion with the charset parameter on
text/plain.  I also believe that G invites mischief.  Also like
Chris, I find E and H aesthetically unattractive (in part
because, while I understood the reasons -- which do not apply
here-- I believe that "message/rfc822" was a mistake the first
time around).

That leaves me with some preference for C or I although I'm not
wild about any of these.  I could easily live with D or some
contraction of "international" that is not on the list (e.g.,
message/intl).   

As I think more about it, the more appeal "I" has.  If one
performs the experiment of pretending to be some years in the
future, with this work widely deployed, message/mail would seem
fairly natural.  It conveys the impression that the
internationalized case is the normal one, with message/rfc822
being the restricted case for those poor backward types who
haven't caught up yet.  That, it seems to me, is exactly what we
want.  Message/mail also connects with some of my aesthetic
objection to many of the other ideas, which stress that this is
an extension rather than the [long-term] normal case.    On that
theory, if message/mail is problematic for some reason,
message/email or message/netmail or message/imail (for Internet
mail, not "international") would be alternatives in the same
spirit. (For those who don't know but still care, as Mike
Padlipsky regularly points out, "'netmail' is what we called
this stuff when we were inventing it".)

      john

---

From: Yangwoo Ko <[email-masked]>
Date: Sat, 23 Jun 2007 10:54:02 +0900

Harald Alvestrand wrote:
> To reply to the poll, send a message to the list, or to both WG 
> chairs, before JUNE 29, 2007, 12:00 GMT. The chairs will tally the 
> responses and report the results; names of respondents will be 
> included in the tally.
>
> the extensions described in draft-ietf-eai-utf8hdrs, when they are 
> part of another message. In the text below, we call them UTF8SMTP 
> messages, without prejudice to what we end up naming them.
>
B
A
A
> S: I have another opinion, which is....
C > (B or J) > (K,Q)

---

From: Martin Duerst <[email-masked]>
Date: Sat, 23 Jun 2007 11:48:04 +0900

At 15:15 07/06/22, Harald Alvestrand wrote:
>This is a poll to determine if there is a WG consensus on the various issues surrounding the MIME type for carrying UTF8SMTP messages.
>
>To reply to the poll, send a message to the list, or to both WG chairs, before JUNE 29, 2007, 12:00 GMT. The chairs will tally the responses and report the results; names of respondents will be included in the tally.
>
>the extensions described in draft-ietf-eai-utf8hdrs, when they are part of another message. In the text below, we call them UTF8SMTP messages, without prejudice to what we end up naming them.
>
>The questions below are not unrelated; the poll is intended to show strong preferences, it is not a replacement for informed debate.
>

I guess B, although I haven't studied this in full detail.

>C: I have another opinion, which is....

A, with same caveat as above.

>C: I have another opinion, which is....

A; B might also be acceptable.

>S: I have another opinion, which is....

Okay, with most preferred first: K, Q, I, J, N, O, P, A, H, M, R
Bad ideas: B, C, D, E, F, G, L

Regards,   Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Kari Hurtta <[email-masked]>
Date: 24 Jun 2007 22:23:59 +0300

> C: I have another opinion, which is....

0  -- No strong preferece, slighly A -- I think that it is used anyway

> C: I have another opinion, which is....

C   -- Depends what is MIME type to carry UTF8SMTP messages

       If type is message/rfc822, or new type is any message/*
       then B

       - Encoding of message/* conflicts with RFC 2045
         (it is not possible to encode message)

       If UTF8SMTP message does not actually include UTF8SMTP 
       addresses, it need to be downgraded.

       Using of any message/* for carrying  UTF8SMTP messages 
       in 8BITMIME or SMTP environment is too dangerous.

> C: I have another opinion, which is....

C -- No strong preference, can be subtype of Message/ inside of 
     UTF8SMTP environment

     Carefully selected application/* can be used, if name refers
     to email.

> S: I have another opinion, which is....

F, P, N

S: application/utf8-email 

S: Message/eai-email

S: application/eai-email

( somewhat in order -- not sure is utf8-email or eai-email better )

/ Kari Hurtta

---

From: [email-masked]
Date: Mon, 25 Jun 2007 18:38:21 +0900 (JST)

> From: Harald Alvestrand <[email-masked]>

B

A

A

> S: I have another opinion, which is....

I prefer A or K.

common nouns or words which have another meaning are not suitable for
identifiers, I think.

--
Kazunori Fujiwara, JPRS

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 25 Jun 2007 15:45:55 +0100

> without prejudice to what we end up naming them.

I must protest most strongly that we are being asked to choose netween two  
alternatives of which one has currently no clearly agreed technical  
description, making it impossible to make an informed choice between them.

> C: I have another opinion, which is....

A.

The only argument presented against A is that such messages might leak  
into the existing environment without being properly downgraded first.  
Leaks happen because standards have been accidentally violated, usually by  
unusual hand-written scripts which have not been implemented with the care  
expected when writing agents intended for widespread use.

The question that arises is whether introducing a message/utf8smtp will  
reduce the number of such 'accidents', bearing in mind that current agents  
and the expectations of script writers are unlikely to be aware of the new  
message type. For sure, the number of leaks will indeed be reduced, but  
will the proportion of leaks reduced be significant in comparison with the  
number that remain? Sufficiently so to justify the introduction of the new  
type?

> C: I have another opinion, which is....

C. It depends on how well such messages will be propagated intact within  
the present network. This is no problem if the answer to Q3 is 'B', but  
otherwise it appears to be the case that NO current MTA will downgrade  
them from 8bit to Q-P or to Base64 (I have repeatedly asked for a SINGLE  
example of a current MTA that would do so, but none has been forthcoming,  
whereas several current MTAs with significant current usage that will not  
do so have been reported - notably sendmail).

If it were already the case that many/most MTAs already handled this case,  
then the implied violation of that EXPRESSLY FORBIDDEN in RFC 2045 could  
perhaps be overlooked; but apparently that is NOT the case.

Therefore, the only possible answer to this question is 'A' if the answer  
to Q1 is 'A', and 'B' if it is not.

Alternatively we could state explicitly that this new message type was not  
expected to propagate through non-8BITMIME environments (as seems to be  
suggested in the latest DSN draft); but that is outwith the scope of the  
question as asked.

> C: I have another opinion, which is....

C. 'A' if the answer to Q2 is 'B', otherwise 'B'.

But 'B' is ugly and counter-intuitive. And indeed the ugliness of 'B' is  
the best argument for not anwering 'A' to Q2.

> S: I have another opinion, which is....

Presumably if Q1 is anwered with 'A', then this Q4 is redundant.

Otherwise, it needs to include the word 'mail' plus either 'utf-8' or  
'international' (or variations on them such as 'email' - even 'smtp' - and  
'i18n').

So that restricts the choice to one of A, J, O, R, of which I prefer O  
(except that has been pre-empted by the new DSN draft - but that is  
fixable, and should have been a text type anyway).

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Randall Gellens <[email-masked]>
Date: Mon, 25 Jun 2007 17:00:00 -0700

B

>  C: I have another opinion, which is....

A (we can make an exception to permit encoding for this one subtype)

>  C: I have another opinion, which is....

A (anything else will be bizarre and unfortunate)

>  S: I have another opinion, which is....

Best of these is "I: Message/mail".

Also acceptable would be versions of "mail" as proposed by John.

I agree that we do not want to pick choices which contain "smtp" or 
"822" or "utf8".

Acceptable would be "D: Message/global" or "C: Message/international" 
although they seem awkward.
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
You may be only one person in the world,
but you may also be the world to one person.

---

From: Tony Hansen <[email-masked]>
Date: Tue, 26 Jun 2007 11:14:43 -0400

B

A

A

> S: I have another opinion, which is....

In order of preference:

D, K, C, B

Whatever we choose will be a compromise.

	Tony Hansen
	[email-masked]

---

From: "Jaeyoun Kim" <[email-masked]>
Date: Wed, 27 Jun 2007 13:26:42 +0900

Please see below.

B

A

> S: I have another opinion, which is....

C, D, or P

Regards,
Jaeyoun Kim

-- 
-----------------------------------
Jaeyoun Kim (Peter)
Manager of .kr SRS, NIDA (National Internet Development Agency of Korea)
Email: [email-masked] / Skype: kimjaeyoun
-----------------------------------

---

From: "abel" <[email-masked]>
Date: Wed, 27 Jun 2007 14:37:07 +0800

----- Original Message ----- 
From: "Harald Alvestrand" <[email-masked]>
To: "EAI WG" <[email-masked]>
Sent: Friday, June 22, 2007 2:15 PM
Subject: [EAI] POLL: on the "what MIME type" question

B
A
A
> S: I have another opinion, which is....

A>G>K>N

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 28 Jun 2007 09:07:53 +0200

>C: I have another opinion, which is....

B.

A.

A.

>S: I have another opinion, which is....

Good: I (mail), Q (ima), K (eai) (in that order)

Bad: A, B, C, D, G, J, L, M, N, O, P

Can live with: E (rfcxxxx), F (rfc822), H (rfc822u), R (int-email).
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Weinh. Str. 22 · Telefon: +49(0)621/4309674 · http://www.bjoernsworld.de
68309 Mannheim · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Yoshiro YONEYA <[email-masked]>
Date: Fri, 29 Jun 2007 20:25:01 +0900

B

A

A

> S: I have another opinion, which is....

P > R > J

-- 
Yoshiro YONEYA <[email-masked]>