Subject: Re: [EAI] I-D Action: draft-ietf-eai-rfc5336bis-10.txt

From: Shawn Steele <[email-masked]>
Date: Fri, 3 Jun 2011 21:06:00 +0000

> An EAI-aware MUA/MSA sending to a legacy SMTP server  and may convert an
> ASCII@U-label  address into the format of ASCII@A-label if the email address
> is in the format of ASCII@U-label.

I think this is extraneous and not necessary.

I think we mentioned before that when EAI-aware servers are communicating with legacy SMTP servers, then the EAI standards no longer apply.  Then the legacy SMTP RFCs apply.  The IDN RFCs are already clear about that happens to U-Labels in an ASCII environment, so this isn't necessary.

Also, with a "strict" interpretation of the legacy SMTP behavior, the EAI RFCs wouldn't apply, which would include this RFC and any of this language within it.

Eg: Legacy SMTP + IDN "works fine" regardless of these RFCs.  Nothing we add here will help or hinder that.  *IF* we want to address this type of thing, then it should go into a separate document about mitigating the legacy compatibility issues.  (Eg: alternate routes, try different addresses, etc.)

-=Shawn

---

From: Dave CROCKER <[email-masked]>
Date: Sat, 04 Jun 2011 08:49:15 -0700

On 6/3/2011 2:06 PM, Shawn Steele wrote:
>> ASCII@U-label  address into the format of ASCII@A-label if the email
>> address is in the format of ASCII@U-label.
>
> I think we mentioned before that when EAI-aware servers are communicating
> with legacy SMTP servers, then the EAI standards no longer apply.

Oh.  Right.

I completely missed that the conversion issue is appropriate for gateways 
between UTF-8 and ASCII environments, but no longer is needed for the current 
specifications, because the current specifications require a UTF8-clean 
environment, end-to-end.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net