Subject: [EAI] Consensus Result - trace fields and RFC5336bis

From: Joseph Yee <[email-masked]>
Date: Mon, 4 Jul 2011 06:01:44 -0400

All,

Following discussion, the WG agreed that message under SMTP without the EAI parameter at MAIL FROM must conform to RFC5321 regardless the server's capability.  Trace field values must conform to RFC5321, whether it's an initial submission or relay.

For message under SMTP with EAI parameter at MAIL FROM, an EAI-capable client SHOULD send messages what require EAI functionality in UTF-8 form to servers that do support EAI functionality.  Trace field values (the domain name) in the "from" clause of "Received:" should use U-label.

The exact wording will be determined by editors of RFC5336bis, with help from everyone in the WG.  The principle text derived during discussion can be served as guideline:

	An EAI-capable client MUST either be able to send a
	5321-conformant message to a non-EAI-capable server or
	MUST reject or return the message.  Only the second is
	plausible in the absence of downgrading facilities if
	the message requires EAI capabilities.
	
	An EAI-capable client SHOULD send messages what require
	EAI functionality in UTF-8 form to servers that do
	support EAI functionality.

Last Call announcement will follow very soon once the revision published.  

[
Note:

I leave out whether MTA can drop or promote the EAI parameter.  This is an implementation issue (as mentioned by John Levine and Ned Freed) and not scope of RFC5336bis.  Personally I believed that it would be good to say something like "It's up to the MTA but iff the message is all ASCII"  but don't go into details .  An advise (informational) doc, or BCP, or AS doc would be the best place to discuss such in details.  Open to WG's suggestion.

]

If you believed that there are any issues not covered that could change the consensus result, please post as soon as possible.  I will post a revised result at July 5, 23:59 US Eastern if necessary.  Thanks.

Regards,
Joseph Yee, co-chair of EAI

---

From: health yao <[email-masked]>
Date: Mon, 4 Jul 2011 20:47:09 +0800

Thanks for your result.

Based on your result,
I propose the followin text to 3.7.3 of rfc5336bis:

----------------------------------------------
3.7.3.  Trace Information

   The trace information <Return-path-line>, <Time-stamp-line> and their
   related rules have been defined in in section 4.4 of RFC 5321
   [RFC5321].  This document has updated <Mailbox> and <Domain> to
   support non-ASCII characters.  So Return-path-line may include the
   'Reverse-path' clause where internationalized domain name with the
   U-label form may be used.  Time-stamp-line may include the 'Stamp'
   clause where the internationalized domain name with the U-label form
   may be used.

  If the message including the trace field values are sent by the
EAI-aware SMTP client or relay server without the EAI parameter at
MAIL command, they MUST conform to RFC5321 regardless the server's
capability.

If the message including trace field values are sent by the  EAI-aware
 SMTP client or relay server with the EAI parameter at MAIL command,
trace field values in the "from" clause of "Received:" SHOULD use the
U-label form for the internationalized domain name.

An EAI-aware SMTP client MUST either be able to send a
RFC 5321-conformant message to a non-EAI-aware server or
MUST reject or return the message.  Only the second is
plausible in the absence of downgrading facilities if
the message requires EAI capabilities.

The protocol value of the 'WITH' clause
   when this extension is used is one of the UTF8SMTPbis values
   specified in the "IANA Considerations" section of this document.

----------------------------------------------------

Jiankang Yao

----- Original Message -----
From: "Joseph Yee" <[email-masked]>
To: <[email-masked]>
Sent: Monday, July 04, 2011 6:01 PM
Subject: [EAI] Consensus Result - trace fields and RFC5336bis

> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>