Subject: [EAI] Summary of issues and agenda for Quebec meeting

From: Joseph Yee <[email-masked]>
Date: Mon, 18 Jul 2011 19:19:20 -0400

Hi all,

Below is summary of issues the WG needs to address, and they will be agenda item for the Quebec meeting.  I will update the agenda after this email.  If anything missing, please reply to this thread and I will update as soon as possible.

(1) Allowing 8-bit or not to Message-ID (also IN-REPLY-TO field & REFERENCES field) in RFC5335bis

Recently the WG made a consensus to allow 8-bit in trace fields.  Message-ID is in similar situation that it value contain local value and domains.  The recent revision (-11) of RFC5335bis ABNF allows 8-bit in domain part.  

The WG need to review and determine whether Message-ID allows 8-bit fully, partially, or not allowing 8-bit.  And what's the impact (for example: mixed of non UTF8 capable mail client with UTF8 capable pop/imap server) of each option.

(2) ABNF in popimap-downgrade-display section 3

In IETF Beijing the WG agreed to adopt group syntax.  In the revision (-02) of popimap-downgrade-display, the ABNF syntax extends to "from", "resent-from", "sender" and "resent-sender" to allow group.  The syntax is not yet complete.

More notes documented in the draft's section 3.  Direct copy over for quick read:
	
  1.  RFC 5322 does not allow group syntax in From and Sender header
       fields.  Existing MUAs may become very confused when they see
       group syntax in originator fields.

   2.  Use of group syntax in this way will essentially make it
       impossible to reply to a message.

   3.  "Reply-To:" header field allows the group syntax in [RFC5322].
         Is it correct ?

   4.  The ABNF syntax here is not yet complete.

   5.  Should the document explicitly recommend the use of comments,
       possibly with encoded words, to document the original non-ASCII
       mailboxes?

Other items that are not issues but need review from WG

All recent active drafts
	- RFC5336bis-11 (SMTP Extension)
	- RFC5335bis-11 (Message Headers)
	- RFC5337bis-03 (DSN)
	- RFC5721bis-02 (POP3)
	- RFC5738bis-01 (IMAP)
	- draft-eai-popimap-downgrade-02

Review of the latest RFC5336bis, any issues before last call?

The current draft agenda is available at http://tools.ietf.org/wg/eai/agenda?item=agenda81.html
Will update the agenda text as soon as possible

Thanks
Joseph

---

From: [email-masked]
Date: Mon, 18 Jul 2011 19:35:03 -0700 (PDT)

> Below is summary of issues the WG needs to address, and they will be agenda
> item for the Quebec meeting.  I will update the agenda after this email.  If
> anything missing, please reply to this thread and I will update as soon as
> possible.

> Recently the WG made a consensus to allow 8-bit in trace fields.  Message-ID
> is in similar situation that it value contain local value and domains.  The
> recent revision (-11) of RFC5335bis ABNF allows 8-bit in domain part.

Not exactly. The latest revision does redefine dpart so 8-bit is allowed
in domains, but it also redefines message id syntax to use a new itext
rule that doesn't allow 8-bit. So the domains in addresses can contain
8-bit but the domains in message-ids do not.

My personal preference is to simply eliminate the redefinition ABNF and allow
8-bit in message-ids, but OTOH the ABNF involved isn't especially complex or
difficult to understand.

				Ned

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 19 Jul 2011 13:29:54 +0900

On 2011/07/19 8:19, Joseph Yee wrote:
> (1) Allowing 8-bit or not to Message-ID (also IN-REPLY-TO field&  REFERENCES field) in RFC5335bis
>

It says '8-bit' here, and not 'UTF-8'. Does this mean that any kind of 
8-bit is okay? Does that mean that 'UTF-8' is preferred, but not 
required? Or what else?

I'd of course personally prefer "UTF-8 only".

Regards,    Martin.

---

From: Joseph Yee <[email-masked]>
Date: Tue, 19 Jul 2011 09:56:47 -0400

Thanks for clarifying and correcting the issue.

Joseph

---

From: Joseph Yee <[email-masked]>
Date: Tue, 19 Jul 2011 09:58:45 -0400

On 2011-07-19, at 12:29 AM, Martin J. Dürst wrote:

> It says '8-bit' here, and not 'UTF-8'. Does this mean that any kind of 8-bit is okay? Does that mean that 'UTF-8' is preferred, but not required? Or what else?
> 

Hi Martin,

Sorry I'm a bit lax on terminology.  It is "UTF-8 only" when I'm referring "8-bit" above.

Joseph

---

From: Chris Newman <[email-masked]>
Date: Mon, 25 Jul 2011 10:48:56 -0400

I decided to investigate the impact to IMAP of these open issues.

> REFERENCES field) in RFC5335bis

The way we did uQuoted for 5738bis makes this not a problem -- the 
Message-ID field would simply be uQuoted in the IMAP envelope for this case.

> In IETF Beijing the WG agreed to adopt group syntax.  In the revision
> (-02) of popimap-downgrade-display, the ABNF syntax extends to "from",
> "resent-from", "sender" and "resent-sender" to allow group.  The syntax
> is not yet complete.

FYI, the base IMAP specification (RFC 3501) uses a generalized address 
model for the parsed IMAP envelope that implicitly allows group syntax in 
both From and Sender. While it's possible IMAP clients won't expect this, 
it's permitted by the IMAP ABNF.

		- Chris