Subject: Re: [EAI] Downgrading an EAI

From: Shawn Steele <[email-masked]>
Date: Wed, 23 Apr 2014 19:08:09 +0000

It's "by design" that EAI doesn't have a way to encode it a Unicode address in non-Unicode form.  Yes, many mail clients don't yet support EAI. (slowly getting there though).

Best practice is to currently resend with a known good ASCII address.  However note that both the Unicode addresses and ASCII addresses are expected to be "readable" (for some definitions of readable).

@microsoft.com and [email-masked] could both point to the same mailbox.

() for those of you that don’t have a Klingon font.  I can’t wait for the IT folks to let me have a Klingon alias ;-)

-Shawn

---

From: "Jiankang Yao" <[email-masked]>
Date: Thu, 24 Apr 2014 07:58:25 +0800

Some implementations have already supported that non-asciic mailbox and ascii box point to the same mailbox.

I think that it is good way. My English name and Chinese name both point to me.

Jiankang Yao

From: Shawn Steele
Date: 2014-04-24 03:08
To: [email-masked]
Subject: Re: [EAI] Downgrading an EAI
It's "by design" that EAI doesn't have a way to encode it a Unicode address in non-Unicode form.  Yes, many mail clients don't yet support EAI. (slowly getting there though).

 
 
-Shawn

---

From: Shawn Steele <[email-masked]>
Date: Thu, 24 Apr 2014 00:02:55 +0000

Since it started as a class problem, how about this for the class assignment?

Design a system where the mail client correlates the contacts ASCII and UTF-8 addresses so that when the sender gets an NDR because something didn’t know about SMTPUTF8, the client knows how to resend it to the ASCII address ;-)

-Shawn

From: Jiankang Yao [mailto:[email-masked]]
Sent: Wednesday, April 23, 2014 4:58 PM
To: Shawn Steele; ima
Subject: Re: Re: [EAI] Downgrading an EAI

________________________________
Jiankang Yao

From: Shawn Steele<mailto:[email-masked]>
Date: 2014-04-24 03:08
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [EAI] Downgrading an EAI

@microsoft.com<mailto:@microsoft.com> and [email-masked]<mailto:[email-masked]> could both point to the same mailbox.

-Shawn

---

From: "Jiankang Yao" <[email-masked]>
Date: Thu, 24 Apr 2014 10:37:24 +0800

Microsoft's outlook has a lot of users.
You can have more powerful voice about how to design the client.
EAI is waiting for the outlook since some servers have implemented EAI.
:)

Jiankang Yao

From: Shawn Steele
Date: 2014-04-24 08:02
To: yaojk; ima; [email-masked]
Subject: RE: Re: [EAI] Downgrading an EAI
Since it started as a class problem, how about this for the class assignment?

-Shawn

 

Jiankang Yao
 
From: Shawn Steele
Date: 2014-04-24 03:08
To: [email-masked]

 
 
-Shawn