Subject: Re: [EAI] ASCII tunneling hack standardization

From: Shawn Steele <[email-masked]>
Date: Fri, 1 Aug 2014 19:14:06 +0000

> I should probably note that the contexts where I chose just-send-utf8 weren't SMTP-related, but rather channels such as forwarding to |program.

If you're just talking to yourself or some tool or something, that seems appropriate.  I'd think that it would be "normal" to try to keep EAI addresses in Unicode.

The intent was spots like maybe an old database column that wasn't Unicode.  The reason to publish the technique would be in case that hack escaped the database or something.

-Shawn

---

From: John C Klensin <[email-masked]>
Date: Fri, 01 Aug 2014 16:05:44 -0400

--On Friday, 01 August, 2014 19:14 +0000 Shawn Steele
<[email-masked]> wrote:

> The intent was spots like maybe an old database column that
> wasn't Unicode.  The reason to publish the technique would be
> in case that hack escaped the database or something.

There, again, I think you would be better off with a lossless
and self-identifying encoding -- encoded words (probably with
Base64), Unicode code point escapes of one of the varieties
discussed in RFC 5137, or, while it doesn't identify the
underlying CCS, even %-encoding of octets.

   john

---

From: Shawn Steele <[email-masked]>
Date: Fri, 1 Aug 2014 20:21:10 +0000

It's pretty hard to self-identify if you don't have a mechanism to self-identify already.  For some slots your suggestions may already be legal and difficult to tell if they were intentional or should be decoded.  In that case xn-- is probably no worse than those (IMO).

-----Original Message-----
From: John C Klensin [mailto:[email-masked]] 
Sent: Friday, August 1, 2014 1:06 PM
To: Shawn Steele; [email-masked]
Subject: Re: [EAI] ASCII tunneling hack standardization

--On Friday, 01 August, 2014 19:14 +0000 Shawn Steele <[email-masked]> wrote:

> The intent was spots like maybe an old database column that wasn't 
> Unicode.  The reason to publish the technique would be in case that 
> hack escaped the database or something.

There, again, I think you would be better off with a lossless and self-identifying encoding -- encoded words (probably with Base64), Unicode code point escapes of one of the varieties discussed in RFC 5137, or, while it doesn't identify the underlying CCS, even %-encoding of octets.

   john