Subject: [Int-dir] Intdir telechat review of draft-ietf-httpbis-proxy-status-06

From: Benno Overeinder via Datatracker <[email-masked]>
Date: Tue, 24 Aug 2021 14:04:04 -0700

Reviewer: Benno Overeinder
Review result: Ready with Nits

Intdir Review draft-ietf-httpbis-proxy-status-06

I am an assigned INT directorate reviewer for
draft-ietf-httpbis-proxy-status-06.  These comments were written
primarily for the benefit of the Internet Area Directors.  Document
editors and shepherd(s) should treat these comments just like they
would treat comments from any other IETF contributors and resolve them
along with any other Last Call comments that have been received.  For
more details on the INT Directorate, see
https://datatracker.ietf.org/group/intdir/about/.

Overall I find the document to be well written and understandable.  I think the
draft is ready with nits for publication.

Section Abstract could provide a little more explanation, such as one
or two examples of how to use the error reporting (as explained in the
Introduction).

At the beginning of Section 2, should it be stated that Proxy-Status
HTTP Fields are only added to responses towards the user agent?  So
explicitly state that an intermediary only adds Proxy-Status HTTP
Field towards the user agent and not towards the origin server?  (It
is implied by the use of the word "response" of course and other text
in this section.)

In Section 2.1, the following paragraph is a bit confusing to me:

   Unless a Proxy Error Type specifies otherwise, the presences of error
   often, but not always, indicates that response was generated by the
   proxy, not the origin server or any other upstream server.  For
   example, a proxy might attempt to correct an error, or part of a
   response might be forwarded before the error is encountered.

I read the sentence "For example, a proxy might ..." as the situation
where the next intermediary will generate the error message.  Is that
correct?

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Aug 2021 11:25:56 +1000

Hi Benno,

Thanks for the review.

> On 25 Aug 2021, at 7:04 am, Benno Overeinder via Datatracker <[email-masked]> wrote:
> 

I don't think adding examples to the abstract is helpful.

> is implied by the use of the word "response" of course and other text

Proxy-Status is explicitly defined as a response field; this is how we denote that in HTTP.

> where the next intermediary will generate the error message.  Is that

Yes, that's not terribly clear. See:
  https://github.com/httpwg/http-extensions/commit/315bcc7f

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 26 Aug 2021 09:21:14 +0000

Thank you Benno for our intdir review. As you may have noticed, I have used your review to ballot on the IETF draft.

Regards

-éric

-----Original Message-----
From: Int-dir <[email-masked]> on behalf of Benno Overeinder via Datatracker <[email-masked]>
Reply-To: Benno Overeinder <[email-masked]>
Date: Tuesday, 24 August 2021 at 23:04
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Int-dir] Intdir telechat review of draft-ietf-httpbis-proxy-status-06

    _______________________________________________
    Int-dir mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/int-dir