Subject: [Ioam] Updated IOAM Proposed Charter

From: Tal Mizrahi <[email-masked]>
Date: Mon, 13 Feb 2017 14:48:21 +0000

Hi,

The charter draft has been updated based on the comments received on the last few days:
https://datatracker.ietf.org/doc/charter-ietf-ioam/

The main changes compared to the previous draft:

-          A few terminology and phrasing changes based on comments received on the list.

-          New text regarding the encapsulations that the working group will initially focus on.

-          Updated the text about consultation with other working groups.

-          New text about cooperation with other standard bodies.

Comments will be welcome.

Thanks,
Tal.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 13 Feb 2017 10:52:05 -0500

Maybe I am missing something, but it seems to me that issues such as 
ECMP and path MTU are not "domain" or "scope" specific.  That is why I 
had asked that reference to these issues be put into the lead paragraph.

Yours,
Joel

On 2/13/17 9:48 AM, Tal Mizrahi wrote:
> _______________________________________________
> Ioam mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ioam
>

---

From: Tal Mizrahi <[email-masked]>
Date: Tue, 14 Feb 2017 13:22:30 +0000

Hi Joel,

Point well taken. I would suggest to split the following paragraph into two paragraphs, one discussing the scope/domain, and the other discussing the "various challenges". Please let us know if that addresses your concern.

*  Scope of in-situ OAM operation. In-Situ OAM operations are defined for a
specific operational domain. In-situ OAM data-records are added and removed at
domain boundaries and updated by nodes within the in-situ OAM domain. Procedure
to deal with various challenges in packet forwarding and error handling such as
ECMP processing, path MTU and ICMP message handling when in-situ OAM is enabled
in an in-situ OAM domain.

Thanks,
Tal. 

>-----Original Message-----
>From: Joel M. Halpern [mailto:[email-masked]]
>Sent: Monday, February 13, 2017 5:52 PM
>To: Tal Mizrahi; [email-masked]
>Subject: [EXT] Re: [Ioam] Updated IOAM Proposed Charter
>
>External Email
>
>----------------------------------------------------------------------
>Maybe I am missing something, but it seems to me that issues such as ECMP and
>path MTU are not "domain" or "scope" specific.  That is why I had asked that
>reference to these issues be put into the lead paragraph.
>
>Yours,
>Joel
>

---

From: Tal Mizrahi <[email-masked]>
Date: Tue, 14 Feb 2017 14:26:24 +0000

Hi,

Another issue that was raised by Stephen:

>1) I'm sure there are good things one can do with such marking, but it is very

>unclear to me how this proposal doesn't also fall afoul of all the privacy

>downsides of the SPUD/PLUS proposal. My understanding of those privacy

>downsides was that any generic/extensible marking scheme (whether of packets

>or transport connections/flows) could easily be abused in many privacy

>unfriendly ways. Note that I'm not claiming there is IETF consensus on that but I

>do claim it was a significant issue for SPUD/PLUS and would like to know why

>(and hope) it is not an issue here. Can someone help me understand what's

>different here so we avoid that same kind of mega-debate?

To address this in the charter, I propose to add the following text to the list of items the WG will work on:

* Security aspects of in-situ OAM, including the potential vulnerabilities of integrating hop-by-hop information to en-route traffic, and measures that should be taken to mitigate them.

Again, comments will be welcome.

Cheers,
Tal.

From: Ioam [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Monday, February 13, 2017 4:48 PM
To: [email-masked]
Subject: [EXT] [Ioam] Updated IOAM Proposed Charter

External Email
________________________________
Hi,

Thanks,
Tal.

---

From: David Mozes <[email-masked]>
Date: Tue, 14 Feb 2017 14:51:25 +0000

Nvo3 ?

From: Ioam [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Tuesday, February 14, 2017 4:26 PM
To: Tal Mizrahi <[email-masked]>; [email-masked]; Stephen Farrell <[email-masked]>; Alvaro Retana (aretana) ([email-masked]) <[email-masked]>
Subject: Re: [Ioam] [EXT] Updated IOAM Proposed Charter

Hi,

Cheers,
Tal.

From: Ioam [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Monday, February 13, 2017 4:48 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [EXT] [Ioam] Updated IOAM Proposed Charter

External Email

Thanks,
Tal.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 14 Feb 2017 10:54:11 -0500

Making the challenges a separate bullet would help.  I might refer to 
challenges and constraints rather than just challenges.

Yours,
Joel