Subject: Re: [Iotops] Automatically connecting to stub networks...

From: "Templin (US), Fred L" <[email-masked]>
Date: Sat, 5 Dec 2020 00:46:29 +0000

Ted, the only aspects of OMNI you would need to see to grasp the concepts
are a quick scan of Sections 9.1.9 and 12.3 (approx. 1.25 total pages of text).

Basically, it imports DHCPv6 options into RS messages and asks the router
to send a “proxy DHCPv6-PD Solicit” to the DHCPv6 server on behalf of the
mobile node. After the router gets back the DHCPv6-PD Reply, it sends an
RA to the mobile node with the delegated prefix information.

This is something I suggested a long time ago, but that was before we had
the OMNI option concept. Now with the OMNI option, it can carry other
protocol information like DHCPv6 options just fine.

Fred

From: Ted Lemon [mailto:[email-masked]]
Sent: Friday, December 04, 2020 3:15 PM
To: Templin (US), Fred L <[email-masked]>
Cc: STARK, BARBARA H <[email-masked]>; Michael Richardson <[email-masked]>; Ole Trøan <[email-masked]>; 6MAN <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [Iotops] Automatically connecting to stub networks...

On Dec 4, 2020, at 6:12 PM, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
DHCPv6-PD fans, please have a look at the latest OMNI draft and see if it provides
the kind of prefix delegation services you would like to see for stub networks:

If you are extending DHCPv6-PD for OMNI, you should really do it as a separate document. OMNI is rather large, so making references to it isn’t ideal.

The only thing we need that isn’t specified anywhere is for the infrastructure router to add the prefix and destination to the routing infrastructure.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 4 Dec 2020 20:27:07 -0500

I can’t see that being useful for stub networks. The whole point of “stub” is to avoid complicated routing, since it’s not useful for a typical stub network. 

> On Dec 4, 2020, at 19:46, Templin (US), Fred L <[email-masked]> wrote:
> 
> 
> On Dec 4, 2020, at 6:12 PM, Templin (US), Fred L <[email-masked]> wrote: