Subject: RE: IPFC: Fibre Channel Management Framework Integration MIB requ est

From: "blumenau, steven" <[email-masked]>
Date: Fri, 5 Jan 2001 08:34:23 -0500

Kevin,
I have made the change and it will be in the next version.
Steve

> -----Original Message-----
> From: Kevin Gibbons [mailto:[email-masked]]
> Sent: Sunday, December 17, 2000 8:47 PM
> To: blumenau, steven
> Cc: [email-masked]'
> Subject: IPFC: Fibre Channel Management Framework Integration MIB
> request
> 
> 
> Steve,
> 	I would like to request a change to the Simple Name Server table
> indexing in the Fibre Channel Management Framework 
> Integration MIB for the
> next revision.  This is based on the discussions during the 
> IETF IP over FC
> WG meeting held on 12/12/00.
> 
> 	The change is to have the table index based on:
> 
>     INDEX { fcConnUnitId, fcConnUnitSnsPortName}
> 
> 	instead of:
> 
>     INDEX { fcConnUnitId, fcConnUnitSnsPortIndex,
>           fcConnUnitSnsPortIdentifier }
> 
> 	Since the fcConnUnitSnsPortName is guaranteed to be 
> unique by Fibre
> Channel standards for each entry in the name server, even 
> across multiple
> SANs, it lends itself well to being an index.
> 
> 	In attempting to implement the table, with the
> fcConnUnitSnsPortIndex and fcConnUnitSnsPortIdentifier, it can be a
> challenge.  When a port record is added, you do not know if 
> it previously
> had an index from a previous period it was present in the 
> SAN, unless the
> removed entries are maintained so the SnsPortName can be 
> compared to the new
> entry.  This is not a problem if you do not want to keep the 
> SnsPortIndex
> constant for a single device over time, but if you do not the 
> value of it is
> greatly diminished.
> 
> 	If the index of the table is on fcConnUnitSnsPortName, 
> the problem
> is eliminated.  All methods recommended for accessing the 
> table in the MIB
> are maintained, with access based on the fcConnUnitSnsPortName greatly
> eased.
> 
> 	Regards, Kevin
> 
> ------ Snipped from draft-ietf-ipfc-fcmgmt-int-mib-05.txt 
> ---------------
> 
> -- the Fibre Channel Simple Name Server table
> --
> -- The Fibre Channel Simple Name Server table contains an entry 
> -- for each device presently known to this connUnit. There will 
> -- not be any version on this since FC-GS3 does not define a 
> -- version today.
> --
> -- This table is accessed either directly if the management
> -- software has an index value or via GetNexts. The value of
> -- the indexes are not required to be contiguous. Each entry
> -- created in this table will be assigned an index. This
> -- relationship is kept persistent until the entry is removed
> -- from the table or the system is reset. The total number of
> -- entries are defined by the size of the table
> 
> fcConnUnitSnsMaxEntry OBJECT-TYPE
>     SYNTAX		Counter32
>     MAX-ACCESS  	read-only
>     STATUS  	current
>     DESCRIPTION
>          "The maximum number of entries in the table."
>     ::= { fcMgmtConfig 9 }
> Blumenau                                                    [Page 42]
> 
> INTERNET-DRAFT           FC Mgmt Integration MIB         Nov 24, 2000
> 
> fcConnUnitSnsTable OBJECT-TYPE
>     SYNTAX      	SEQUENCE OF FcConnUnitSnsEntry
>     MAX-ACCESS  	not-accessible
>     STATUS      	current
>     DESCRIPTION
>           "This table contains an entry for each object 
>            registered with this port in the switch."
>     ::= { fcMgmtSNS 1 }
> 
> fcConnUnitSnsEntry OBJECT-TYPE
>     SYNTAX      	fcConnUnitSnsEntry
>     MAX-ACCESS      not-accessible
>     STATUS      	current
>     DESCRIPTION
>           "The Simple Name Server table for the port 
>            represented by fcConnUnitSnsPortIndex ."
>     INDEX { fcConnUnitId, fcConnUnitSnsPortIndex,
>           fcConnUnitSnsPortIdentifier }
>     ::= { fcConnUnitSnsTable 1 }
> 
> fcConnUnitSnsEntry ::=
>     SEQUENCE {
>         fcConnUnitSnsId                OCTET STRING,
>         fcConnUnitSnsPortIndex         Counter32,
>         fcConnUnitSnsPortIdentifier    FcAddressId,
>         fcConnUnitSnsPortName          FcNameId,
>         fcConnUnitSnsNodeName          FcNameId,
>         fcConnUnitSnsClassOfSvc        OCTET STRING,
>         fcConnUnitSnsNodeIPAddress     OCTET STRING,
>         fcConnUnitSnsProcAssoc         OCTET STRING,
>         fcConnUnitSnsFC4Type           OCTET STRING,
>         fcConnUnitSnsPortType          OCTET STRING,
>         fcConnUnitSnsPortIPAddress     OCTET STRING,
>         fcConnUnitSnsFabricPortName    FcNameId,
>         fcConnUnitSnsHardAddress       FcAddressId,
>         fcConnUnitSnsSymbolicPortName  DisplayString, 
>         fcConnUnitSnsSymbolicNodeName  DisplayString
>      }
> 
> fcConnUnitSnsId OBJECT-TYPE
>     SYNTAX 		OCTET STRING (SIZE (16))
>     MAX-ACCESS 	read-only
>     STATUS 		current
>     DESCRIPTION
>           "The connUnitId of the connectivity unit
>            that contains this Name Server table."
>     ::= { fcConnUnitSnsEntry 1 }
> 
> fcConnUnitSnsPortIndex OBJECT-TYPE
>     SYNTAX      	Counter32
>     MAX-ACCESS      read-only
>     STATUS      	current
>     DESCRIPTION
>           "The physical port number of this SNS table entry.
>            Each physical port has an SNS table with 1-n entries
> 
> -----------------------------------------
> Kevin Gibbons
> Nishan Systems, Inc.
> (408) 519-3756
> [email-masked]
> ----------------------------------------- 
>

---

From: "Kevin Gibbons" <[email-masked]>
Date: Fri, 5 Jan 2001 09:10:11 -0800

Steve,
	thanks much.  The Fibre Channel Management Framework Integration MIB has
come a long way.  I look forward to seeing the next version.
	Regards, Kevin

-----Original Message-----
From: blumenau, steven [mailto:[email-masked]]
Sent: Friday, January 05, 2001 5:34 AM
To: Kevin Gibbons
Cc: [email-masked]'
Subject: RE: IPFC: Fibre Channel Management Framework Integration MIB
request

Kevin,