Subject: RE: Comments on fcmgmt 06

From: "blumenau, steven" <[email-masked]>
Date: Fri, 6 Apr 2001 22:25:02 -0400

how would you propose unsupported counters be identified.

> -----Original Message-----
> From: Les Lovett [mailto:[email-masked]]
> Sent: Friday, April 06, 2001 11:53 AM
> To: blumenau, steven
> Cc: [email-masked]'; [email-masked]'
> Subject: Comments on fcmgmt 06
> 
> 
> Regarding most recently published fcmgmt MIB, 
> draft-ietf-ipfc-fcmgmt-int-mib-06.txt
> Specifically - Port Statistics table
> All of the counters are defined as Counter64.
> The table's comment header says to set the most significant 
> bit to 1 if
> the counter is not supported. 
> 
> My opinion is - do not use bit 1 {high order bit} to indicate
> supported/not-supported. Instead use all 64 bits as a counter.
> 
> LesLovett
>

---

From: "Infante, Jon" <[email-masked]>
Date: Fri, 06 Apr 2001 20:08:40 -0700

FYI
In other FC documents, like FC-MI the HBAAPI annex, unsupported counters

are identified by setting all bits in the counter (-1).

Jon Infante
Emulex

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 9 Apr 2001 11:10:04 +0200

>>>>> blumenau, steven writes:

Steven> how would you propose unsupported counters be identified.

There is a general MIB rule: Objects that an implementation does not
support do not exist. You need a very good reason to invent something
new.

/js

-- 
Juergen Schoenwaelder      Technical University Braunschweig
<[email-masked]>  Dept. Operating Systems & Computer Networks
Phone: +49 531 391 3289    Bueltenweg 74/75, 38106 Braunschweig, Germany
Fax:   +49 531 391 5936    <URL:http://www.ibr.cs.tu-bs.de/~schoenw/>