Subject: RE: [ipfix-arch] Comments/questions on draft-ietf-ipfix-architecture-00.txt

From: "VENKATG" <[email-masked]>
Date: Mon, 11 Feb 2002 19:18:07 +0530

Hi,

This might have been discussed before, but i've not followed all the
past mails very closely, hence this question.

In the filw http://norseth.org/ietf/ipfix/draft-ietf-ipfix-data-00.txt

and under section 5 [ Information Elements ], there does not seem to be
any mention on the 'Version No' as one of the Information Elements.

Do we not need this ? I feel that this would be needed once we
use/extend the same frame-work for IPv6.

Regards - venkat

=======================================
Venkatraman G
Infosys Technologies Limited
Bangalore 
India-561229

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 11 Feb 2002 15:05:41 +0100

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 11 Feb 2002 15:11:26 +0100

Hi Venkat,

sorry, my previous email slipped to the outbox
before I entered my comments.

> use/extend the same frame-work for IPv6.

I completely agree. This is already part of the requirements.

Considering support for NAT-PTs (acting as gateways
between IPv4 and IPv6) we should also include and IE
for "virtual" or "modified" IP version Number.

    Juergen
-- 
Juergen Quittek     [email-masked]     Tel: +49 6221 90511-15
NEC Europe Ltd.,    Network Laboratories     Fax: +49 6221 90511-55
Adenauerplatz 6, 69115 Heidelberg, Germany   http://www.ccrle.nec.de

---

From: [email-masked]
Date: Mon, 11 Feb 2002 11:51:15 -0500

> for "virtual" or "modified" IP version Number.

	The virtual stuff is there. And as stated earlier,
	the version details are left for later. But version
	will some how be included.

---

From: [email-masked]
Date: Mon, 11 Feb 2002 11:48:31 -0500

Depends on how the address is encoded. If the
address family is included no version if needed.
If not, them we either need a version of the
IE itself can specify (e.g. SRC_ADDR_IPV4, SRC_ADDR_IPV6)

I left those details for later.

Paul