Subject: [ipfix-data] Comments on the data model - rewrites.

From: "Norseth, KC" <[email-masked]>
Date: Tue, 12 Feb 2002 10:02:10 -0500

Hi Reinaldo,
 
I sent the word format in a seperate doc.  I assume that you also want to
include 5.11.5?
 
K.C.

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Tuesday, February 12, 2002 7:52 AM
To: Norseth, KC; 'Juergen Quittek'; K.C. Norseth
Cc: data; Calato, Paul
Subject: RE: [ipfix-data] RE: [ipfix] Draft updates - Comments on the data
model 

Hello K.C.
 
The NAT part includes 5.11.6, 5.11.7, 5.11.8 and 5.11.9. Can you send me
both docs in word format?
 
thanks,
 
Reinaldo

-----Original Message-----
From: Norseth, KC [mailto:[email-masked]]
Sent: Tuesday, February 12, 2002 6:45 AM
To: Penno, Reinaldo [SC9:T327:EXCH]; 'Juergen Quittek'; K.C. Norseth
Cc: data; Calato, Paul
Subject: RE: [ipfix-data] RE: [ipfix] Draft updates - Comments on the data
model 

Hi Reinaldo,
 
sounds good.
 
5.12 - NAT
5.14.4 - Internal Queue Priority
5.10.1-2 - netmask
5.9.3-4 - ATM & Frame Relay
5.11.4 - VLAN.  (I duped VLAN, it is also 5.14.11), just make one.
 
Sorry on the URL down.  It has small bandwidth and unfortunately, if it
doesn't come back up on its own, It will be down until I can get to it this
afternoon. I can send anyone the drafts if they cannot access my url.  I
have the documents in both Word and Text format.
 
K.C.

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Tuesday, February 12, 2002 7:04 AM
To: Norseth, KC; 'Juergen Quittek'; K.C. Norseth
Cc: data; Calato, Paul
Subject: RE: [ipfix-data] RE: [ipfix] Draft updates - Comments on the data
model 

Hello K.C.
 
I cannot access the URL of the drafts anymore...
 
Anyway, I can work on the sections I commented on. The ones related to
NAT/Firewall/Cache/etc and 5.14.4, 5.10.1, 5.10.2, 5.9.3, 5.9.4. 5.11.4 and
I can come up the IEs for 802.1p. I believe Juergen already wrote some text
for NAT sections also.
 
regards,
 
Reinaldo

-----Original Message-----
From: Norseth, KC [mailto:[email-masked]]
Sent: Tuesday, February 12, 2002 5:47 AM
To: 'Juergen Quittek'; Penno, Reinaldo [SC9:T327:EXCH]; K.C. Norseth;
[email-masked]
Cc: data; Calato, Paul
Subject: RE: [ipfix-data] RE: [ipfix] Draft updates - Comments on the data
model 

There is a need to do some rewrite in the data, to make the source look like
one document.  Currently, the document is of 2 definit design styles.  If
someone can help with that, it would be great.  Just let me know what
section so we are not working on the same piece.  I will be focusing on this
myself.

K.C. 

|-----Original Message----- 
|From: Juergen Quittek [mailto:[email-masked]
<mailto:[email-masked]> ] 
|Sent: Tuesday, February 12, 2002 5:43 AM 
|To: Reinaldo Penno; K.C. Norseth; [email-masked] 
|Cc: data; Calato, Paul 
|Subject: [ipfix-data] RE: [ipfix] Draft updates - Comments on 
|the data model 
| 
| 
|--On 12 February 2002 00:18 -0800 Reinaldo Penno wrote: 
| 
|> 
|> Comments: 
|> 
|> First ol all, would you guys mind if I rewrite this whole section 
|> using the words "private side" and "public side" so we align our 
|> nomenclature to RFC2663? 
| 
|Why risking further inconsistencies? Just refer to RFC 2663. 
|All you want to introduce is well explained there. 
| 
|> 
|> Also, the subsection titles refer to "virtual" this and 
|that, but the 
|> IEs refer to "outside" and "inside". So, we need some unified 
|> terminology. I also think that using inside and outside can cause 
|> confusion since the exporter/collector does not know what's 
|inside and 
|> outside. See draft-iab-unsaf-considerations-01.html 
| 
|I still have problems with "virtual", "inside", and "outside". 
|This applies to firewalls and IPv4 NATs, but not to several 
|other boxes. Why not using more general terms, such as 
|"received" and "transmitted" or "original" and "modified". 
|These terms would apply to a wider range of boxes (what is 
|"inside" for a NAT-PT?). 
| 
|This would make the draft more independent from certain 
|NAT/firewall scenarios and would be understandable even for 
|people who do not care about NAT issues at all. 
| 
|Reinaldo, you talked about good writing. I think this includes 
|avoiding irrelevant information (while still remaining clearly 
|understandable). 
| 
|> other stuff. 
|> 
|[...] 
|> 
|> then in 5.11.18 and 5.11.9 
|> 
|> "The Destination Virtual IE contains the destination address of the 
|> flow/port as *received* by the Exporter" 
|> 
|> It should be *transmited* by the exporter, ie, you need an almost 
|> complete 5-tuple set of IEs for the private side and for the public 
|> side. 
| 
|You see, it already gets confusing. "received/original 
|destination" would have been a much better choice of term 
|compared to "virtual destination". 
| 
|    Juergen 
|-- 
|Juergen Quittek     [email-masked]     Tel: +49 6221 90511-15 
|NEC Europe Ltd.,    Network Laboratories     Fax: +49 6221 90511-55 
|Adenauerplatz 6, 69115 Heidelberg, Germany   http://www.ccrle.nec.de
<http://www.ccrle.nec.de>  
| 
| 
| 
|-- 
|Help        mailto:[email-masked]
<mailto:[email-masked]>  and say "help" 
|in message body 
|Unsubscribe mailto:[email-masked]
<mailto:[email-masked]>  and say 
|"unsubscribe ipfix" in message body 
|Archive     http://ipfix.doit.wisc.edu/archive/
<http://ipfix.doit.wisc.edu/archive/>  
|

---

From: "Reinaldo Penno"<[email-masked]>
Date: Tue, 12 Feb 2002 07:07:46 -0800

okay, I can get the VLAN stuff. 5.11.4 and 5.11.5.
 
regards,
 
Reinaldo

-----Original Message-----
From: Norseth, KC [mailto:[email-masked]]
Sent: Tuesday, February 12, 2002 7:02 AM
To: Penno, Reinaldo [SC9:T327:EXCH]
Cc: data
Subject: Comments on the data model - rewrites.

Hi Reinaldo,

K.C.

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Tuesday, February 12, 2002 7:52 AM
To: Norseth, KC; 'Juergen Quittek'; K.C. Norseth
Cc: data; Calato, Paul
Subject: RE: [ipfix-data] RE: [ipfix] Draft updates - Comments on the data
model 

Hello K.C.

thanks,
 
Reinaldo

-----Original Message-----
From: Norseth, KC [mailto:[email-masked]]
Sent: Tuesday, February 12, 2002 6:45 AM
To: Penno, Reinaldo [SC9:T327:EXCH]; 'Juergen Quittek'; K.C. Norseth
Cc: data; Calato, Paul
Subject: RE: [ipfix-data] RE: [ipfix] Draft updates - Comments on the data
model 

Hi Reinaldo,
 
sounds good.
 
5.12 - NAT

K.C.

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Tuesday, February 12, 2002 7:04 AM
To: Norseth, KC; 'Juergen Quittek'; K.C. Norseth
Cc: data; Calato, Paul
Subject: RE: [ipfix-data] RE: [ipfix] Draft updates - Comments on the data
model 

Hello K.C.

 
regards,
 
Reinaldo

-----Original Message-----
From: Norseth, KC [mailto:[email-masked]]
Sent: Tuesday, February 12, 2002 5:47 AM
To: 'Juergen Quittek'; Penno, Reinaldo [SC9:T327:EXCH]; K.C. Norseth;
[email-masked]
Cc: data; Calato, Paul

K.C. 

|From: Juergen Quittek [ mailto:[email-masked]