Subject: RE: [ipfix] WG process: a proposal

From: "Norseth, KC" <[email-masked]>
Date: Wed, 13 Feb 2002 17:51:15 -0500

Sounds great.  I would like to be on the team.  

I have been working on a comparitive analysis on the docs, section by
section.  This could be of help in the merge process.  I could get that out
tonight if wanted.  Each set of documents have strong features and weak
features that together would form a solid document.

K.C.

|-----Original Message-----
|From: Nevil Brownlee [mailto:[email-masked]] 
|Sent: Wednesday, February 13, 2002 3:23 PM
|To: [email-masked]
|Cc: [email-masked]; [email-masked]; [email-masked]; 
[email-masked]; [email-masked]
|Subject: [ipfix] WG process: a proposal
|
|
|
|Hello all:
|
|Various people have been asking for some direction from the WG chairs 
|as to where we're heading with the two current documents.  
|After some discussion between Dave and myself, I'd like to 
|suggest the following:
|
|A: Background
|
|1) At the Salt Lake City IETF we called for volunteers to work on
|   the two IPFIX documents, as set out in the WG charter.  About
|   20 people volunteered.
|
|2) After an initial flurry of discussion on the IPFIX list, things
|   went quiet.  We set up some extra sub-lists to help the design
|   team members get some initial discussions going.
|
|3) KC Norseth stepped forward and posted some skeleton documents.
|   These were simply lists of section headings based on the
|   'IPFIX requirements' document.
|
|4) KC also proposed a design teleconference.  That idea was
|   welcomed, and the conference was scheduled for 31 January.
|
|5) At that point a group from Cisco, led by Benoit and Ganesh,
|   came forward with a much more complete document, which they
|   published as an individual Internet draft, so everyone could
|   read it and comment.  This was a very considerable contribution
|   to the WG.
|
|6) The teleconference was held, with many people participating.
|   Minutes were posted on the list.  Since then there has been
|   a *lot* of discussion on the list and sublists.  Many people
|   (including those from Cisco) have contributed text, which KC
|   has edited together to form a second document.  This will
|   shortly be published as a second individual draft.
|
|7) We now have two documents, each with lots of worthwhile material
|   in them.  I suspect there is a feeling that these are, somehow,
|   competing proposals - this is not the case.  Both are serious
|   contributions to the WG effort.
|
|B: What next?
|
|From the WG co-chairs point of view, any documents being 
|produced as WG drafts need to be the result of open discussion 
|in the WG, i.e. on its mailing list.  The co-chairs' role is 
|to facilitate discussion, 
|and to guide it towards actually delivering documents as per 
|the WG's charter goals.  Decisions about the technical merit 
|of text in various sections of the document needs to be 
|decided by consensus on the list.
|
|Ideally, we'd like to get to the next IETF meeting (Minneapolis in 
|March) with a single document to review / discuss / amend.  So 
|how can we achieve that?
|
|I propose that
|
|1) We form a small 'editorial' team, with two people from those
|   working on each of the two current documents (4 altogether).
|
|2) We ask the editorial team to merge the documents together,
|   and publish the resulting document(s) as IPFX WG drafts.
|
|3) The members of the design team - i.e. all those who've contributed
|   text to the drafts - will be listed in the 'Acknowledgements'
|   section of all drafts produced. The editors of each document
|   will appear as the document authors.
|
|4) Watching the mailing list discussion, this is starting to 
|   happen as a natural development anyway.  Agreeing to proceed
|   in this way would simply introduce a little formality to it,
|   and make the process clear to everyone.
|
|One other comment. This WG has certainly generated plenty of 
|interesting discussion on its mailing list.  It's clear that 
|all those involved are putting a lot of effort into our goal 
|of producing the best 
|technical solutions.  Thanks all round.
|
|I'd like comments / feedback on this notion from all 
|concerned, please. In particular, if we can agree to proceed 
|in this way, we need to decide who's on the editorial team ...
|
|Cheers, Nevil
|
|+---------------------------------------------------------------------+
|| Nevil Brownlee                     Director, Technology Development |
|| Phone: +64 9 373 7599 x8941        ITSS, The University of Auckland |
||   FAX: +64 9 373 7021      Private Bag 92019, Auckland, New Zealand |
|+---------------------------------------------------------------------P
|
|
|--
|Help        mailto:[email-masked] and say "help" 
|in message body
|Unsubscribe mailto:[email-masked] and say 
|"unsubscribe ipfix" in message body
|Archive     http://ipfix.doit.wisc.edu/archive/
|

---

From: "Reinaldo Penno"<[email-masked]>
Date: Wed, 13 Feb 2002 15:55:08 -0800

I agree with this.

I would prefer to be on the IPfix architecture editorial team.

regards,

Reinaldo

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Wednesday, February 13, 2002 2:36 PM
>To: Nevil Brownlee
>Cc: [email-masked]; [email-masked]; [email-masked];
>[email-masked]; [email-masked]
>Subject: Re: [ipfix] WG process: a proposal
>
>
>
>Fine with me. 
>
>I have strong interest in being on the
>data document's editorial team.
>
>Paul
>
>Nevil Brownlee wrote:
>> 
>> Hello all:
>> 
>> Various people have been asking for some direction from the WG chairs
>> as to where we're heading with the two current documents.  After some
>> discussion between Dave and myself, I'd like to suggest the 
>following:
>> 
>> A: Background
>> 
>> 1) At the Salt Lake City IETF we called for volunteers to work on
>>    the two IPFIX documents, as set out in the WG charter.  About
>>    20 people volunteered.
>> 
>> 2) After an initial flurry of discussion on the IPFIX list, things
>>    went quiet.  We set up some extra sub-lists to help the design
>>    team members get some initial discussions going.
>> 
>> 3) KC Norseth stepped forward and posted some skeleton documents.
>>    These were simply lists of section headings based on the
>>    'IPFIX requirements' document.
>> 
>> 4) KC also proposed a design teleconference.  That idea was
>>    welcomed, and the conference was scheduled for 31 January.
>> 
>> 5) At that point a group from Cisco, led by Benoit and Ganesh,
>>    came forward with a much more complete document, which they
>>    published as an individual Internet draft, so everyone could
>>    read it and comment.  This was a very considerable contribution
>>    to the WG.
>> 
>> 6) The teleconference was held, with many people participating.
>>    Minutes were posted on the list.  Since then there has been
>>    a *lot* of discussion on the list and sublists.  Many people
>>    (including those from Cisco) have contributed text, which KC
>>    has edited together to form a second document.  This will
>>    shortly be published as a second individual draft.
>> 
>> 7) We now have two documents, each with lots of worthwhile material
>>    in them.  I suspect there is a feeling that these are, somehow,
>>    competing proposals - this is not the case.  Both are serious
>>    contributions to the WG effort.
>> 
>> B: What next?
>> 
>> From the WG co-chairs point of view, any documents being produced as
>> WG drafts need to be the result of open discussion in the WG, i.e. on
>> its mailing list.  The co-chairs' role is to facilitate discussion,
>> and to guide it towards actually delivering documents as per the WG's
>> charter goals.  Decisions about the technical merit of text 
>in various
>> sections of the document needs to be decided by consensus on 
>the list.
>> 
>> Ideally, we'd like to get to the next IETF meeting (Minneapolis in
>> March) with a single document to review / discuss / amend.  So how
>> can we achieve that?
>> 
>> I propose that
>> 
>> 1) We form a small 'editorial' team, with two people from those
>>    working on each of the two current documents (4 altogether).
>> 
>> 2) We ask the editorial team to merge the documents together,
>>    and publish the resulting document(s) as IPFX WG drafts.
>> 
>> 3) The members of the design team - i.e. all those who've contributed
>>    text to the drafts - will be listed in the 'Acknowledgements'
>>    section of all drafts produced. The editors of each document
>>    will appear as the document authors.
>> 
>> 4) Watching the mailing list discussion, this is starting to
>>    happen as a natural development anyway.  Agreeing to proceed
>>    in this way would simply introduce a little formality to it,
>>    and make the process clear to everyone.
>> 
>> One other comment. This WG has certainly generated plenty of 
>interesting
>> discussion on its mailing list.  It's clear that all those involved
>> are putting a lot of effort into our goal of producing the best
>> technical solutions.  Thanks all round.
>> 
>> I'd like comments / feedback on this notion from all 
>concerned, please.
>> In particular, if we can agree to proceed in this way, we need to
>> decide who's on the editorial team ...
>> 
>> Cheers, Nevil
>> 
>> 
>+---------------------------------------------------------------------+
>> | Nevil Brownlee                     Director, Technology 
>Development |
>> | Phone: +64 9 373 7599 x8941        ITSS, The University of 
>Auckland |
>> |   FAX: +64 9 373 7021      Private Bag 92019, Auckland, 
>New Zealand |
>> 
>+---------------------------------------------------------------------P
>> 
>> --
>> Help        mailto:[email-masked] and say 
>"help" in message body
>> Unsubscribe mailto:[email-masked] and say
>> "unsubscribe ipfix" in message body
>> Archive     http://ipfix.doit.wisc.edu/archive/
>
>--
>Help        mailto:[email-masked] and say "help" 
>in message body
>Unsubscribe mailto:[email-masked] and say
>"unsubscribe ipfix" in message body
>Archive     http://ipfix.doit.wisc.edu/archive/
>

---

From: <[email-masked]>
Date: Thu, 14 Feb 2002 06:41:14 -0500

I want to part of editorial team
regards
ramg

>From: ext Nevil Brownlee [mailto:[email-masked]]
>Sent: Wednesday, February 13, 2002 5:23 PM
>To: [email-masked]
>Cc: [email-masked]; [email-masked]; [email-masked];
>[email-masked]; [email-masked]
>Subject: [ipfix] WG process: a proposal
>
>
>
>Hello all:
>
>discussion between Dave and myself, I'd like to suggest the following:
>
>A: Background
>
>charter goals.  Decisions about the technical merit of text in various
>sections of the document needs to be decided by consensus on the list.
>
>I'd like comments / feedback on this notion from all concerned, please.
>| Nevil Brownlee                     Director, Technology Development |
>| Phone: +64 9 373 7599 x8941        ITSS, The University of Auckland |
>|   FAX: +64 9 373 7021      Private Bag 92019, Auckland, New Zealand |

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: <[email-masked]>
Date: Thu, 14 Feb 2002 06:42:38 -0500

I want to be part of editorial team for architecture document
regards
ramg

---

From: <[email-masked]>
Date: Thu, 14 Feb 2002 06:51:09 -0500

Sorry, email is slipped twice before i completed the email.

I want to be part of editorial team for architecture and data model documents.
See my  inline comments

>decide who's on the editorial team ...

I agree with your suggestions since there may be more voluteers for this 
activity also how do we restrict the editorial team size.
regards
ramg

---

From: "Kevin Zhang" <[email-masked]>
Date: Thu, 14 Feb 2002 09:21:51 -0500

RE: [ipfix] WG process: a proposalMy original message got bounced back.  See
below.

Kevin
  -----Original Message-----
  From: Kevin Zhang [mailto:[email-masked]]
  Sent: Wednesday, February 13, 2002 6:09 PM
  To: Norseth, KC; 'Nevil Brownlee'; [email-masked]
  Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; K.C. Norseth
  Subject: RE: [ipfix] WG process: a proposal

  Hi all,

  I have strong interest to be on the architecture editorial team.

  Thanks,

  Kevin
    -----Original Message-----
    From: majordomo listserver [mailto:[email-masked]]On Behalf
Of Norseth, KC
    Sent: Wednesday, February 13, 2002 5:51 PM
    To: 'Nevil Brownlee'; [email-masked]
    Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; K.C. Norseth; Norseth, KC
    Subject: RE: [ipfix] WG process: a proposal

    K.C.

---

From: "Norseth, KC" <[email-masked]>
Date: Thu, 14 Feb 2002 14:59:10 -0500

I am not the only one with significant inputs.  One of my responsibilities
on the design team was to combine the work of the contributers into the team
draft.  Everyone who has volunteered to be on the review team has
contributed major sections to the team drafts.  Their input has been
valueable and extensive.

K.C.

|-----Original Message-----
|From: Peram Marimuthu [mailto:[email-masked]] 
|Sent: Thursday, February 14, 2002 12:03 PM
|To: Juergen Quittek
|Cc: Nevil Brownlee; [email-masked]; 
[email-masked]; [email-masked]; [email-masked]; 
[email-masked]
|Subject: Re: [ipfix] WG process: a proposal
|
|
|Juergen,
|
|I dont believe this is what Nevil/Dave wanted. If I read the 
|message correctly, Nevil was suggesting respresentation from 
|draft-gsadasiv and the other draft that KC is putting together equally.
|
|My recommendation is to form a team only with people with 
|significant inputs into the documents - Not just people that 
|can say "I am interested" three times. I would recommend 
|keeping the three editors - KC, Ganesh and Benoit as the 
|editors of the current combined draft. As people start 
|contributing significantly to the outcome of the combined 
|draft, they join the editorial team.
|
|Peram
|
|Juergen Quittek wrote:
|
|> Nevil and Dave,
|>
|> You suggested a editor team of 4, but now we have 6
|> volunteers: Paul, KC, Reinaldo, Ram, Kevin and me.
|>
|> I am sure that all of us are well motivated and capable
|> of doing a good job. Therefore, selecting just 4 might 
|disappoint one 
|> or the other.
|>
|> Therefore I suggest taking all 6 instead of 4
|> and dividing us into two groups of 3,
|> one for each document.
|>
|> However you decide, please decide soon, because we just
|> have one week left and there is still a lot of work ahead.
|> We need to arrange phone conferences, distribute the work
|> and come up with the documents until next Friday.
|>
|> Cheers,
|>
|>     Juergen
|>
|> --On 14 February 2002 11:23 +1300 Nevil Brownlee 
|> <[email-masked]> wrote:
|>
|> >
|> > Hello all:
|> >
|> > Various people have been asking for some direction from the WG 
|> > chairs as to where we're heading with the two current documents.  
|> > After some discussion between Dave and myself, I'd like to suggest 
|> > the following:
|> >
|> > A: Background
|> >
|> > 1) At the Salt Lake City IETF we called for volunteers to work on
|> >    the two IPFIX documents, as set out in the WG charter.  About
|> >    20 people volunteered.
|> >
|> > 2) After an initial flurry of discussion on the IPFIX list, things
|> >    went quiet.  We set up some extra sub-lists to help the design
|> >    team members get some initial discussions going.
|> >
|> > 3) KC Norseth stepped forward and posted some skeleton documents.
|> >    These were simply lists of section headings based on the
|> >    'IPFIX requirements' document.
|> >
|> > 4) KC also proposed a design teleconference.  That idea was
|> >    welcomed, and the conference was scheduled for 31 January.
|> >
|> > 5) At that point a group from Cisco, led by Benoit and Ganesh,
|> >    came forward with a much more complete document, which they
|> >    published as an individual Internet draft, so everyone could
|> >    read it and comment.  This was a very considerable contribution
|> >    to the WG.
|> >
|> > 6) The teleconference was held, with many people participating.
|> >    Minutes were posted on the list.  Since then there has been
|> >    a *lot* of discussion on the list and sublists.  Many people
|> >    (including those from Cisco) have contributed text, which KC
|> >    has edited together to form a second document.  This will
|> >    shortly be published as a second individual draft.
|> >
|> > 7) We now have two documents, each with lots of worthwhile material
|> >    in them.  I suspect there is a feeling that these are, somehow,
|> >    competing proposals - this is not the case.  Both are serious
|> >    contributions to the WG effort.
|> >
|> > B: What next?
|> >
|> > From the WG co-chairs point of view, any documents being 
|produced as 
|> > WG drafts need to be the result of open discussion in the WG, i.e. 
|> > on its mailing list.  The co-chairs' role is to facilitate 
|> > discussion, and to guide it towards actually delivering 
|documents as 
|> > per the WG's charter goals.  Decisions about the technical 
|merit of 
|> > text in various sections of the document needs to be decided by 
|> > consensus on the list.
|> >
|> > Ideally, we'd like to get to the next IETF meeting (Minneapolis in
|> > March) with a single document to review / discuss / amend.  So how 
|> > can we achieve that?
|> >
|> > I propose that
|> >
|> > 1) We form a small 'editorial' team, with two people from those
|> >    working on each of the two current documents (4 altogether).
|> >
|> > 2) We ask the editorial team to merge the documents together,
|> >    and publish the resulting document(s) as IPFX WG drafts.
|> >
|> > 3) The members of the design team - i.e. all those who've 
|contributed
|> >    text to the drafts - will be listed in the 'Acknowledgements'
|> >    section of all drafts produced. The editors of each document
|> >    will appear as the document authors.
|> >
|> > 4) Watching the mailing list discussion, this is starting to
|> >    happen as a natural development anyway.  Agreeing to proceed
|> >    in this way would simply introduce a little formality to it,
|> >    and make the process clear to everyone.
|> >
|> > One other comment. This WG has certainly generated plenty of 
|> > interesting discussion on its mailing list.  It's clear that all 
|> > those involved are putting a lot of effort into our goal of 
|> > producing the best technical solutions.  Thanks all round.
|> >
|> > I'd like comments / feedback on this notion from all concerned, 
|> > please. In particular, if we can agree to proceed in this way, we 
|> > need to decide who's on the editorial team ...
|> >
|> > Cheers, Nevil
|> >
|> > 
|+---------------------------------------------------------------------+
|> > | Nevil Brownlee                     Director, Technology 
|Development |
|> > | Phone: +64 9 373 7599 x8941        ITSS, The University 
|of Auckland |
|> > |   FAX: +64 9 373 7021      Private Bag 92019, Auckland, 
|New Zealand |
|> > 
|+-------------------------------------------------------------------
|> > +--P
|> >
|> >
|> > --
|> > Help        mailto:[email-masked] and say 
|"help" in message body
|> > Unsubscribe mailto:[email-masked] and say 
|"unsubscribe 
|> > ipfix" in message body
|> > Archive     http://ipfix.doit.wisc.edu/archive/
|> >
|>
|> --
|> Help        mailto:[email-masked] and say 
|"help" in message body
|> Unsubscribe mailto:[email-masked] and say "unsubscribe 
|> ipfix" in message body
|> Archive     http://ipfix.doit.wisc.edu/archive/
|
|
|--
|Help        mailto:[email-masked] and say "help" 
|in message body
|Unsubscribe mailto:[email-masked] and say 
|"unsubscribe ipfix" in message body
|Archive     http://ipfix.doit.wisc.edu/archive/
|

---

From: <[email-masked]>
Date: Thu, 14 Feb 2002 15:06:40 -0500

Hello Will,

Every one is subscribed to the email list, and mail has been sent out from the WG chair and it
is not a good practice to force someone. I have not seen their response to the WG chairs request
for editorial volunteers. Neither you mentioned that you are speaking with the consent of them.
 
Moreover they are answering and listening to the other  emails , it is not a good practice to refer 
someone with out their consent ( even if they have it is their responsibility to take interest in such
activity)
 
Coming back to your point, trying move other volunteers and making one document with the people
you want to favor them is not good - we not playing we are doing a combined team effort.
 
Regards
Ramg

>From: ext Will Eatherton [mailto:[email-masked]]
>Sent: Thursday, February 14, 2002 1:47 PM
>To: Juergen Quittek; Nevil Brownlee; [email-masked]
>[email-masked]
>Juergen,
>Proposal was 2 from each exisiting draft (from first draft I assume
>Ganesh/Benoit).  So that is 6 volunteers for 2 slots.  Since I have not
>volunteered I will feel comfortable pushing that I believe it 
>should be kept
>to 4 total since otherwise I expect the group to have as much trouble
>reaching consensus as we have seen occur on the the list thus far.
>
>The rest of us will defintely continue to provide input in the form of
>reviews, but a cohesive document is going to require a small team with
>somewhat similar starting views on what the scope of this document is.
>
>Will
>
>> From: majordomo listserver 
>[mailto:[email-masked]]On Behalf
>> Of Juergen Quittek
>> Sent: Thursday, February 14, 2002 10:39 AM
>> To: Nevil Brownlee; [email-masked]
>> [email-masked]
>> Nevil and Dave,
>> You suggested a editor team of 4, but now we have 6
>> volunteers: Paul, KC, Reinaldo, Ram, Kevin and me.
>>
>> I am sure that all of us are well motivated and capable
>> of doing a good job. Therefore, selecting just 4 might
>> disappoint one or the other.
>>
>> Therefore I suggest taking all 6 instead of 4
>> and dividing us into two groups of 3,
>> one for each document.
>>
>> However you decide, please decide soon, because we just
>> have one week left and there is still a lot of work ahead.
>> We need to arrange phone conferences, distribute the work
>> and come up with the documents until next Friday.
>>
>> Cheers,
>>
>>     Juergen
>>
>>
>> --On 14 February 2002 11:23 +1300 Nevil Brownlee
>> <[email-masked]> wrote:
>>
>> >
>> > Hello all:
>> >
>> > One other comment. This WG has certainly generated plenty 
>of interesting

---

From: <[email-masked]>
Date: Thu, 14 Feb 2002 15:30:41 -0500

Hello Peram,

You do not force Cisco people only as editors  and they have not raised their desire so far
in the email.In IETF individual speaks for themselves and they are also subscribed to the list.  
 
See my inline comments.
 
>I dont believe this is what Nevil/Dave wanted. If I read the
>message correctly, Nevil was suggesting respresentation from
>draft-gsadasiv and the other draft that KC is putting together equally.

You read once more.
"
1) We form a small 'editorial' team, with two people from those
    working on each of the two current documents (4 altogether). "

Regards
Ramg

>Juergen Quittek wrote:

---

From: "Reinaldo Penno"<[email-masked]>
Date: Thu, 14 Feb 2002 18:09:51 -0800

Will,

what you are proposing is not consensus. Nevil asked for comments on his
*proposal*. This is a proposal, he didn't asked/mandated us to agree with
him. This is the IETF, rough consensus...

Reinaldo

>From: Will Eatherton [mailto:[email-masked]]
>Sent: Thursday, February 14, 2002 10:47 AM

---

From: "Reinaldo Penno"<[email-masked]>
Date: Thu, 14 Feb 2002 18:27:58 -0800

I second this proposal. I also think there should be no esoteric number of
editors we need to follow. So 6 people volunteered and btw they also
contributed and put a lot of effort on both of these drafts.

This would be fair because would balance people from several companies with
different visions that gave considerable contributions. 

regards,

Reinaldo

>From: Juergen Quittek [mailto:[email-masked]]