Subject: Re: [ipfix-data] Data doc - New section 6.12 - 6.12.4

From: [email-masked]
Date: Fri, 22 Feb 2002 16:14:34 -0500

Reinaldo Penno wrote:
> 
> >-----Original Message-----
> >From: [email-masked] [mailto:[email-masked]]
> >Sent: Friday, February 22, 2002 12:32 PM
> >To: Penno, Reinaldo [SC9:T327:EXCH]
> >Cc: [email-masked]; Norseth, KC
> >Subject: Re: [ipfix-data] Data doc - New section 6.12 - 6.12.4
> >
> >
> >Reinaldo Penno wrote:
> >>
> >> Hello Paul/K.C.
> >>
> >> this is part of the proposed changes in section 6.12. If we get
> some
> >> rough consensus I will post the whole section later.
> >>
> >> 6.12. Virtual Information <or some other name>
> >>
> >> An exporter may be involved in providing services that require
> >> application level intelligence and/or transform or filter
> >content such
> >> as middlebox and OPES respectively.
> >>
> >> Each type field of the following IEs contain the type of operation
> >> performed on the packet. The currently available types are:
> >>
> >> 1. - NAT
> >> 2. - LSNAT
> >> 3. - Twice NAT
> >> 4. - Request Routing
> >> 5. - Outgoing L3 Tunnel
> >> 6. - Incoming L3 Tunnel
> >> 7. - Outgoing L2 Tunnel
> >> 8. - Incoming L2 Tunnel
> >> 9. - OPES (several sub-services here)
> >> 10. - others...
> >>
> >> TBD: How to convey when Several operations are applied to a packet,
> 
> >> for instance, NAT and L2TP. Export several virtual sets...
> >
> >       Can't you just have a LIST of IE's?
> 
> yes, that what I meant by "several virtual sets". I was wondering if
> maybe you could maybe consolidate the information.
> 
> >
> >>
> >> TBD: The type field is repeated on each IE, altough I do not expect
> 
> >> that for the same set of virtual IEs we are going to have NAT in
> one
> >> and RR in other. It would cause confusion (see below)
> >>
> >> TBD: The order is important when applying and consequentely
> reporting
> >> a chain of operations in flow records.
> >
> >       If order means the order of translation then I think that
> >       takes care of having multiple IE's with the same type.
> 
> Not only having multiple IEs with the same type but in order, not any
> order. I just want to make sure that we understand that the order is
> important. We should probably say that when the exporter is involved
> on these types of services the order of the IEs MUST reflect the order
> of the operations performed.

	agreed.

> regards,
> Reinaldo
> >> regards,
> >> Reinaldo

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "Reinaldo Penno"<[email-masked]>
Date: Fri, 22 Feb 2002 13:08:06 -0800

>> this is part of the proposed changes in section 6.12. If we get some

yes, that what I meant by "several virtual sets". I was wondering if maybe
you could maybe consolidate the information.

>> that for the same set of virtual IEs we are going to have NAT in one
>> TBD: The order is important when applying and consequentely reporting

Not only having multiple IEs with the same type but in order, not any order.
I just want to make sure that we understand that the order is important. We
should probably say that when the exporter is involved on these types of
services the order of the IEs MUST reflect the order of the operations
performed. 

regards,

Reinaldo