Subject: RE: [ipfix-arch] applicability document?

From: "Reinaldo Penno"<[email-masked]>
Date: Mon, 18 Feb 2002 19:45:22 -0800

I think it's a good idea Benoit.

comments inline...

>-----Original Message-----
>From: Benoit Claise [mailto:[email-masked]]
>Sent: Monday, February 18, 2002 11:09 AM
>To: [email-masked]
>Subject: [ipfix-arch] applicability document?
>
>
>All,
>
>As already proposed by Nevil, I think this is a good idea to have an
>applicability document.
>What I would see in there is:
>- section 8.4 on "ipfix considerations for middleboxes"

Some of it could be on the applicability. But some of it need to be on the
arch document. Also, If you want to include CDI and OPES under the middlebox
umbrella, then there is no need for a different section. Otherwise a section
on OPES is deserved  due to the uniqueness of the flow handling. 

>- section 8.5 on "QOS Monitoring with IPFIX"

I like this section.

>- section 11.1 on "Some applications of IPFIX"
>
>What do you think?
>
>Regards, Benoit
>
>
>--
>Help        mailto:[email-masked] and say "help" 
>in message body
>Unsubscribe mailto:[email-masked] and say
>"unsubscribe ipfix" in message body
>Archive     http://ipfix.doit.wisc.edu/archive/
>

---

From: "Carter Bullard" <[email-masked]>
Date: Wed, 20 Feb 2002 09:41:51 -0500

Gentle people,
I hate to make a negative point, because so much good
stuff has been going on, but the applications that are
listed below relate to the analysis flow data, not IPFIX.  

I can see applications like syslog event transport,
packet capture transport, SNMP event transport, routing
information export as extended applications of IPFIX,
as these are transport applications.

This is not to say that these things aren't important,
but we shouldn't let IPFIX get toooo far off of the
point.

Carter

Carter Bullard
QoSient, LLC
300 E. 56th Street, Suite 18K
New York, New York  10022

[email-masked]
Phone +1 212 588-9133
Fax   +1 212 588-9134
http://qosient.com

> From: majordomo listserver 
> [mailto:[email-masked]] On Behalf Of Benoit Claise
> Sent: Wednesday, February 20, 2002 6:48 AM
> To: Tanja Zseby
> Cc: [email-masked]
> Subject: Re: [ipfix-arch] applicability document?
> 
> 
> Tanja,
> 
> Perfect.
> 
> Regards, Benoit
> 
> > Hi Benoit,
> >
> > I  agree that it is a good idea to create an applicability 
> document. I 
> > would propose to have one section for each of the 
> applications in the 
> > requirements documents. Maybe there are also further 
> applications that 
> > can use IPFIX ? Also the relations of IPFIX to other 
> > frameworks/protocols could be put into this document (or a separate 
> > one
> > ?)  I propose to have the following parts in the document:
> >
> > 1. Applications of IPFIX
> >     1.1 Accounting with IPFIX
> >     1.2 Traffic Profiling with IPFIX
> >     1.3 Traffic Engineering with IPFIX
> >     1.4 Intrusion detection with IPFIX
> >     1.5 QoS Monitoring with IPFIX
> >     - other applications ?
> >
> > 2. Relation of IPFIX to other frameworks and protocols
> >     2.1 IPFIX and AAA
> >     2.2 IPFIX and RTFM
> >     2.3 IPFIX considerations for middleboxes
> >     2.4 IPFIX and RMON
> >     2.5  IPFIX and IPPM (e.g. IPPM MIB)
> >     2.6 IPFIX and PSAMP
> >     -  further relations
> >
> > I could contribute some text at least to 1.1, 1.5 ,2.1, 2.2 
> and 2.5. 
> > If others agree, that we should work on this document, 
> maybe Dave can 
> > open an additional "pseudo"- mailling-list [ipfix-appl] ?
> >
> > Regards
> > Tanja
> >
> > Benoit Claise wrote:
> >
> > >All,
> > >
> > >applicability document. What I would see in there is:
> > >Help        mailto:[email-masked] and say 
> "help" in message body
> > Dipl.-Ing. Tanja Zseby
> > FhI FOKUS/Global Networking                     Email: 
> [email-masked]
> > Kaiserin-Augusta-Allee 31                               
> Phone: +49-30-3463-7153
> > D-10589 Berlin, Germany                         Fax:   
> +49-30-3463-8153
> > 
> ----------------------------------------------------------------------
> > ----------------
> > "Living on earth is expensive but it includes a free trip 
> around the sun." (Anonymous)
> > 
> --------------------------------------------------------------
> ------------------------
> 
> 
> --

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "Norseth, KC" <[email-masked]>
Date: Wed, 20 Feb 2002 09:49:17 -0500

That is one reason for a separate document.  Currently, until decided,
hopefully today, it remains in the arch document.

K.C.

|-----Original Message-----
|From: Carter Bullard [mailto:[email-masked]] 
|Sent: Wednesday, February 20, 2002 7:42 AM
|To: 'Benoit Claise'; 'Tanja Zseby'
|Cc: [email-masked]
|Subject: RE: [ipfix-arch] applicability document?
|
|
|
|Gentle people,
|I hate to make a negative point, because so much good
|stuff has been going on, but the applications that are
|listed below relate to the analysis flow data, not IPFIX.  
|
|I can see applications like syslog event transport,
|packet capture transport, SNMP event transport, routing 
|information export as extended applications of IPFIX, as these 
|are transport applications.
|
|This is not to say that these things aren't important,
|but we shouldn't let IPFIX get toooo far off of the
|point.
|
|Carter
|
|Carter Bullard
|QoSient, LLC
|300 E. 56th Street, Suite 18K
|New York, New York  10022
|
[email-masked]
|Phone +1 212 588-9133
|Fax   +1 212 588-9134
|http://qosient.com
|
|
|
|> -----Original Message-----
|> From: majordomo listserver
|> [mailto:[email-masked]] On Behalf Of Benoit Claise
|> Sent: Wednesday, February 20, 2002 6:48 AM
|> To: Tanja Zseby
|> Cc: [email-masked]
|> Subject: Re: [ipfix-arch] applicability document?
|> 
|> 
|> Tanja,
|> 
|> Perfect.
|> 
|> Regards, Benoit
|> 
|> > Hi Benoit,
|> >
|> > I  agree that it is a good idea to create an applicability
|> document. I
|> > would propose to have one section for each of the
|> applications in the
|> > requirements documents. Maybe there are also further
|> applications that
|> > can use IPFIX ? Also the relations of IPFIX to other
|> > frameworks/protocols could be put into this document (or a 
|separate 
|> > one
|> > ?)  I propose to have the following parts in the document:
|> >
|> > 1. Applications of IPFIX
|> >     1.1 Accounting with IPFIX
|> >     1.2 Traffic Profiling with IPFIX
|> >     1.3 Traffic Engineering with IPFIX
|> >     1.4 Intrusion detection with IPFIX
|> >     1.5 QoS Monitoring with IPFIX
|> >     - other applications ?
|> >
|> > 2. Relation of IPFIX to other frameworks and protocols
|> >     2.1 IPFIX and AAA
|> >     2.2 IPFIX and RTFM
|> >     2.3 IPFIX considerations for middleboxes
|> >     2.4 IPFIX and RMON
|> >     2.5  IPFIX and IPPM (e.g. IPPM MIB)
|> >     2.6 IPFIX and PSAMP
|> >     -  further relations
|> >
|> > I could contribute some text at least to 1.1, 1.5 ,2.1, 2.2
|> and 2.5.
|> > If others agree, that we should work on this document,
|> maybe Dave can
|> > open an additional "pseudo"- mailling-list [ipfix-appl] ?
|> >
|> > Regards
|> > Tanja
|> >
|> > Benoit Claise wrote:
|> >
|> > >All,
|> > >
|> > >As already proposed by Nevil, I think this is a good idea
|> to have an
|> > >applicability document. What I would see in there is:
|> > >- section 8.4 on "ipfix considerations for middleboxes"
|> > >- section 8.5 on "QOS Monitoring with IPFIX"
|> > >- section 11.1 on "Some applications of IPFIX"
|> > >
|> > >What do you think?
|> > >
|> > >Regards, Benoit
|> > >
|> > >
|> > >--
|> > >Help        mailto:[email-masked] and say 
|> "help" in message body
|> > >Unsubscribe mailto:[email-masked] and say
|> "unsubscribe
|> > >ipfix" in message body
|> > >Archive     http://ipfix.doit.wisc.edu/archive/
|> > >
|> >
|> > --
|> > Dipl.-Ing. Tanja Zseby
|> > FhI FOKUS/Global Networking                     Email: 
|> [email-masked]
|> > Kaiserin-Augusta-Allee 31                               
|> Phone: +49-30-3463-7153
|> > D-10589 Berlin, Germany                         Fax:   
|> +49-30-3463-8153
|> > 
|> 
|----------------------------------------------------------------------
|> > ----------------
|> > "Living on earth is expensive but it includes a free trip
|> around the sun." (Anonymous)
|> > 
|> --------------------------------------------------------------
|> ------------------------
|> 
|> 
|> --
|> Help        mailto:[email-masked] and say "help" 
|> in message body
|> Unsubscribe mailto:[email-masked] and say
|> "unsubscribe ipfix" in message body
|> Archive     http://ipfix.doit.wisc.edu/archive/
|> 
|> 
|
|
|
|--
|Help        mailto:[email-masked] and say "help" 
|in message body
|Unsubscribe mailto:[email-masked] and say 
|"unsubscribe ipfix" in message body
|Archive     http://ipfix.doit.wisc.edu/archive/
|