Subject: [ipfix-data] Data doc - New section 6.12 - 6.12.4

From: "Reinaldo Penno"<[email-masked]>
Date: Fri, 22 Feb 2002 12:23:23 -0800

Hello Paul/K.C.

this is part of the proposed changes in section 6.12. If we get some rough
consensus I will post the whole section later.

6.12. Virtual Information <or some other name>

An exporter may be involved in providing services that require application
level intelligence and/or transform or filter content such as middlebox and
OPES respectively.

Each type field of the following IEs contain the type of operation performed
on the packet. The currently available types are:

1. - NAT
2. - LSNAT
3. - Twice NAT
4. - Request Routing 
5. - Outgoing L3 Tunnel
6. - Incoming L3 Tunnel
7. - Outgoing L2 Tunnel
8. - Incoming L2 Tunnel
9. - OPES (several sub-services here)
10. - others...

TBD: How to convey when Several operations are applied to a packet, for
instance, NAT and L2TP. Export several virtual sets...

TBD: The type field is repeated on each IE, altough I do not expect that for
the same set of virtual IEs we are going to have NAT in one and RR in other.
It would cause confusion (see below)

TBD: The order is important when applying and consequentely reporting a
chain of operations in flow records.

regards,

Reinaldo

---

From: [email-masked]
Date: Fri, 22 Feb 2002 15:31:56 -0500

Reinaldo Penno wrote:
> 
> Hello Paul/K.C.
> 
> this is part of the proposed changes in section 6.12. If we get some
> rough consensus I will post the whole section later.
> 
> An exporter may be involved in providing services that require
> application level intelligence and/or transform or filter content such
> as middlebox and OPES respectively.
> 
> Each type field of the following IEs contain the type of operation
> performed on the packet. The currently available types are:
> 
> 1. - NAT
> 2. - LSNAT
> 3. - Twice NAT
> 4. - Request Routing
> 5. - Outgoing L3 Tunnel
> 6. - Incoming L3 Tunnel
> 7. - Outgoing L2 Tunnel
> 8. - Incoming L2 Tunnel
> TBD: How to convey when Several operations are applied to a packet,
> for instance, NAT and L2TP. Export several virtual sets...

	Can't you just have a LIST of IE's?

> 
> TBD: The type field is repeated on each IE, altough I do not expect
> that for the same set of virtual IEs we are going to have NAT in one
> and RR in other. It would cause confusion (see below)
> 
> TBD: The order is important when applying and consequentely reporting
> a chain of operations in flow records.

	If order means the order of translation then I think that 
	takes care of having multiple IE's with the same type.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/