Subject: [ipfix] Terminology: metering process

From: Juergen Quittek <[email-masked]>
Date: Thu, 21 Mar 2002 18:31:09 +0100

Tanja and myself have discussed the definition of the term
'metering process', particularly considering hierarchical
systems as the one Ganesh contributed to the architecture
(draft-ietf-ipfix-architecture-00.txt, page 5) and as the
ones we showed on the requirement slides at Minneapolis (http://ipfix.doit.wisc.edu/IETF53/IPFIX-reqs-IETF53.ppt, page 10).

The old definition in the draft-ietf-ipfix-reqs-01.txt is:

2.3. Metering Process
   A metering process is a set of actions performed on packets observed
   at an observation point in order to map them to a flow. A metering
   process can include functions for timestamping, classification and
   sampling of packets. Typically, the metering process also includes
   maintainance of flow records, computation of flow statistics, and
   detection of flow expiration.

We propose to replace it by the following definition:

2.3. Metering Process
   The metering process generates flow records. Input to the process
   are IP packets observed at an observation point. The metering process
   consists of a set of functions that includes packet header capturing,
   timestamping, sampling, classifying, and maintaining flow records.

   The maintenance of flow records may include creating new records,
   updating existing ones, computing flow statistics, deriving further
   flow properties, detecting flow expiration, passing flows record to
   the exporting process, and deleting flow records.

   The sampling function and the classifying function may be realized as
   trivial functions, for example one-in-one sampling or mapping all packets
   to the same single class. They may be applied more than once with different
   parameters. The figure below shows the sequence in which the functions
   are applied.

                        packet header capturing
                                  |
                             timestamping
                                  |
                                  v
                           +----->+
                           |      |
                           |   sampling
                           |      |
                           | classifying
                           |      |
                           +------+
                                  |
                       maintaining flow records
                                  |
                                  v

              Figure 1: Functions of the metering process

Cheers,

    Juergen
-- 
Juergen Quittek     [email-masked]     Tel: +49 6221 90511-15
NEC Europe Ltd.,    Network Laboratories     Fax: +49 6221 90511-55
Adenauerplatz 6, 69115 Heidelberg, Germany   http://www.ccrle.nec.de

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Ganesh Sadasivan <[email-masked]>
Date: Thu, 21 Mar 2002 11:07:28 -0800

Hi Jurgene,
  See inline.

>    The sampling function and the classifying function may be realized as

Don't we need to define sampling & classifying before refering to it here?
Looks a little confusing to me.

>    trivial functions, for example one-in-one sampling or mapping all packets

What do you mean by "trivial functions"? Aren't Sampling & classifying optional.
In the figure don't you need a direct path from "timestamping" to
"maintaining flow records" ?

Thanks
Ganesh

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 21 Mar 2002 23:31:13 +0100

Ganesh,

> Juergen Quittek wrote:
[...]
> Looks a little confusing to me.

Concerning packet sampling I am not sure, because this might be
sufficiently understood term already. Concerning classifying I agree.

> What do you mean by "trivial functions"? Aren't Sampling & classifying optional.

OK, we have two alternatives of phrasing: either we declare them optional
or we say they may degenerate to trivial functions. The effect - at least
for sampling - would be the same. What would be your preference?

> "maintaining flow records" ?

How should this work? we first need to sample and classify before
we know which flow record to update. Maybe we should explain timestamping
as 'adding a timestamp to the captured packet header'?

Cheers,

    Juergen

---

From: Ganesh Sadasivan <[email-masked]>
Date: Fri, 22 Mar 2002 09:41:26 -0800

Jurgene,

> sufficiently understood term already. Concerning classifying I agree.

The packet headers are subjected to one of or a combination of
classification based on some criteria and sampling based on some
algorithm.We can just mention the special cases in the figure.
This can can effective represent any combination of Si & Fi defined
in the data model.

                      packet header capturing
                                 |
                         timestamping
                                 |
                                 v
                          +----->+
                          |      |
                          |   sampling (1:1 in case of no sampling)
                          |      |
                          | classification (NULL when No criteria)
                          |      |
                          +------+
                                 |
                     maintaining flow records
                                 |
                                 v
Does this look ok to you?
Thanks
Ganesh