Subject: Re: [ipfix] Re: congestion awareness, reliability

From: Peram Marimuthu <[email-masked]>
Date: Thu, 14 Mar 2002 08:42:16 -0800

Kevin,

"kevin.zhang" wrote:

>
> > Ok. If I am right, Ganesh's presentation said that we need 6.8Gbytes
> > of memory and 30% CPU utilization to support Netflow (with TCP)
> > on a 40G router.
> > Let us assume that he is completely wrong and the requirement is
> > just 1/5th.
> > Even then we need a buffer of about 1.4Gbytes.
> >
> > Now, what I am looking for is a presentation with the right calculations
> > and acceptable assumptions that shows buffer requirements for a 40G box.
> > Assume 100 ms RTT, 50Kbps as bandwidth per flow, 40 bytes as flow record
> > size,  path mtu is 1500 bytes and you will have to support 1
> > retransmission.
> > Convince that buffering requirements are not very high and TCP
> > will work here.
> >
> > Thanks
> > Peram
> >
>
> Paul's recollection is accurate. I remembered about the presentation assumed that a TCP SEND needs three memory copies, which might be arguable.
>
> As engineers, we encounter these problems (like Ganesh presented) everyday.  Our job is to design a solution that meets customer's requirement given the constraints of the system (System engineering 101).  I doubt an application will be interested in each IP packets routed by your high end router, many mechanisms (described in the architecture draft) such as filtering,  aggregating, efficient data representation, etc. can significantly reduce the amount of exported data as well as memory consumption.
>
> If IPFIX is deployed over LAN, the RTT would be much smaller, maybe in 10ms range; this is 10 fold reduction of the memory from your presentation.
>
> Thanks,
>
> Kevin

A 40G router is a mid-range router, not a high end. We have been shipping 160G boxes for quite some time
and you dont even want to do calculations for TCP for this router. Now the argument
"filtering,  aggregating, efficient data representation, etc. can significantly reduce the amount of exported data as well as memory consumption" does not solve everyone's problem. If someone is able to do
Netflow on 40G routers and you tell him that he has "filter, aggregate etc" to use IPfix guess
what he is going to do.

Even on a LAN, if you do a 10 fold reduction, the buffer requirements are very high.

Peram

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: [email-masked]
Date: Fri, 15 Mar 2002 09:05:43 -0500

> Even on a LAN, if you do a 10 fold reduction, the buffer requirements are very high.

	Just a question, if we take the numbers at face value, can even UDP
	handle the load?

	Also, is there a pointer to Ganesh's presentation? I couldn't
	find it.

---

From: Ganesh Sadasivan <[email-masked]>
Date: Fri, 15 Mar 2002 10:00:56 -0800

You can it in  http://ipfix.doit.wisc.edu/IETF52/

[email-masked] wrote:
<snip>