Subject: [ipfix] ipfix-arch Section 3 comments

From: "Kevin Zhang" <[email-masked]>
Date: Thu, 7 Mar 2002 22:07:22 -0500

Hi All,

I have a couple of comments related to flow type and template definitions.  See if you can agree with my proposed changes.

Thanks,

Kevin
  
   Flow Type:
   A function F that would take input as a set of keys and the output 
   would be one or more flows depending on the combination of values 
   for the set of keys. 

[kz] this is a bit confusing, I am proposing the following 
"Flow Type:
A flow type represents some properties of a flow, it is derived by applying a function on a set of keys. With identical keys as inputs to the function, only a single flow type shall be obtained." [kz]

   Template:
   Templates is a set of {type, length} ordered pairs, used to 
   completely identify the structure and semantics of a particular 
   information that needs to be communicated from the exporter to the 
   collector. Each template is uniquely identified by a Template ID. 
[kz] The definition of Template was significantly changed from our previous draft, the current definition looks more like an IE coding. Propose the following definition for Template and Data Record Spec.
" Template:
A Template is an ordered list of Data Record Spec., it completely defines the structure of multiple data records that may be logically related (e.g. through flow definitions). It specifies the data type, meaning, and location of the data records in such a set. A template is typically negotiated between the exporter and collectors; an exporter uniquely identifies each template by a Template ID. 

Data Record Spec.:
A Data Record Spec. defines a data record that an exporter may export. The specification may consist of the description, length, and the data type of the data record. (e.g. 'Byte Count'  can be a key that is an 32 bit unsigned integer) An exporting device typically defines keys." [kz]

ÿñÞ–™šŠ[hþf£¢·hšçzßÝ¢+ÿÂ+ýçnjwlk/ázZÿŠyž²Æ yºÉIì¹»®&Þ™¨¥¶æj:+v‰¨þwýÚ"·ü"±ÏÞvæ§vÆ²þéì¹»®&ÞŠ—âÇø§™ë,j›¡Ü€Èb½èm¶Ÿÿþ*_‹Ý¢+ÿÂ+ýçnýªÜ†+Þ

---

From: Ganesh Sadasivan <[email-masked]>
Date: Thu, 07 Mar 2002 20:13:18 -0800

Hi Kevin,

> A flow type represents some properties of a flow, it is derived by applying a function on a set of keys. With identical keys as inputs to the function, only a single flow type shall be obtained." […

A flow type generates a class of flows. Infact this is a problem of distributing
definitions across docs. The data model doc describes with examples what a
flow type is.
You can imagine this as a function f(x1,x2..). Based on different values of
tuple (x1, x2..) the function returns  values which are flows. Now for 2 different
tuples, the function can return the same flow or different flows. It depends on
what the function does.

>    collector. Each template is uniquely identified by a Template ID.

The above defintion is inline with the proposed data model of {field type, size}.
The semantics (.i.e meaning) is automatically understood based on this
information and so is the structure (what you refer to as "location").

> A Template is an ordered list of Data Record Spec., it completely defines the structure of multiple data records that may be logically related (e.g. through flow definitions). It specifies the data…

"negotiation" is not part of template defintion.

> A Data Record Spec. defines a data record that an exporter may export. The specification may consist of the description, length, and the data type of the data record. (e.g. 'Byte Count'  can be a k…

This statement talks about an implementation.
Thanks
Ganesh

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/