Subject: RE: [ipfix-eval] Discussion of Candidate Protocols

From: "Carter Bullard" <[email-masked]>
Date: Thu, 3 Oct 2002 17:31:48 -0400

Gentle people,

My existing flow record generators provide jitter and loss
information in flow data records.  How do I do that with an
LFAP or netflow strategy?

Carter

Carter Bullard
QoSient, LLC
300 E. 56th Street, Suite 18K
New York, New York  10022

[email-masked]
Phone +1 212 588-9133
Fax   +1 212 588-9134
http://qosient.com

-----Original Message-----
From: majordomo listserver [mailto:[email-masked]] On
Behalf Of Michael MacFaden
Sent: Thursday, October 03, 2002 3:50 PM
To: [email-masked]
Subject: Re: [ipfix-eval] Discussion of Candidate Protocols

On Thu, Oct 03, 2002 at 09:08:12AM -0700, Jeff Meyer wrote:
>  So you have one description language, based on
>XML Schema, a wire protocol, a binary format,
>an XML format and a DB mapper, in a single document.
>
>
>  Show me how that is done w/ the  other proposed
>drafts?

My main issue with such a system is do we *require*
such complexity if a simple numbering of fields
will do just fine? 

I'd really like to see the IPIFIX protocol do one thing 
and do it very well.

Delivering IP header information, as has been done
for a very long time now with NetFlow and others,
only really needs a clear definition 
of is being collected, how it is collected, 
and how to signal when the collector can't 
collect a paritcular piece of data ala RDBMS 
null indicator.  

The LFAP data spec clearly defines what is being
collected and like NetFlow are purpose built
targeted protocols. They not generic data movers.

This makes them simple as can be, consistent and 
extremely interoperable.

Regards,
Mike MacFaden

--
Help        mailto:[email-masked] and say "help" in message
body
Unsubscribe mailto:[email-masked] and say "unsubscribe
ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Michael MacFaden <[email-masked]>
Date: Thu, 3 Oct 2002 15:10:20 -0700

>LFAP or netflow strategy?

For LFAP, build your collector as one normally would and
then just follow section 2.45 of 
http://www.ietf.org/internet-drafts/draft-riverstone-lfap-data-01.txt

My point was/is simply this. 
We should consider the feature/complexity tradeoff 
for each criteria considered in context of the problem 
being solved. 

My personal belief is that IPFIX does not stand for 
GDMP (Generic Data Mover Protocol). 

Regards,
Mike MacFaden