Subject: RE: [ipfix-eval] Simon's and Ram's evaluations

From: "Carter Bullard" <[email-masked]>
Date: Tue, 22 Oct 2002 12:08:29 -0400

> Carter Bullard wrote:
> > 
> > > [snip]
> > >
> > > consumption of
> > > > processing power and the memory consumption.
> > > >
> > >
> > >       Netflow V9 will need to me modified to allow split 
> reporting.
> > >       Many devices do not have the ability to store attributes per
> > flow
> > >       until expiration.
> > 
> > When did split reporting become a requirement?
> 
> 	I thought that was what section 6.5.  Regular Reporting Interval
> 	was all about. If we want low memory consumption on the device
> 	this is an important requirement.
> 

This is an implementation issue, and should be vendor specific.
LFAP's split reporting introduces complexity and reliability problems
that are unjustified.  There is no reason that this feature would
reduce probe memory consumption, unless you've got an incredibly
inefficient monitor to begin with.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: [email-masked]
Date: Tue, 22 Oct 2002 12:15:26 -0400

> inefficient monitor to begin with.

	First, this is an LFAP option, not a must. Those
	devices that don't need don't use it. For those
	that do it is key. Otherwise, 

	If turning on IPFIX capabilities chews up a ton of memory, 
	it wont be turned on. 

	Many devices do not store all the attributes that
	IPFIX can report on in the hardware entry. AS number 
	for example. That means that such attributes are stored 
	in memory per flow until report time.

	I don't believe it is vendor specific.

	Paul