Subject: RE: [ipfix-req] Re: Data Export Reliability Requirement [was: Re :IPFIXRequireme nt draft status - section 6.3.2]

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 9 Oct 2002 10:42:24 -0700

This one?

"As an example of data loss reporting, suppose that we are exporting a
single
metric and that the statistics on the exporter are:
     # flow records sent (not counting retransmitted) 1000
     # flow records ACKed                              900
     sum of metric all records                       10000
     sum of metric in all ACKed records               8000
From which we derive the following:
     average metric per record                          10
     average metric per ACKed record                     8.889
     average metric per un-ACKed record                 20
And on the receiver, we have:
     # flow records received (de-duplicated)           950
     sum of metric in all received records            9200
     average metric per received record                  9.684
The receiver notes that it did not receive 50 records; it can estimate the
sum of metric in these as 50 * 20 = 1000, for an estimated total of the
metric of 10200. (Something fancier could be done by using variance
calculations, combined with other metrics.)

[In CRANE, we provide two mechanisms for reporting loss:
 - the exporter can define an additional set of fields that it
   exports periodically with data loss values;
 - a status request from the collector, also reported as a set
   of fields.
 The content of these records is defined by the exporter, using the general
template mechanism.]

So, to sum up:
   - require application-level ACKs in the protocol (SHOULD be after
     data are persisted)
   - require enable de-duplication of received records
   - require mechanism for reporting data loss in the exporter -
     the details of this mechanism are outside the scope of the
     protocol except that the protocol must be general enough to
     allow them
   - individual information models (which use the flow export protocol)
     SHOULD describe data loss reporting"

---

From: Vamsidhar Valluri <[email-masked]>
Date: Wed, 9 Oct 2002 11:22:27 -0700 (PDT)

Please see inline

>  The content of these records is defined by the exporter, using the general

With Netflow Version 9 we can export Total number of export packets and
flow records sent using Option templates. For the example above with
Version 9 we can report

  -Total number of records sent
  -If configured on the exporter we can send sum of metric of all records

Collector can get an idea of average metric per record and
apply same value to missed records (missed records = Number of records
sent - Number of records received)

-vamsi

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/