Subject: RE: [ipfix-req] Re: Data Export Reliability Requirement [was: Re :IPFIXRequireme nt draft status - section 6.3.2]

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 9 Oct 2002 07:44:23 -0700

One thing is bothering me..

How could you gauge the amount of ->flow information<- lost (as stated
below) by just looking at sequence numbers? Without some sort of ack
mechanim, mind you.

It seems to me the best you can do is to report the amount of application
layer packets dropped. Since a packet can have a bunch of records, you would
never know the amount of flow information lost...am I missing something?

regards,

Renaldo

> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: Wednesday, October 09, 2002 1:34 AM
> To: [email-masked]
> Cc: Simon Leinen; Penno, Reinaldo [BL60:0430:EXCH];
> [email-masked]; [email-masked]
> Subject: Re: [ipfix-req] Re: Data Export Reliability Requirement [was:
> Re:IPFIXRequireme nt draft status - section 6.3.2]
> 
> 
> [email-masked] wrote:
> 
> >>>      Again, I think it is difficult to describe how to 
> measure loss
> >>>      without a protocol definition to analyze.
> >>>
> >>>      
> >>>
> >>Agreed. So maybe we should maybe postpone the discussion...
> >>
> >>    
> >>
> >
> >	Lets do that. 
> >
> >	However, I think this discussion shows the req section 
> should be a 
> >	little more general to leave open implementation 
> details. Here is 
> >	my proposal..
> >
> >	
> > 	If flow information is lost, a means to gauge the amount of
> >	loss MUST be available from the Exporter, Collector or both. 
> >	Possible reasons for flow data loss include loss of packets on 
> >	the network path, resource shortage at the exporter, Collector
> >	crash, etc...
> >
> >	Paul
> >
> I would prefer Simon's proposal.
> 
>  "If some flow information data cannot be delivered to the collector
>   in a timely manner, the collector MUST be able to estimate the
>   amount of data missing.  Possible reasons for failure to deliver
>   data include loss of packets on the network path, or resource
>   shortage at the exporter."
> 
> Unless you want to say:
>  	If flow information is lost, a means to gauge the amount of
> 	loss MUST be available from the Exporter _or the_ 
> Collector or both. 
> 	Possible reasons for flow data loss include loss of packets on 
> 	the network path, resource shortage at the exporter, Collector
> 	crash, etc...
> 
> Regards, Benoit.
> 
> 
>

---

From: [email-masked]
Date: Wed, 09 Oct 2002 10:58:27 -0400

> Reinaldo Penno wrote:
> It seems to me the best you can do is to report the amount of
> application layer packets dropped. Since a packet can have a bunch of
> records, you would never know the amount of flow information lost...am
> I missing something?

	That is why we postponed the discussion of how this accomplished
	until the protocol is a little more concrete.

	I would agree that just counting the messages dropped is a pretty
	weak gauge. That said, it is one that indicates more than zero and 
	you could use it at least as a relative measure. Hopefully we can
	do better.

	Paul

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Vamsidhar Valluri <[email-masked]>
Date: Wed, 9 Oct 2002 10:10:04 -0700 (PDT)

One possibility is Exporter keeping track of number of flow records that
it had sent and periodically communicating this information to the
collector.

-vamsi

---

From: "Peter Ludemann" <[email-masked]>
Date: Wed, 9 Oct 2002 10:14:24 -0700

I suggest number of records + some important totals (I described this more
fully in one of my emails)

> From: majordomo listserver [mailto:[email-masked]]On Behalf
> Of Vamsidhar Valluri
> Sent: Wednesday, October 09, 2002 10:10 AM
> To: Reinaldo Penno
> Cc: Benoit Claise; [email-masked]; Simon Leinen;
> Subject: RE: [ipfix-req] Re: Data Export Reliability Requirement [was:
> application