Subject: [ipfix] charter re-negotiation?

From: Juergen Quittek <[email-masked]>
Date: Tue, 19 Nov 2002 00:39:06 +0100

Hi all,

I have a request for clarification.

Nevil identified a list consensus on supporting multiple
levels of reliability:

-- Nevil Brownlee wrote on 16 November 2002 08:23 +1300:
>    * It's clear that a 'standard IPFIX' must allow for various levels
>      of reliability.  That suggests either having a base level (MUST) and
>      higher levels (SHOULD and MAY), or having a mnimum set of features
>      which applications can use to implement whatever level of reliability
>      they need. [list consensus]
in http://ipfix.doit.wisc.edu/archive/1462.html

But my understandung of Randy's message http://ipfix.doit.wisc.edu/archive/1408.html
is that the high "carrier class" reliability level is out of scope:

-- Randy Bush wrote on 11 November 2002 09:48 -0800:
> <ad>
>
>> I feel strongly that "typical Internet reliability" is
>> insufficient to make this standard of value for a large set of
>> applications.
>
> this is trivially true.  the question is whether such applications
> are, or should be, in the charter of this wg.  currently they are
> not.  if you wish to change that, then a change to the charter will
> be needed.  in this case, as it would seriously affect many
> parties, that will be a rather inclusive process and success is far
> from sure.
>
> it would be nice if the wg could abjure mission creep.
>
> </ad>

Consequently, if we have consensus that we need more than "typical Internet
reliabiltiy", then we should add the item "charter re-negotiation" to the
agenda of our session on Thursday.

Am I wrong with this assessment?

    Juergen

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "Paul Calato" <[email-masked]>
Date: Tue, 19 Nov 2002 13:30:15 -0800

If sending aggregated data via IPFIX is in scope then I ask you to consider 
the affect of send and forget in that scenairo.
 
It is no longer billing applications looking for 100%  reliability but rather 
any application that wants reasonable data. Aggregated records can represent 
such large chunks of information that loosing a fewof them is likely to be a problem.
 
Is that a scenairo IPFIX is/should be concerned about?
 
Paul

	-----Original Message----- 
	From: Dave Plonka [mailto:[email-masked]] 
	Sent: Tue 11/19/2002 11:28 AM 
	To: [email-masked] 
	Cc: 
	Subject: Re: [ipfix] charter re-negotiation?

	IPFIXers,
	
	Nevil and I have had the opportunity to discuss this...
	Here is our understanding (but in my own words of course):
	
	Our charter does not mandate that IPFIX be highly reliable at the
	transport nor the application layer.  This was intentional - only a
	subset of applications benefit significantly from that somewhat
	complicated feature which is costly to implement on some exporter
	platforms.  That said, IPFIX doesn't preclude transport or
	application-level reliability.  So, it is possible to build a
	highly-reliable system that is IPFIX conforming.
	
	The IPFIX WG, through our evaluation process, will select a protocol
	that (1) satisfies the requirements and (2) is preferred with respect
	to less tangible aspects including flexibility, simplicity, etc.
	
	If some among us believe have identified applications that require
	absolute reliability at the transport or application layer, then IPFIX
	requirements are perhaps insufficient for your applications
	requirements.  We mean IPFIX to be the "lingua franca" for the routed
	Internet, so relaxing applications requirements to make use of
	ubiquitous IP flow data may be in your best interest.  If that is not
	possible, perhaps you can lobby an IPFIX canidate protocol advocate to
	optionally support some more reliable mode for your application domain.
	
	To the best of my knowledge, no IP router stops forwarding packets
	because of occasionally reporting system failures (at least not by
	design ;^), and that could be one ultimate consequence of mandating
	application-level reliability and implementing it on a router.
	
	Instead, IPFIX defines the failure modes for the flow information
	export; it defines how the system behaves when confronted with
	transport congestion or resource overloads, so that we can bound, or at
	least know, the error.
	
	Dave
	
	On Tue, Nov 19, 2002 at 07:34:45AM +0100, Juergen Quittek wrote:
	> Nevil and Dave,
	>
	> Before this thread produces another 50 emails:
	> Could you please comment on it with WG chair hat on?
	
	> You wrote an negotiated the charter. Do you agree with
	> Randy's clear statement that high reliability is not covered
	> by the charter? Or do you disagree?
	>
	> In either case, clarification will speed up our progress.
	<snip>
	
	--
	[email-masked]  http://net.doit.wisc.edu/~plonka  ARS:N9HZF  Madison, WI

��ޖ���[h�f���h���z�ݢ+��+��njwlk/�zZ��y��Ơy��I칻�&ޙ�����j:+v���w���"��"���v�vƲ��칻�&ފ�������,j��܀��b��m����*_�ݢ+��+��n��܆+�

---

From: "Reinaldo Penno" <[email-masked]>
Date: Tue, 19 Nov 2002 15:20:06 -0800

Randy,

that would be my strong suggestion (make it crystal clear); change the
charter so that is clear we can have any congestion aware transport protocol
and the application protocol will be unidirectional with sequence numbers on
the headers. 

We should also remove billing and accounting from target applications and
point out this is out of scope. Or maybe say that the protocol might provide
unreliable (or best effort) billing and accouting and that carrier grade
billing and accounting should be pursed elsewhere.

regards,

Reinaldo

> From: Randy Bush [mailto:[email-masked]]
> Sent: Tuesday, November 19, 2002 6:00 PM
> To: Juergen Quittek
> Cc: Tal Givoly; Penno, Reinaldo [BL60:0430:EXCH];
> [email-masked]
> Subject: RE: [ipfix] charter re-negotiation?
> 
> 
> > We just need to realize, that standardizing something with 
> a reliability
> > similar to NetFlow is intended by the charter.
> 
> <ad hat>
> 
> indeed.  and if we need to have the charter changed to make that
> sufficiently clear, just say so and it will be done.
> 
> randy
> 
>

---

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 20 Nov 2002 11:41:43 -0800

Given the amount of emails I got on this....
 
yes, I was being serious. If that's what the ADs and Chairs want It's better
to be specific and get over with this than to keep "cooking" this decision.
Then everything is specified and in clear.
 
regards,
 
Reinaldo

-----Original Message-----
From: Penno, Reinaldo [BL60:0430:EXCH] 
Sent: Tuesday, November 19, 2002 6:20 PM
To: Randy Bush; Juergen Quittek
Cc: Tal Givoly; [email-masked]
Subject: RE: [ipfix] charter re-negotiation?

Randy, 

regards, 

Reinaldo 

> From: Randy Bush [ mailto:[email-masked] <mailto:[email-masked]> ]

---

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Wed, 20 Nov 2002 22:06:12 -0500

It sounds like the intent is to change to charter to better suit some
candidate protocols.  If that is the case, then a tremendous amount of time
by various participants has been wasted.
 
I'm sorry I took the statement in the charter of addressing accounting and
billing at face value :-(
 
I also suspect that this will do a lot of disservice to paying customers who
would like to employ this technology for business activities.
 
Perhaps at tomorrows meeting we can settle this.
 
Regards,
 
  Jeff Meyer

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]]
Sent: Wednesday, November 20, 2002 11:42 AM
To: Reinaldo Penno; Randy Bush
Cc: [email-masked]
Subject: RE: [ipfix] charter re-negotiation?

 
regards,
 
Reinaldo

-----Original Message-----
From: Penno, Reinaldo [BL60:0430:EXCH] 
Sent: Tuesday, November 19, 2002 6:20 PM
To: Randy Bush; Juergen Quittek
Cc: Tal Givoly; [email-masked]
Subject: RE: [ipfix] charter re-negotiation?

Randy, 

regards, 

Reinaldo