Subject: RE: [ipfix] Re: I-D ACTION:draft-ietf-ipfix-reqs-07.txt

From: "Carter Bullard" <[email-masked]>
Date: Wed, 13 Nov 2002 11:49:48 -0500

Hey Paul,
   I believe that your list of 4 items is missing
the critical reliability support mechanism that IPFIX
has in its list of requirements.   IMHO, the only
reliability mechanism that IPFIX needs.

   Receiver detection of IPFIX message loss.

   If the protocol supports this basic property, vendors
can then build reliable systems; as reliable as any
customer can afford.  Supplementing this with data
stream integrity mechanisms so that the receiver can
realize the nature of any loss, would be a dream
solution.

   What does this mean for the protocol?  Sequence
numbers and periodic stream integrity reports. Anything
else can be vendor improvements.   IMHO.

Carter

> -----Original Message-----
> From: majordomo listserver 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Wednesday, November 13, 2002 10:35 AM
> Cc: [email-masked]
> Subject: [ipfix] Re: I-D ACTION:draft-ietf-ipfix-reqs-07.txt
> 
> 
> 
> I'm left wondering what level of reliability is in scope?
> 
> It seems we a few people that agree a highly reliable 
> protocol is out of scope and several agreeing it is in 
> scope. Since one person from the former was wearing an AD 
> hat I'm left still uncertain of the outcome.
> 
> Is high reliability in scope or out of scope. If out
> of scope, to what level is in scope?
> 
> 	1. Transport level reliability
> 	2. Redundancy reliability (e.g. sending all data 
> 	   to multiple collectors or multicasting)
> 	3. Failover (i.e. detecting a collector is 
> 	   down and switching to another)
> 	4. Congestion awareness only (i.e. send and forget)
> 	
> What level of reliability is in scope?
> 
> Paul
> 
> --
> Help        mailto:[email-masked] and say "help" 
> in message body
> Unsubscribe mailto:[email-masked] and say 
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "Peter Ludemann" <[email-masked]>
Date: Thu, 14 Nov 2002 20:17:48 -0800

Carter:

Your statement could be true for one definition of reliability, but not for
full reliability with fail-over. For that, one needs *exporter" detection of
message loss (this could be caused by link failure or by collector failure -
that is, failure to acknowledge); the exporter can then fail-over to another
collector and retransmit unacknowledged records.

Probably we need multiple "levels" of reliability (I tried to define some in
a note a few days ago); reliability isn't a one-size-fits-all item and we
should have a protocol which can support the various kinds of reliability.

- peter

> From: majordomo listserver [mailto:[email-masked]]On Behalf
> Of Carter Bullard
> Sent: Wednesday, November 13, 2002 8:50 AM
> To: [email-masked]
> Subject: RE: [ipfix] Re: I-D ACTION:draft-ietf-ipfix-reqs-07.txt
>
>
> Hey Paul,