Subject: [ipfix-arch] Flow Keys versus Flow key

From: Benoit Claise <[email-masked]>
Date: Tue, 30 Nov 2004 12:42:45 +0100

Dear all,

There is a problem with use of the term "flow keys" versus "flow key" in the architecture draft.

The definition in both [IPFIX-ARCH] and [IPFIX-PROTO] is
 * Flow Key
      Each of the fields which
      1.  Belong to the packet header (e.g.  destination IP address)
      2.  Are a property of the packet itself (e.g.  packet length)
      3.  Are derived from packet treatment (e.g.  AS number)
      and which are used to define a Flow are termed Flow Keys.

The question boils down to: what is the flow key notion?
1. The flow key is the list of information elements?
   Example: 
	The flow keys are: source IP address, destination IP address, and DSCP
2. Or the flow key is the set of all information elements?
   Example: 
	The flow key is: {source IP address, destination IP address, DSCP}

Personally, I prefer the option 2. 
- as this is the way it has been known in NetFlow
- as this corresponds to the definition.
Note that [IPFIX-PROTO] is consistent with the option 2

However, [IPFIX-ARCH] use the term "flow key" (option 1)
- "If the Flow Key is defined as {source IP address, destination IP address, DSCP}, ..."
- "This could be done by defining the Flow Key as {source IP address, destination IP address, DSCP}"

I would propose to change those the sentences to:
- "If the Flow Keys are defined as {source IP address, destination IP address, DSCP}, ..."
- "This could be done by defining the Flow Keys as {source IP address, destination IP address, DSCP}"

Feedback?

Regards, Benoit.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 30 Nov 2004 16:06:11 +0100

Dear all,

The difference in usage is that option 2 uses the term 'flow key' for the
entire set of flow properties that determine whether or not a packet is
mapped to a flow.

In contrast, option 1 uses the term 'flow key for each individual member
of this set.

In previous (ancient?) discussions we used option 2, for example
<http://ipfix.doit.wisc.edu/archive/1557.html>

Also RFC 2722 (and 2063) use option 2 and so does the NetFlow
terminology.  We might confuse people if we now choose the
other option.

Thanks,

     Juergen
-- 
Juergen Quittek        [email-masked]       Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.netlab.nec.de

--On 30.11.2004 12:42 h +0100 Benoit Claise wrote:

>    Example: 	The flow keys are: source IP address, destination IP address, and DSCP
>    Example: 	The flow key is: {source IP address, destination IP address, DSCP}
>
>
> Personally, I prefer the option 2. - as this is the way it has been known in NetFlow