Subject: Re: [ipfix-info] boolean

From: Stewart Bryant <[email-masked]>
Date: Tue, 04 Jan 2005 13:56:14 +0000

I agree.

Stewart

Benoit Claise wrote:

> Dear all,
> 
> Our description of the boolean is not complete
> 
> 3.1.6  boolean
>   The type "boolean" represents a binary value.
> 
> I propose to extend it, to make compliant with:
>      RFC 2579:
>          TruthValue ::= TEXTUAL-CONVENTION
>              STATUS       current
>              DESCRIPTION
>                  "Represents a boolean value."
>              SYNTAX       INTEGER { true(1), false(2) }
> 
> 3.1.6  boolean
>   The type "boolean" represents a binary value.
>   The value 1 represents true. The value 2 represents false.
> 
> The value 0/1 for false/true seems a nice solution. However, the 0 is 
> the most likely value of an uninitialized data variable. It was one of 
> the justification why SMIv1 didn't allow an enumerated value of 0.
> 
> 
> Regards, Benoit.
> 
> 
> -- 
> Help        mailto:[email-masked] and say "help" in message 
> body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
> 
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: prarch <[email-masked]>
Date: Tue, 04 Jan 2005 21:35:57 -0500

A new start up company located in New York, NY in VoIP/Telephony software 
space is looking for software architects and developers.

  1.. Network Management Software product architects
  2.. SNMP/MIB architects and developers
  3.. Voice application product architects
  4.. Voice protocol architects and developers
  5.. Application GUI architects and developers
  6.. Technical marketing and product engineering
  7.. Sales engineers

Please send your resume to [email-masked]

----- Original Message ----- 
From: "Stewart Bryant" <[email-masked]>
To: "Benoit Claise" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, January 04, 2005 8:56 AM
Subject: Re: [ipfix-info] boolean

>> The value 0/1 for false/true seems a nice solution. However, the 0 is the 
>> most likely value of an uninitialized data variable. It was one of the 
>> justification why SMIv1 didn't allow an enumerated value of 0.
>>
>>
>> Regards, Benoit.
>>
>>
>> --