Subject: RE: [ipfix-protocol] Encoding of IPFIX Data Types

From: "STEPHAN Emile RD-CORE-LAN" <[email-masked]>
Date: Tue, 3 May 2005 15:10:26 +0200

Dear Stewart, Lutz

I suggest that section 6.2 defines the reduced size encoding not only for integer but for string and array too. That will clarify the link to section 6.2 in section "3.2 Field Specifier". 

Regards
Emile
> -----Message d'origine-----
> De : majordomo listserver [mailto:[email-masked]] De la part
> de Stewart Bryant
> Envoyé : mardi 3 mai 2005 14:22
> À : Lutz Mark
> Cc : [email-masked]
> Objet : Re: [ipfix-protocol] Encoding of IPFIX Data Types
> 
> 
> 
> Lutz Mark wrote:
> 
> >
> >  > 6.1.5   string and octetarray
> >  >
> >  >   The data type string represents a finite length string of valid
> >  >   characters of the Unicode character encoding set.  It is expected
> >  >   that strings will be encoded in UTF-8 format. The string is sent as
> >  >   an array of octets.  The length of the string and the octetArray is
> >  >   encoded as described in Section 7 (Variable Length Information
> >  >   Element).  The length is followed by that many octets as encoded in
> >  >   the length.
> >
> > The section implies that you have to use variable length IEs to
> > export strings and octetarrays (or does the text mean that you
> > have to send the length twice? It's not clear to me).
> 
> 
> There are three possible ways to send a string:
> 
> 1) Fixed length
> 2) Short variable length
> 3) Long variable length.
> 
> In case 1, you put the length in the template and the string
> is always that length, and if your string is shorter you have
> to pad.
> 
> In case 2 and 3 you use a special length value in the template
> which says that the length is encoded at the start of the string.
> 
> > I suggest to change the text to allow the export of strings and
> > octetarrays in an IE of fixed length.
> >
> > For example:
> >
> >    The data type string represents a finite length string of valid
> >    characters of the Unicode character encoding set. It is expected
> >    that strings will be encoded in UTF-8 format. The string is sent as
> >    an array of octets. The length of the information element
> >    specifies the length of the octedarray.
> 
> This is only true for fixed length strings.
> 
> Regards
> 
> Stewart
> 
> >
> > Regards,
> > Lutz
> >
> >
> > --
> > Help        mailto:[email-masked] and say "help" in message
> > body
> > Unsubscribe mailto:[email-masked] and say
> > "unsubscribe ipfix" in message body
> > Archive     http://ipfix.doit.wisc.edu/archive/
> >
> >
> 
> --
> Help        mailto:[email-masked] and say "help" in message
> body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Lutz Mark <[email-masked]>
Date: Wed, 04 May 2005 14:09:18 +0200

> I suggest that section 6.2 defines the reduced size encoding not only for integer but for string and array too. That will clarify the link to section 6.2 in section "3.2 Field Specifier". 

for me this makes sense.

Lutz

---

From: Benoit Claise <[email-masked]>
Date: Thu, 12 May 2005 12:09:00 +0200

Emile,

Draft changed.

 6.2      Reduced Size Encoding of Integer Types 
 
   Information Elements containing integer, _string, and octetarray_ types
   in the information model MAY be encoded using fewer octets than those 
   implied by their type in the information model definition [IPFIX-INFO],  
   based on the assumption that the smaller type is sufficient to carry 
   any value the Exporter may need to deliver.  

Regards, Benoit.