Subject: RE: [ipfix] dateTimeNanoSeconds

From: "Thomas Dietz" <[email-masked]>
Date: Tue, 26 Jul 2005 11:09:36 +0200

Dear Jon,

I see your point. The data type of dateTimeNanoSecond should represent the
date/time in the unit of nanoseconds. So the word "precision" is not the
right term anyway. (BTW. This should be changed in all the other dateTime...
data types, too) The data type cannot give the precision because the
precision depends on the device. The representation of the value in NTP
format has the problem that it just gives the fractional part of a second
and can only represent steps of about 233 picoseconds.

The conclusion is that we need to rephrase the dateTimeNanoSeconds part and
will come up with a new version within the next few days.

Best Regards,

Thomas

-- 
Thomas Dietz                       E-mail: [email-masked]
Network Laboratories               Phone:  +49 6221 90511-28
NEC Europe Ltd.                    Fax:    +49 6221 90511-55
Kurfuersten-Anlage 36
69115 Heidelberg, Germany          http://www.netlab.nec.de

> -----Original Message-----
> From: majordomo listserver 
> [mailto:[email-masked]] On Behalf Of Jon Kåre Hellan
> Sent: Friday, July 15, 2005 2:49 PM
> To: [email-masked]
> Subject: [ipfix] dateTimeNanoSeconds
> 
> Hi
> 
> Here's how the draft protocol specification defines
> dateTimeNanoSeconds:
> 
> > 6.1.8   dateTimeNanoSeconds 
> >    
> >   The data type of dateTimeNanoSeconds represents a time 
> value having 
> >   a precision of nanoseconds and normalized to the GMT 
> timezone.  It 
> >   is encoded in a 64-bit integer according to the NTP 
> format given in 
> >   [RFC1305].  The high-order 32-bits represent the number 
> of seconds 
> >   1900 and the low-order 32-bits represent the fractional 
> seconds with 
> >   the fraction ranging from 0 - 2^(32-1) / 2^32.  This 
> gives a maximum 
> >   precision of about 200 picoseconds. 
> 
> Two problems here:
> 
> 1. Both the first and the last sentence appear to define the 
> precision,
>    inconsistently. Changing the the first sentence to read "a 
> precision in
>    the order of nanoseconds" would fix this.
> 
> 2. The range of the fraction given is approximately 0 - 0.5
>    seconds. The intention is probably (0 - (2^32) - 1) / 2^32.
> 
> Regards
> 
> Jon Kåre Hellan, UNINETT
> 
> --
> Help        mailto:[email-masked] and say "help" 
> in message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
>

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 26 Jul 2005 11:34:25 +0200

> will come up with a new version within the next few days.

It looks like rephrasing is needed for the info model as well.
Let's try to come up with a consistent suggestion for both.

    Juergen

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/