Subject: [ipfix-info] mplsTopLabelEntry -> mplsTopLabeStackEntry

From: Benoit Claise <[email-masked]>
Date: Thu, 14 Jul 2005 17:01:14 +0200

Hi Juergen,

I'm wondering whether the following I.E. should not be called mplsTopLabeStackEntry:
- to be inline with mplsLabelStackEntry* 
- to avoid the confusion that the label is not the label stack entry
 
5.5.13  mplsTopLabelEntry

   Description:
      The label, exp and s fields from the top MPLS label stack entry,
      i.e. the last label that was pushed.

       0                   1                   2
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |                Label                  | Exp |S|
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Regards, Benoit.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 15 Jul 2005 00:55:47 +0200

Benoit,

> I'm wondering whether the following I.E. should not be called mplsTopLabeStackEntry:

I would prefer mplsTopLabelStackEntry.
                          ^
> - to be inline with mplsLabelStackEntry*

Currently it is in line with
   200  mplsTopLabelTtl
   203  mplsTopLabelExp

> - to avoid the confusion that the label is not the label stack entry

To be consewquent, we should also change #200 and #203:
The TTL is not part of the label but of the LabelStackEntry.
The same holds for the Exp field.

Any suggestions?

Thanks,

    Juergen

---

From: Benoit Claise <[email-masked]>
Date: Fri, 15 Jul 2005 01:21:43 +0200

Hi Juergen,

> I would prefer mplsTopLabelStackEntry.

Sure ;)

> The same holds for the Exp field.

Yes, I agree.

Regards, Benoit.