Subject: [ipfix] padding spec

From: Juergen Quittek <[email-masked]>
Date: Tue, 09 Aug 2005 03:09:55 +0200

Eliza,

Thank you for collecting issues detected at the interop.
I have a question on one of the comments on the info model:

> PaddingOneOctet
> If the record is very small, less than 4 octets
> (e.g. TOS is 1 octet) and you want to export it
> with padding then
>   ? 3 times PaddingOneOctet in your template
>   ? We suggest to have PaddingOctetsand the length
>     is the number of octets
>
>   ? Change the name and remove the restriction
>     in the draft

I am fine with changing the name of IE #220 from
paddingOneOctet to paddingOctets.  But how do you
want to have your other issue solved: "remove the
restriction".  I guess that you address the data
type that currently is 'octet'.  Doe you suggest
using 'octetArray'?

Thanks,

    Juergen
-- 
Juergen Quittek        [email-masked]       Tel: +49 6221 90511-15
NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.netlab.nec.de

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Jeroen Massar <[email-masked]>
Date: Tue, 09 Aug 2005 09:25:55 +0200

> type that currently is 'octet'.  Doe you suggest

Speaking from my view and not for Elisa (who btw might have only limited
connectivity during the coming days due to vacation...)

The above sounds fine but it could also be solved as simply saying that
the datatype is repeated by length <n>.

Greets,
 Jeroen

---

From: Paul Aitken <[email-masked]>
Date: Tue, 09 Aug 2005 08:40:10 +0100

Juergen,

> I am fine with changing the name of IE #220 from paddingOneOctet to
> paddingOctets.

Or indeed, just "padding" since other IE's don't generally have their 
length ("One") or type ("Octet") specified in their name.

> But how do you want to have your other issue solved: "remove the 
> restriction".  I guess that you address the data type that currently
> is 'octet'.  Doe you suggest using 'octetArray'?

Fine.

Cheers.
-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.