Subject: RE: [ipfix] Floating point numbers in IPFIX

From: "Bora Akyol" <[email-masked]>
Date: Tue, 3 Jan 2006 17:19:35 -0800

Hi Juergen

With unsigned64, what is the driver for requiring floating point
numbers?

Regards,

Bora

> 
> Currently, we have octet, unsigned16, unsigned32, unsigned64, 
> and float32.
> 
> New type names would be signed8, signed16, signed32, 
> signed64, and floast64.
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Paul Aitken <[email-masked]>
Date: Thu, 05 Jan 2006 00:56:08 +0000

Bora,

> With unsigned64, what is the driver for requiring floating point

It's useful for accurately specifying PSAMP probabilities.

Cheers.
-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 05 Jan 2006 10:02:12 +0000

> It's useful for accurately specifying PSAMP probabilities.

Also for reporting mean, variance etc

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 05 Jan 2006 11:19:46 +0100

Hi Bora,

Floats have different properties concerning precision
than Integers.  For example, for probability values
in the range [0,1] very small values smaller than 1e-6,
can be represented with higher precision.  Also the
mapping of an Integer to the interval [0,1] requires
additional definition and confusing and error-prone
conversion operations when you use the IE.

Thanks,

    Juergen