Subject: [ipfix] question

From: "João Paulo Vieira Olival" <[email-masked]>
Date: Wed, 04 Jan 2006 15:17:41 +0000

Hi there!

I have one question, concerning the flow records that are 
sent to the collecting process.
I have a list of the current flows. When a flow expires, 
its information is sent to another list (expired flow 
list) and in my case that expired list only accept 3 
elements. When the list is full, all 3 elements (3 flow 
records) are sent to the collecting process.
My question is: The size of that expired list has to obey 
to any condition or we're free to choose its size?

Thanks for your attention,
João Olival

------------------------------------------

João Paulo Veira Olival

Institute of Telecommunications - Aveiro

3810-193 AVEIRO - PORTUGAL
Phone: +351 91 8626391

e-mail: [email-masked]

------------------------------------------

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Paul Aitken <[email-masked]>
Date: Thu, 05 Jan 2006 00:55:02 +0000

João,

> I have one question, concerning the flow records that are sent to the 
> collecting process.
> I have a list of the current flows. When a flow expires, its information 
> is sent to another list (expired flow list) and in my case that expired 
> list only accept 3 elements. When the list is full, all 3 elements (3 
> flow records) are sent to the collecting process.
> My question is: The size of that expired list has to obey to any 
> condition or we're free to choose its size?

If the flows contain relative timestamps (eg, 
flowStartDeltaMicroSeconds, flowEndDeltaMicroSeconds) then all three 
flows need timestamps within the same 2^32 microseconds timeframe and 
must be exported within 2^32 microseconds of the IPFIX header timestamp.

But it's not a problem if you use absolute timestamps.

Otherwise the size of the list seems to be an implimentation decision, 
so you can impliment whatever works for you.

Cheers.
-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.