Subject: RE: [ipfix] Floating point numbers in IPFIX

From: "Carsten Schmoll" <[email-masked]>
Date: Fri, 10 Feb 2006 12:19:44 +0100

Completely agree. 

-----Original Message-----
From: Thomas Dietz [mailto:[email-masked]] 
Sent: Friday, February 10, 2006 12:18 PM
To: Paul Aitken; Carsten Schmoll
Cc: Benoit Claise; Andrew Johnson; [email-masked]; Elisa Boschi
Subject: RE: [ipfix] Floating point numbers in IPFIX

Carsten and all,

I think Paul is right. This should be taken to the implementation
guidelines
since this is not directly a protocol issue.

Thomas

-- 
Thomas Dietz
Network Laboratories, NEC Europe Ltd., 69115 Heidelberg, Germany

> -----Original Message-----
> From: Paul Aitken [mailto:[email-masked]] 
> Sent: Friday, February 10, 2006 11:47 AM
> To: Carsten Schmoll
> Cc: Thomas Dietz; Benoit Claise; Andrew Johnson; 
> [email-masked]; Elisa Boschi
> Subject: Re: [ipfix] Floating point numbers in IPFIX
> 
> Carsten,
> 
> > I think the reduction of precision is unavoidable (depending on the 
> > concrete exported value). Therefore I would suggest some text like:
> > 
> > "When using reduced encoding for double or float types make 
> sure that
> > the potential loss of precision due to the smaller mantissa is
> > acceptable for your application."
> 
> That sounds like an appropriate point for the implimentation guide?
> 
> -- 
> Paul Aitken
> Cisco Systems Ltd, Edinburgh, Scotland.
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 10 Feb 2006 11:36:15 +0000

>since this is not directly a protocol issue.
Yes - permission to do it if you want and what it means if you
get a smaller length in the template than you were expecting
belongs in the protocol definition, but when you do it and
what the implications are is an implementation guideline.

- Stewart