Subject: RE: [ipfix] signed data types for the info model

From: "Schmoll, Carsten" <[email-masked]>
Date: Wed, 19 Apr 2006 14:59:21 +0200

Jürgen,

I support adding them to the info model.
Don't forget about signed8 + 64 types.

related question 1: 
 should we say somewhere that floating point types are always signed?

related question 2:
 Is there any special care to be taken when transmitting signed
 numbers using reduced size encoding? (anyway, if so then a
 sentence about it would need to go to the impl guidelines draft)

Regards,
Carsten.

> -----Original Message-----
> From: majordomo listserver 
> [mailto:[email-masked]] On Behalf Of Juergen Quittek
> Sent: Wednesday, April 19, 2006 2:20 PM
> To: [email-masked]
> Subject: [ipfix] signed data types for the info model
> 
> Dear all,
> 
> While editing the info model, I found a note that we discussed
> adding signed data types.  We do not need them now, but several
> WG members suggested having them in order to be open for future
> extensions.
> 
> I suggest adding signed16 and signed32.
> 
> Are there any objections or suggestions for alternative choices?
> 
> Thanks,
> 
>     Juergen
> 
> --
> Help        mailto:[email-masked] and say "help" 
> in message body
> Unsubscribe mailto:[email-masked] and say
> "unsubscribe ipfix" in message body
> Archive     http://ipfix.doit.wisc.edu/archive/
> 
> 

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 19 Apr 2006 15:34:25 +0200

Hi Carsten,

> Don't forget about signed8 + 64 types.

Shall we call it signed8 or signedOctet?
currently we only have octet and not unsigned8.

I do not see a real need for signed64.
This is hardly used even as data type in programs.

>  should we say somewhere that floating point types are always signed?

We are referring to IEEE.754.1985 that fully specifies the range.
In programming languages float use to be signed.  In never
saw an unsigned float.

>  sentence about it would need to go to the impl guidelines draft)

If we agree on having signed types in the info model, we need to
update the encoding section in the protocol document.  We need to add
a section 6.1.2. on encoding signed data types and we need to add
a paragraph to section 6.2 Reduced Size Encoding of Integer Types
on how to reduce the size of signed data types.

Thanks,

    Juergen

---

From: Benoit Claise <[email-masked]>
Date: Thu, 27 Apr 2006 15:05:02 +0200

Carsten,
>  sentence about it would need to go to the impl guidelines draft)
We do have in [IPIFX-PROTO].

   The same signed versus unsigned property MUST 
   be preserved. 

After discussing with Juergen, we came up with a better sentence.
	The signed versus unsigned property of the reported value MUST be preserved.   

Regards, Benoit.