Subject: RE: [ipfix] signed data types for the info model

From: "Schmoll, Carsten" <[email-masked]>
Date: Wed, 19 Apr 2006 15:45:49 +0200

Some more small comments inline:

> > I support adding them to the info model.
> > Don't forget about signed8 + 64 types.
> 
> Shall we call it signed8 or signedOctet?
> currently we only have octet and not unsigned8.

Then I would say to go for signedOctet.

> I do not see a real need for signed64.
> This is hardly used even as data type in programs.

Ok. I can do without sugned64. All the 64bit values 
in use are counters and they all are clearly unsigned.

> > related question 1:
> >  should we say somewhere that floating point types are 
> always signed?
> 
> We are referring to IEEE.754.1985 that fully specifies the range.

Ok. Then it is already well defined. No need for extra text.

> If we agree on having signed types in the info model, we need to
> update the encoding section in the protocol document.  We need to add
> a section 6.1.2. on encoding signed data types and we need to add
> a paragraph to section 6.2 Reduced Size Encoding of Integer Types
> on how to reduce the size of signed data types.

Yep. I can suggest some added text there when you have a new 
version of the info model to refer.

Kind regards,
Carsten.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 25 Apr 2006 16:42:15 +0100

> in use are counters and they all are clearly unsigned.

... but it's only a few lines of trivial text and it
completes the specification.

Just to contrive a use, suppose you were reporting the
difference in bytes over the elements of path split,
i.e. A-B, then you would need signed64.

- Stewart

- Stewart