Subject: RE: [ipfix] signed data types for the info model

From: "Schmoll, Carsten" <[email-masked]>
Date: Tue, 25 Apr 2006 18:34:26 +0200

Dear Stewart, 

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]] 

> > Carsten wrote:
> > Ok. I can do without signed64. All the 64bit values 
> > in use are counters and they all are clearly unsigned.
> > 
> 
> ... but it's only a few lines of trivial text and it
> completes the specification.
> 
> Just to contrive a use, suppose you were reporting the
> difference in bytes over the elements of path split,
> i.e. A-B, then you would need signed64.
> 
> - Stewart

I'm fine with both, and I see your point.

The question is really whether we go for briefness
or for completeness. It is similar to the do-we-need-floats-
discussion. I agree adding those few lines will not hurt,
nor make any implementation more complicated.

It would be something like 

"
3.1.x  signed64

   The type "signed64" represents an integer value in the range of
   -9223372036854775808 to 9223372036854775807.
"

and

"
3.1.y   float64 
    
   The float64 data type MUST be encoded as an IEEE double-precision 
   64-bit floating point-type, as specified in [IEEE.754.1985]. 
"

respectively (which is already in the protocol draft as 6.1.4).

@Jürgen,

one really minor typo in the ipfix-info-11 draft:

3.1.6.  boolean

   The type "boolean" represents a binary value.  The only allowed
   values are "true" and false.
                        "     "   are missing.
                      ^^^^^^^^^^^^

Regards,
Carsten.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 25 Apr 2006 18:06:30 +0100

Looks good.

My desire for completeness of the basic types is to make
sure that there is consistency amongst the IEs defined outside
the WG by the IETF and by vendors.

- Stewart

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 25 Apr 2006 20:25:04 +0200

>    values are "true" and false.

Fixed.

Thanks,

    Juergen

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 25 Apr 2006 20:23:35 +0200

Hi Stewart and Carsten,

To conclude: We add the following data types to the IPFIX info model:

    signed8     (I don't think anymore that signedOctet is a reasonable type name)
    signed16
    signed32
    signed64
    float64.

Benoit,  would you update the encoding section in the protocol document?
We need to add a section 6.1.2. on encoding signed data types and we need
to add a paragraph to section 6.2 "Reduced Size Encoding of Integer Types"
on how to reduce the size of signed data types.

Thanks,

    Juergen