Subject: [ipfix-info] Request for new I.E. MPLSL3VpnRouteDistinguisher

From: Benoit Claise <[email-masked]>
Date: Thu, 01 Jun 2006 09:41:34 +0200

Dear all, 

I would like to request a new I.E.

MPLSL3VpnRouteDistinguisher
 
    Description:
 	The route distinguisher ensures that the same address can be used in several
        different MPLS VPNs, and that it is possible for BGP to carry several completely
        different routes to that address, one for each VPN. If this MPLS label is
        registered due to VRF-specific routing, this information element represents the 
        route distinguisher associated with the particular VRF. According to [RFC4364]
        the route distinguisher is encoded into a string of 8 octets.
   Abstract Data Type: string
   Data Type Semantics: identifier
   ElementId: 90
   Status: current
   Reference:      
      See RFC 4364 [RFC4364] for the route distinguisher specification.
      See RFC 4382 [RFC4382] for the specification of the MPLS/BGP Layer 3
      Virtual Private Network (VPN) Management Information Base.

Notes:
- this I.E. is currently in the reserved ElementId range. However, I think it would benefit everybody
- it should be added in the "Sub-IP Header Fields" section.

Regards, Benoit.

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 01 Jun 2006 11:15:59 +0200

Hi Benoit,

> MPLSL3VpnRouteDistinguisher

Why is there a '3' in the name?

If we keep it consistent with other MPLS IEs, the first four letters
would be lower case letters.

>         registered due to VRF-specific routing, this information element represents the         route distinguisher associated with the particular VRF. According to [RFC4364]
>    Reference:            See RFC 4364 [RFC4364] for the route distinguisher specification.

No problem. We can take it our of the reserved range.

> - it should be added in the "Sub-IP Header Fields" section.

Fine.

Thanks,

   Juergen

---

From: Benoit Claise <[email-masked]>
Date: Thu, 01 Jun 2006 13:38:30 +0200

Hi Juergen,
> Why is there a '3' in the name?
To match MplsL3VpnRouteDistinguisher in RFC4382.
Now, no big deal if you want to remove it.

Regards, Benoit.
>>         registered due to VRF-specific routing, this information 
>> element represents the         route distinguisher associated with 
>> the particular VRF. According to [RFC4364]

---

From: kobayashi atsushi <[email-masked]>
Date: Fri, 02 Jun 2006 12:28:50 +0900

Dear Benoit,

It is good idea. It is useful for monitoring VPN customer's traffic and
we can easily extract informations of MPLS-VPN-MIB.

Regards,
Atsushi KOBAYASHI

On Thu, 01 Jun 2006 09:41:34 +0200

> - it should be added in the "Sub-IP Header Fields" section.

--- 
Atsushi KOBAYASHI  <[email-masked]>
NTT Information Sharing Platform Lab.
tel:+81-(0)422-59-3978 fax:+81-(0)422-59-5652