Subject: [ipfix-info] TCP Flag counter

From: "Tanja Zseby" <[email-masked]>
Date: Tue, 18 Jul 2006 11:23:54 +0200

Hi Jürgen,

as discussed last week at the IETF we propose to add the following IEs to the INFO-Model. 
We can also provide the XML description if you want.

as extension of 5.10. "Per-Flow Counters":

5.10.x.  tcpSynTotalCount

    Description:
       The total number of packets of this flow with
       TCP synchronize sequence numbers flag set.
    Abstract Data Type: unsigned64
    Data Type Semantics: totalCounter
    ElementId: to be assigned
    Status: current
    Units: packets

5.10.x.  tcpFinTotalCount

    Description:
       The total number of packets of this flow with
       TCP finish flag set.
    Abstract Data Type: unsigned64
    Data Type Semantics: totalCounter
    ElementId: to be assigned
    Status: current
    Units: packets

5.10.x.  tcpRstTotalCount

    Description:
       The total number of packets of this flow with
       TCP reset flag set.
    Abstract Data Type: unsigned64
    Data Type Semantics: totalCounter
    ElementId: to be assigned
    Status: current
    Units: packets

5.10.x.  tcpPshTotalCount

    Description:
       The total number of packets of this flow with
       TCP push flag set.
    Abstract Data Type: unsigned64
    Data Type Semantics: totalCounter
    ElementId: to be assigned
    Status: current
    Units: packets

5.10.x.  tcpAckTotalCount

    Description:
       The total number of packets of this flow with
       TCP acknowledgment flag set.
    Abstract Data Type: unsigned64
    Data Type Semantics: totalCounter
    ElementId: to be assigned
    Status: current
    Units: packets

5.10.x.  tcpUrgTotalCount

    Description:
       The total number of packets of this flow with
       TCP urgent pointer flag set.
    Abstract Data Type: unsigned64
    Data Type Semantics: totalCounter
    ElementId: to be assigned
    Status: current
    Units: packets

Regards,
Tanja

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: Paul Aitken <[email-masked]>
Date: Tue, 18 Jul 2006 10:46:37 +0100

Tanja, Jürgen,

This is good, but we also need equivalent delta counters too.

Cheers.
P.

-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

---

From: Gerhard Muenz <[email-masked]>
Date: Tue, 18 Jul 2006 11:50:41 +0200

Hi Tanja,

Is there a reason for defining total counter and not delta counter? I
asume delta counter are easier to handle at the probe.

Sorry, I only followed the counter discussion on the jabber minutes. So
maybe I missed something.

Regards,
Gerhard

-- 
Dipl.-Ing. Gerhard Münz
Computer Networks and Internet
Wilhelm Schickard Institute for Computer Science
University of Tuebingen
Auf der Morgenstelle 10C 9P16, D-72076 Tuebingen, Germany
Phone: +49 7071 29-70534 / Fax: +49 7071 29-5220
EMail: [email-masked]
WWW:   http://net.informatik.uni-tuebingen.de/~muenz