Subject: [ipfix] Re: [ippm] IPFIX AS /IPPM

From: Juergen Quittek <[email-masked]>
Date: Fri, 04 Aug 2006 11:03:02 +0200

Hi Emile,

--On 28.07.2006 16:39 Uhr +0200 STEPHAN Emile RD-CORE-LAN wrote:

> Hi,
>
> I reread IPFIX AS regarding IPPM aspects.
>
> I think that it (section 2.5) may refer to the RFCs which define the
> IPPM metrics presented.
>
> As IPFIX (section 2.7) can also be used to transfer metrics result I

What are "metrics results"?  Is this correct IPPM terminology?

> consider that the Applicability Statement has to propose to transfer the
> result conjointly with its corresponding metric identifier in the IANA
> IPPM registry
> (http://www.iana.org/assignments/ianaippmmetricsregistry-mib).

Yes, you are right, this is a potential application area of IPFIX.
Still, it needs exploration.  Main work would be specifying information
elements for reporting results of the specified measurements.
This has not been done yet, but might be a potential future work item
for IPFIX or IPPM.

Thanks,

    Juergen

> Note that the draft
> http://tools.ietf.org/wg/ippm/draft-ietf-ippm-multimetrics/ includes
> pure passive metrics. So there will be metric identifiers for passive
> metrics in the IANA IPPM metrics registry.
>
>
> Regards
> Emile
>
>
>
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ippm

--
Help        mailto:[email-masked] and say "help" in message body
Unsubscribe mailto:[email-masked] and say
"unsubscribe ipfix" in message body
Archive     http://ipfix.doit.wisc.edu/archive/

---

From: "Tanja Zseby" <[email-masked]>
Date: Fri, 4 Aug 2006 11:35:44 +0200

Hi Jürgen,

in our IPIFX implementation we already have defined some (vendor specific) IEs for reporting QoS metrics. We are working on a short technical report on this. So we could provide the descriptions of the QoS IEs.  

Regards,
Tanja

> -----Original Message-----
> From: Juergen Quittek [mailto:[email-masked]] 
> Sent: Friday, August 04, 2006 11:25 AM
> To: Tanja Zseby; STEPHAN Emile RD-CORE-LAN; 
> [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [ippm] IPFIX AS /IPPM
> 
> Hi Tanja,
> 
> --On 02.08.2006 10:35 Uhr +0200 Tanja Zseby wrote:
> 
> > Hi Emile,
> >
> > the IPPM RFCs are already mentioned in section 2.5. in 
> version 09 of the docuemnt.
> > Using the IANA numbers from the IPPM registry sound like a 
> good idea.
> > Does this mean that we probably could use the IANA numbers for the 
> > metrics directly as element identifier for the IPFIX 
> information elements?
> > Jürgen, is this possible with the IPFIX info model? e.g. using 
> > ianaIppmMetrics in the same way as an enterprise ID?
> 
> This would be an option to be considered.  However, the IANA 
> numbers identify metrics, not results from measurements 
> according to a metric.  We would have to investigate whether 
> or not a one-to-one mapping from metric identifier to an 
> information element carrying measured results would make sense.
> 
> There might be a need to have more than one information 
> element for a single metrics, for example, when time is 
> measured.  In the current information model we have different 
> elements for reporting the same time information with 
> different precisions (nanoseconds, microseconds, 
> milliseconds, seconds).
> 
> Anyway, it looks like a useful task to specify IPFIX 
> information elements for reporting measurements according to 
> IPPM metrics.  Which numbers to assign to these elements 
> would be just one issue to be solved within this task.
> 
> Thanks,
> 
>     Juergen
> 
> > Regards,
> > Tanja
> >
> >
> >> -----Original Message-----
> >> From: STEPHAN Emile RD-CORE-LAN 
> [mailto:[email-masked]]
> >> Sent: Friday, July 28, 2006 4:40 PM
> >> To: [email-masked]; [email-masked]
> >> Cc: [email-masked]
> >> Subject: [ippm] IPFIX AS /IPPM
> >>
> >> Hi,
> >>
> >> consider that the Applicability Statement has to propose 
> to transfer 
> >> the result conjointly with its corresponding metric 
> identifier in the 
> >> IANA IPPM registry 
> >> http://tools.ietf.org/wg/ippm/draft-ietf-ippm-multimetrics/
> >> includes pure passive metrics. So there will be metric identifiers 
> >> for passive metrics in the IANA IPPM metrics registry.
> >>
> >>
> >> Regards
> >> Emile
> >>
> >>
> >>