Subject: [IPFIX] Exporint options data packet

From: "Bhuvaneswari R P - TLS ,Chennai" <[email-masked]>
Date: Wed, 2 May 2007 15:20:25 +0530

Can anyone inform me at what frequency should a netflow
Collector send options data packet?

Regards,
Bhuvana.

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Paul Aitken <[email-masked]>
Date: Wed, 02 May 2007 11:17:26 +0100

Bhuvana,

> Collector send options data packet?

Zero. Collectors receive, they don't send. Exporters send options to 
Collectors.

If the option pertains to data records, then the option should be sent 
before those data records to ensure the collector can decode the 
received data records.

However, if the option data isn't directly related to data records (eg, 
it's system meta-data) then it can be sent whenever you like. Perhaps on 
a regular basis, or perhaps only when the information changes.

It also depends on how reliable the transport is and how important the 
data is. ie, the less reliable the transport, the more often you'll want 
to send the data.

-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

---

From: Paul Aitken <[email-masked]>
Date: Wed, 02 May 2007 11:17:26 +0100

Bhuvana,