Subject: [IPFIX] some notes on draft-morton-ippm-delay-var-as-03

From: "Schmoll, Carsten" <[email-masked]>
Date: Fri, 17 Aug 2007 17:53:59 +0200

Dear authors, 

I have recently read the ippm-delay-var-as
draft and believe it is on the right way.

For me it is clearly the most complete 
comparison PDV vs. IPDV up to now and very
helpful to understand the nitpicks of each definition.

Let me add a few observations from my own work
in this area here:

a) as PDV is clearly a shifted version of the 
   delay itself, its statistics can be directly
   derived from the delay (OWD) statistics when
   in addition the reference value is known. 
   Even though I believe it has its own justification and use.

b) For IPDV it would be nice to know, how symmetrical
   it is in practice. If it is very symmetric in 
   almost all cases then one might as well work 
   with the stats applied to abs(IPDV) only.
   If unsymmetric IPDV distributions appear then 
   one should present a positive and a negative high 
   percentile or something like inter-quartile range 
   as resulting statistics (in addition to mean IPDV in any case)

   Does anyone have results wrt. the symmetricity?

c) Esp. for IPDV it is not clear to me the effect
   of the packet selection function: Esp. the question:
   Does the size of the gaps between selected packets have an 
   influence on the distribution of the resulting IPDV values?

   (in theory yes (I could give an example), but in practice?)

I will have a more detailed look at the draft in the next
week and then write some specific comments as well.

In general I'd say the draft should be concluded 
with something like a table which recomends clearly 
the use of PDV or IPDV and suggested stats
per desired application.

Best regards so far and have a nice weekend,
Carsten.

--

### !! ATTENTION !! Change of email address! Please use in future only:
[email-masked] ###

"The difference between theory and practice is that in theory theory and
practice are the same but in practice they are not."

Dipl.Ing. Carsten Schmoll              Fraunhofer Institute FOKUS
[email-masked]    National Research Institute
Fraunhofer FOKUS / dept. NET           for Open Communication Systems
Tel: +49-30-3463-7136                  Kaiserin-Augusta-Allee 31
Fax: +49-30-3463-8136                  D-10589 Berlin, Germany 
_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: "Schmoll, Carsten" <[email-masked]>
Date: Mon, 20 Aug 2007 10:43:24 +0200

Dear all, 

I'm sorry, please ignore my previous post.
I incidentially posted on the wrong list.

If you like to reply to my comments on the 
ippm-delay-var-as draft then find it at the 
IPPM list as of today.

Regards,
Carsten.

> -----Original Message-----
> From: Schmoll, Carsten [mailto:[email-masked]] 
> Sent: Friday, August 17, 2007 5:54 PM
> To: [email-masked]
> Subject: [IPFIX] some notes on draft-morton-ippm-delay-var-as-03
> 
>

---

From: "Schmoll, Carsten" <[email-masked]>
Date: Mon, 20 Aug 2007 10:43:24 +0200

Dear all, 

Regards,
Carsten.