Subject: Re: [IPFIX] WG Last Call for draft-ietf-ipfix-testing-02

From: Paul Aitken <[email-masked]>
Date: Sun, 18 Nov 2007 21:32:21 +0000

Ronny,

Thanks for reviewing the draft.

> 1) I would seriously cut down on the "1. Introduction".
> You don't have to mention what IPFIX is about and why it was created
> (and mention UDP, TCP or even SCTP) and so on. Just link to the
> relevant RFCs.

Done: I reorganised and simplified the introduction.

> 2) Sec 3.1.1.
> "The transmitted data might be observed on-line with an appropriate
> tool such as Wireshark (www.wireshark.org)."
> 
> Please write the words "network sniffer" oder "packet sniffer" or
> something else there, so everybody knows what you are trying to say.

Good, done.

> 3) Sec 3.2.1.
> 
> "The tester MUST create a Template with a few fixed-size Information
> Elements..."
> 
> and later
> 
> " MUST use various Information Elements in the Template so that each
> data type...is used at least once"
> 
> How about make that simply:
> 
> "The tester MUST create Templates with fixed-size IEs where each data
> type defined in ... is used at least once."

Good suggestion, done.

> 4) 3.5.1.  Large number of Records for one Template
> 
> "The tester MUST export many Data Records to the Collecting Process"
> 
> how about add: "in order to put the Collecting Process under stress"
> or somesuch to make clear why this test is to be performed?

Well, it's in the "Stress/Load tests" section...

But done.

> 5) 3.6.5.
> 
> Illegal use of reduced size encoding/ <- I think this "/" is superfluous.

Fixed.

> That's about it.
> Cheers!
> Ronny

Thanks for your feedback!

-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

_______________________________________________
IPFIX mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipfix

---

From: Paul Aitken <[email-masked]>
Date: Sun, 18 Nov 2007 21:32:21 +0000

Ronny,

Good, done.

Good suggestion, done.

But done.

Fixed.