Subject: [IPFIX] [Technical Errata Reported] RFC5101 (1655)

From: RFC Errata System <[email-masked]>
Date: Tue, 20 Jan 2009 03:59:20 -0800 (PST)

The following errata report has been submitted for RFC5101,
"Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow Information".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5101&eid=1655

--------------------------------------
Type: Technical
Reported by: Paul Aitken <[email-masked]>

Section: A.4.4.

Original Text
-------------
   Line Card ID               | IPFIX Message  | Exported Flow Records
   -------------------------------------------------------------------
   Line Card 1 (lineCardId=1) | 345            | 10201
   Line Card 2 (lineCardId=2) | 690            | 20402

Corrected Text
--------------
   Enterprise field 123 | exportedPacketCount | exportedFlowCount
   -------------------------------------------------------------------
   1                    | 345                 | 10201
   2                    | 690                 | 20402

Notes
-----
The example in A.4.4 uses set ID 260 which is defined in the template in A.4.3. 
Therefore the fields used in A.4.4 must be those defined in A.4.3.
Fortunately the field lengths are correct, so no other change is required.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the veFrom [email-masked]  Tue Jan 20 04:01:10 2009
Date: Tue, 20 Jan 2009 03:59:20 -0800 (PST)
To: [email-masked], [email-masked], [email-masked],
	[email-masked], [email-masked]
From: RFC Errata System <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: [IPFIX] [Technical Errata Reported] RFC5101 (1655)
Sender: [email-masked]

The following errata report has been submitted for RFC5101,
"Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow Information".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5101&eid=1655

--------------------------------------
Type: Technical
Reported by: Paul Aitken <[email-masked]>

Section: A.4.4.

Original Text
-------------
   Line Card ID               | IPFIX Message  | Exported Flow Records
   -------------------------------------------------------------------
   Line Card 1 (lineCardId=1) | 345            | 10201
   Line Card 2 (lineCardId=2) | 690            | 20402

Corrected Text
--------------
   Enterprise field 123 | exportedPacketCount | exportedFlowCount
   -------------------------------------------------------------------
   1                    | 345                 | 10201
   2                    | 690                 | 20402

Notes
-----
The example in A.4.4 uses set ID 260 which is defined in the template in A.4.3. 
Therefore the fields used in A.4.4 must be those defined in A.4.3.
Fortunately the field lengths are correct, so no other change is required.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the rifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5101 (draft-ietf-ipfix-protocol-26)
--------------------------------------
Title               : Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow Information
Publication Date    : January 2008
Author(s)           : B. Claise, Ed.
Category            : PROPOSED STANDARD
Source              : IP Flow Information Export
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG
_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5101 (draft-ietf-ipfix-protocol-26)
--------------------------------------
Title               : Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow Information
Publication Date    : January 2008
Author(s)           : B. Claise, Ed.
Category            : PROPOSED STANDARD
Source              : IP Flow Information Export
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG
_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 Jan 2009 13:04:15 +0100

Authors and Chairs - what is your advice, please?  

Dan

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]] 
> Sent: Tuesday, January 20, 2009 1:59 PM
> To: [email-masked]; Romascanu, Dan (Dan); 
> [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Technical Errata Reported] RFC5101 (1655)
> 
> 
> "Specification of the IP Flow Information Export (IPFIX) 
> Protocol for the Exchange of IP Traffic Flow Information".
> 
> This errata is currently posted as "Reported". If necessary, 
> please use "Reply All" to discuss whether it should be 
> verified or rejected. When a decision is reached, the 
> verifying party (IESG) can log in to change the status and 
> edit the report, if necessary. 
> 
> Title               : Specification of the IP Flow 
> Information Export (IPFIX) Protocol for the Exchange of IP 
> Traffic Flow Information

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 Jan 2009 13:04:15 +0100

Dan

---

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Jan 2009 13:14:15 +0100

Dan,

This correction makes sense.
Note: Paul and I discussed this one before posting the technical errata. ;-)

Regards, Benoit.

---

From: Benoit Claise <[email-masked]>
Date: Tue, 20 Jan 2009 13:14:15 +0100

Dan,

Regards, Benoit.

---

From: Brian Trammell <[email-masked]>
Date: Tue, 20 Jan 2009 13:25:28 +0100

Dan, all,

Have looked over this and agree, the correction makes sense.

Regards,

Brian

On Jan 20, 2009, at 1:14 PM, Benoit Claise wrote:

>>> From: RFC Errata System [mailto:[email-masked]] Sent:  
>>> Tuesday, January 20, 2009 1:59 PM
>>> To: [email-masked]; Romascanu, Dan (Dan); [email-masked]; [email-masked] 
>>> ; [email-masked]
>>> "Specification of the IP Flow Information Export (IPFIX) Protocol  
>>> for the Exchange of IP Traffic Flow Information".
>>>
>>> The example in A.4.4 uses set ID 260 which is defined in the  
>>> template in A.4.3. Therefore the fields used in A.4.4 must be  
>>> those defined in A.4.3.
>>> please use "Reply All" to discuss whether it should be verified or  
>>> rejected. When a decision is reached, the verifying party (IESG)  
>>> Title               : Specification of the IP Flow Information  
>>> Export (IPFIX) Protocol for the Exchange of IP Traffic Flow  
>>> Information

---

From: Brian Trammell <[email-masked]>
Date: Tue, 20 Jan 2009 13:25:28 +0100

Dan, all,

Regards,

Brian

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 Jan 2009 13:28:16 +0100

Thanks, unless I hear any objection soon I will proceed and approve it. 

Dan

> From: Brian Trammell [mailto:[email-masked]] 
> Sent: Tuesday, January 20, 2009 2:25 PM
> To: Romascanu, Dan (Dan)
> Cc: IETF IPFIX Working Group; [email-masked]; Nevil 
> Brownlee; [email-masked]; RFC Errata System; Benoit Claise
> Subject: Re: [IPFIX] [Technical Errata Reported] RFC5101 (1655)
> 
> Dan, all,
> 
> >>> To: [email-masked]; Romascanu, Dan (Dan); [email-masked]; 
> >>> [email-masked] ; [email-masked]
> >>> template in A.4.3. Therefore the fields used in A.4.4 
> must be those 
> >>> defined in A.4.3.
> >>> rejected. When a decision is reached, the verifying party 
> (IESG) can 
> >>> log in to change the status and edit the report, if necessary.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 20 Jan 2009 13:28:16 +0100

Dan

---

From: Nevil Brownlee <[email-masked]>
Date: Wed, 21 Jan 2009 13:59:18 +1300

Yes, I agree that this correction makes sense, and should be done.

Cheers, Nevil

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

And now, on another matter ..

Benoit and Paul, can you now make a list of the other errors in 5101
that need fixing, e.g. IEs 58, 59 status is deprecated ?
This seems to be the best way to initiate an IANA action to fix them
in the IE Registry.

After that (for registry errors in 'new' IEs), I think we should
submit them to IANA in the same way we submit requests for new IEs.
Can you also prepare a list of the changes needed for that?
Please send me a draft of that list, and I'll check with Michelle
that they can handle registry changes in that way.

Cheers again, Nevil

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand
_______________________________________________
IPFIX mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ipfix

---

From: Nevil Brownlee <[email-masked]>
Date: Wed, 21 Jan 2009 13:59:18 +1300

Cheers, Nevil

Cheers again, Nevil