Subject: Re: [IPFIX] IPFIX-MIB: comments to AD review

From: Benoit Claise <[email-masked]>
Date: Sat, 21 Mar 2009 16:39:48 -0700

Gerhard,

Personally, I have a small preference for "parallel"

Regards, Benoit.
> One more:
>
> ipfixExportMemberType OBJECT-TYPE
>     SYNTAX      INTEGER {
>                     unknown(0),
>                     primary(1),
>                     secondary(2),
>                     parallel(3),
>                     loadBalancing(4)
>                 }
>     MAX-ACCESS  read-only
>     STATUS      current
>     DESCRIPTION
>         "The type of a member Transport Session in a Transport
>         Session group (identified by the value of ipfixExportIndex,
>         ipfixObservationDomainId and ipfixMeteringProcessCacheId).
>         The following values are valid:
>
>         unknown(0)
>             This value MUST be used if the status of the group
>             membership cannot be detected by the equipment. This
>             value should be avoided as far as possible.
>
>
>
>         primary(1)
>             This value is used for a group member that is used as
>             the primary target of an Exporter. Other group members
>             (with the same ipfixExportIndex and
>             ipfixMeteringProcessCacheId) MUST NOT have the value
>             primary(1) but MUST have the value secondary(2).
>             This value MUST also be specified if the Exporter does
>             not support Transport Session grouping.In this case the
>             group contains only one Transport Session.
>
>         secondary(2)
>             This value is used for a group member that is used as a
>             secondary target of an Exporter. The Exporter will use
>             one of the targets specified as secondary(2) within the
>             same Transport Session group when the primary target is
>             not reachable.
>
>         duplicate(3)
>             This value is used for a group member that is used for
>             duplicate exporting i.e., all group members identified
>             by the ipfixExportIndex are exporting the same Records
>             in parallel. This implies that all group members MUST
>             have the the same membertype duplicate(3).
>
>         loadBalancing(4)
>             This value is used for a group member that is used as
>             as one target for load-balancing. This means that a
>             Record is sent to one of the group members in this
>             group identified by ipfixExportIndex.
>             This implies that all group members MUST have the same
>             membertype load-balancing(4)."
>     ::= { ipfixExportEntry 2 }
>
>
> Do you prefer duplicate or parallel for value 3?
>
>   
> ------------------------------------------------------------------------
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix
>

---

From: Gerhard Muenz <[email-masked]>
Date: Sun, 22 Mar 2009 12:29:43 +0100

Benoit,

> Personally, I have a small preference for "parallel"

Yes, "parallel" is better because "duplicate" suggests that there are
two collectors (although there might be several ones).

My main point was that it is currently not consistent in SYNTAX and
DESCRIPTION.

Cheers,
Gerhard