Subject: Re: [IPFIX] IPFIX-MIB: ipfixMeteringProcessMessages, ipfixMeteringProcessErrors, ipfixMeteringProcessDataRecords

From: "Thomas Dietz" <[email-masked]>
Date: Mon, 9 Mar 2009 12:29:31 +0100

Dear Benoit, Atsushi, all,

I think Gerhard is right. If nobody objects I will remove those objects in
the upcoming version 07.

Best Regards,

Thomas

-- 
Thomas Dietz                 E-mail: [email-masked]
NEC Europe Ltd.              Phone:  +49 6221 4342-128
NEC Laboratories Europe      Fax:    +49 6221 4342-155
Network Research Division
Kurfuersten-Anlage 36
69115 Heidelberg, Germany    http://www.nw.neclab.eu

NEC Europe Limited           Registered in England 2832014
Registered Office: NEC House, 1 Victoria Road, London W3 6BL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Gerhard Muenz
> Sent: Mittwoch, 25. Februar 2009 15:12
> To: [email-masked]
> Subject: [IPFIX] IPFIX-MIB: ipfixMeteringProcessMessages,
> ipfixMeteringProcessErrors, ipfixMeteringProcessDataRecords
> 
> 
> Thomas, Benoit,
> 
> I do not understand why the following statistics are associated to the
> Metering Process:
> 
> ipfixMeteringProcessMessages OBJECT-TYPE
>     SYNTAX      Counter32
>     MAX-ACCESS  read-only
>     STATUS      current
>     DESCRIPTION
>         "The number of IPFIX messages transmitted."
>     ::= { ipfixMeteringProcessStatsEntry 3 }
> 
> ipfixMeteringProcessErrors OBJECT-TYPE
>     SYNTAX      Counter32
>     MAX-ACCESS  read-only
>     STATUS      current
>     DESCRIPTION
>         "The number of messages that could not be sent due to e.g.
>         internal buffer overflows or network congestion."
>     ::= { ipfixMeteringProcessStatsEntry 4 }
> 
> The Metering Process does not generate or transmit any IPFIX Messages.
> Also, IPFIX Messages including Data Records of a specific Metering
> Process can be sent to different collectors resulting in different
> Message errors.
> 
> I think the two counters should be removed. The Transport Session
> statistics are sufficient.
> 
> It is interesting to count the Data Records *generated* (not
> transmitted) by a Metering Process. Therefore, the following
> DESCRIPTION
> should be changed:
> 
> ipfixMeteringProcessDataRecords OBJECT-TYPE
>     SYNTAX      Counter32
>     MAX-ACCESS  read-only
>     STATUS      current
>     DESCRIPTION
>         "The number of Data Records transmitted."
>     ::= { ipfixMeteringProcessStatsEntry 5 }
> 
> Regards,
> Gerhard
> 
> --
> Dipl.-Ing. Gerhard Münz
> Chair for Network Architectures and Services (I8)
> Department of Informatics
> Technische Universität München
> Boltzmannstr. 3, 85748 Garching bei München, Germany
> Phone:  +49 89 289-18008       Fax: +49 89 289-18033
> E-mail: [email-masked]    WWW: http://www.net.in.tum.de/~muenz
>

---

From: Benoit Claise <[email-masked]>
Date: Sat, 21 Mar 2009 16:36:37 -0700

Dear all,

Gerhard is right.
First of all, the Metering Process doesn't "transmit" or "sent".
Secondly, we have the ipfixTransportSessionMessages and 
ipfixTransportSessionDiscardedMessages counters, which do the job
So I'm in favor of removing ipfixMeteringProcessMessages and 
ipfixMeteringProcessErrors

Regards, Benoit.
> ------------------------------------------------------------------------
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix
>