Subject: [IPFIX] minor comments on ipfix-psamp.yang

From: Andy Bierman <[email-masked]>
Date: Fri, 20 Mar 2009 18:32:46 -0700

Hi,

These are just some bugfix comments for the ipfix-psamp YANG module.
Half of them are due to recent changes in YANG syntax.

  - module name:
    should be changed from ipfix-psamp to ietf-ipfix-psamp

  - imports:
    s/yang-types/ietf-yang-types/
    s/inet-types/ietf-inet-types/

  - leaf startAS, leaf stopAS:
    s/autonomous-system-number/as-number/

  - grouping transportSessionParameters;
    after description-stmt: extra tokens '";'

  - most must-stmts:
    need single quotes around string values
    OLD:
       must "../cacheType!=permanent";
    NEW:
       must "../cacheType!='permanent'";

  - should fill in many missing description statements
    before RFC publication

FYI, an updated version can be found here:

http://www.netconfcentral.com/src/ipfix-psamp.2009-03-02.yang

Andy

---

From: Gerhard Muenz <[email-masked]>
Date: Sat, 21 Mar 2009 13:48:45 +0100

Hi Andy,

Thanks a lot for validating the module. Your improvements will be
adopted in the next draft version.

Regards,
Gerhard

Andy Bierman wrote:
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Andy Bierman <[email-masked]>
Date: Sat, 21 Mar 2009 08:01:15 -0700

> adopted in the next draft version.

no problem.
thanks for providing a 'real' data model to test with.

forgot 1 more:  s/keyref/leafref/

Andy