Subject: [IPFIX] IPFIX-MIB: Separation of MIB modules (was: T21 from AD review)

From: "Thomas Dietz" <[email-masked]>
Date: Mon, 9 Mar 2009 12:36:15 +0100

Dear all,

Dan raised the following issue in the AD review:

> T21. I assume that selection functions will be added in the future. If I
> am wrong please delete all mention of extensibility and take out the
> ipfixSelectorFunctions group. If I am right, I suggest to put
> ipfixSelectorFunctions in a separate MIB module that will be IANA
> maintained, so that new functions can be added in the future without the
> need to revise the MIB module and the RFC. The separate MIB module will
> become the initial version of the IANA maintained module, and new
> selector functions will be added using for example Expert Review policy.

I personally think it is a good idea to put the selector functions in a
separate MIB module (still defined in the same draft) and put that module
under control of IANA. I would propose further to make additions subject to
Expert Review policy.

If you agree with this procedure I would make those changes for the upcoming
version 07. If you think different please speak up.

Best Regards,

Thomas

-- 
Thomas Dietz                 E-mail: [email-masked]
NEC Europe Ltd.              Phone:  +49 6221 4342-128
NEC Laboratories Europe      Fax:    +49 6221 4342-155
Network Research Division
Kurfuersten-Anlage 36
69115 Heidelberg, Germany    http://www.nw.neclab.eu

NEC Europe Limited           Registered in England 2832014
Registered Office: NEC House, 1 Victoria Road, London W3 6BL

---

From: Benoit Claise <[email-masked]>
Date: Sat, 21 Mar 2009 16:24:32 -0700

Thomas,

This makes a lot of sense to me.

Regards, Benoit.
> ------------------------------------------------------------------------
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix
>