Subject: Re: [IPFIX] [MIB-DOCTORS] AD review of draft-ietf-ipfix-mib-05.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 16 Apr 2009 09:38:30 +0200

Thomas,

I do not think that the pending issues T19 and T21 were addressed
properly in  draft-ietf-ipfix-mib-06.txt

See in-line my concerns. 

Thanks and Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Romascanu, 
> Dan (Dan)
> Sent: Wednesday, March 18, 2009 3:57 PM
> To: Thomas Dietz; IETF IPFIX Working Group
> Cc: MIB Doctors (E-mail)
> Subject: Re: [MIB-DOCTORS] [IPFIX] AD review of 
> draft-ietf-ipfix-mib-05.txt
> 
> Thank you for addressing my comments. Most of the issues were 
> acknowledged and fixed accordingly. T19 and T21 still need 
> discussion, while T23 needs to be acknowledged by the other editors. 
> 
> My question to the WG chairs is whether we should send the 
> document to IETF Last Call, considering the open issues as 
> Last Call issues, to be answered and resolved together with 
> other Last Call comments we receive.
> 
> 
> Dan
>  
> 
> > -----Original Message-----
> > From: Thomas Dietz [mailto:[email-masked]]
> > Sent: Monday, March 09, 2009 1:26 PM
> > To: Romascanu, Dan (Dan); IETF IPFIX Working Group
> > Cc: MIB Doctors (E-mail)
> > Subject: RE: [IPFIX] AD review of draft-ietf-ipfix-mib-05.txt
> > 
> > Dear Dan, all,
> > 
> > find my comments inline...
> > 
> > 
> > > T19. I cannot understand what useful information carries 
> > > ipfixmeteringProcessId - it is not an index and its value is 
> > > implementation dependent.
> > 
> > We wanted to give a kind of ID to make it possible to identify the 
> > process that creates the Flow Records. This may be a process id or 
> > something similar. Maybe we should specify it as process id. This 
> > needs further discussion.
> > 

This does not seem to be addressed. The object with the current
DESCRIPTION clause would not help an implementer understand what is the
information to be placed in or a manager to know what to do with it. 

> > 
> > > T21. I assume that selection functions will be added in the
> > future. If
> > > I am wrong please delete all mention of extensibility and
> > take out the
> > > ipfixSelectorFunctions group. If I am right, I suggest to put 
> > > ipfixSelectorFunctions in a separate MIB module that will be IANA 
> > > maintained, so that new functions can be added in the
> > future without
> > > the need to revise the MIB module and the RFC. The separate
> > MIB module
> > > will become the initial version of the IANA maintained
> > module, and new
> > > selector functions will be added using for example Expert Review 
> > > policy.
> > > 
> > > 
> > 
> > I personally think this makes sense to put it in a separate 
> MIB module 
> > which is maintained by IANA but this needs further 
> discussion on the 
> > list which I will start soon.

This does not seem to be addressed  From your response it looked like
you agreed that moving ipfixSelectorFunctions to a separate
IANA-maintained module would be a good idea. Yet, I see that the group
is still present in the current MIB, and although it includes only one
object ipfixFuncSelectAllAvail - you would need to deprecate it when the
IANA-maintained MIB module shows up. This is cumbersome, I suggest to
take it out as the object does not provide any useful information any
way, from the DESCRIPTION clause it is always at value true.

---

From: "Thomas Dietz" <[email-masked]>
Date: Thu, 16 Apr 2009 09:43:26 +0200

Dear Dan,

you are right we need a revised version of the draft. Meanwhile we agreed
that for T19 the object will be deleted. For T21 we need to put up the text
and the extra MIB module in the draft. I will do that asap.

Best Regards,

Thomas

-- 
Thomas Dietz                 E-mail: [email-masked]
NEC Europe Ltd.              Phone:  +49 6221 4342-128
NEC Laboratories Europe      Fax:    +49 6221 4342-155
Network Research Division
Kurfuersten-Anlage 36
69115 Heidelberg, Germany    http://www.nw.neclab.eu

NEC Europe Limited           Registered in England 2832014
Registered Office: NEC House, 1 Victoria Road, London W3 6BL
> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: Donnerstag, 16. April 2009 09:38
> To: Romascanu, Dan (Dan); Thomas Dietz; IETF IPFIX Working Group
> Cc: MIB Doctors (E-mail)
> Subject: RE: [MIB-DOCTORS] [IPFIX] AD review of draft-ietf-ipfix-mib-
> 05.txt
> 
> Thomas,
>