Subject: [IPFIX] 2 bugs in ietf-ipfix-psamp.yang

From: Andy Bierman <[email-masked]>
Date: Mon, 09 Nov 2009 12:53:56 -0800

Hi,

I use your data model to test my YANG compiler.
It is complaining about the latest version.

In 'list selectionProcess', the must-stmt has an
extra right parenthesis at the end.

Within that list, 'list selector' has a unique-stmt
for a non-config leaf (selectorId), even though that
list is config=true.

I am not sure this is an error though.
I cc:ed the NETMOD WG because it
is not clear if yang-08, sec 8.* covers this usage.

I think a config=true node can only define constraints
on other config=true nodes.  If this is not the case,
then the YANG draft (sec 8.1) should make that clear.
The data-not-unique error does not apply,
but the YANG text in sec. 13.1 does not make that clear.

thanks,
Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 10 Nov 2009 00:31:54 +0100 (CET)

> I am not sure this is an error though.

No it is ok.

> is not clear if yang-08, sec 8.* covers this usage.

Section 7.8.3. says:

   If one of the referenced leafs represents configuration data, then
   all of the referenced leafs MUST represent configuration data.

This requirment is clearly fulfilled in this case.

Section 8.1 says:

   o  If the constraint is defined on state data, it MUST be true in a
      reply to the <get> command.

This constraint is defined for state data, so it is ok.

> but the YANG text in sec. 13.1 does not make that clear.

I will fork this thread here, since I suspect that the discussion on
these details might not be of general interest.  So I will respond to
this on the NETMOD list only.

/martin

---

From: Gerhard Muenz <[email-masked]>
Date: Tue, 10 Nov 2009 10:17:56 +0100

Hi Andy,

> extra right parenthesis at the end.

Thanks. There should be a left parenthesis before "count" in the same 
must statement.

Regards,
Gerhard