Subject: Re: [IPFIX] WG last call on draft-ietf-ipfix-mediators-problem-statement-06

From: "Juergen Quittek" <[email-masked]>
Date: Mon, 2 Nov 2009 11:22:30 +0100

Hi Sujay,

Thank you for the review.

On 31.10.09 08:27  "sujay gupta" <[email-masked]> wrote:

> Hi,
> A few comments.
> 1) I have a slight problem overall with the language structuring
> especially from section 1 to 4. It could be made simple.

Would you have concrete suggestions? This would be helpful.

Thanks,

    Juergen

> 2) IPFIX mediation as a service or device? is intermixed, can we
> differentiate that? also can we call the different type of mediators
> as services?
> 3) Is there any line of thought of having the mediation device
> incorporate record compression to reduce b/w?(
> draft-muenz-ipfix-compression) as another service, or deal with
> compressed data from the original exporter?
> BR,
> -Sujay
> 
> 
> On Mon, Oct 19, 2009 at 10:32 AM, Juergen Quittek <[email-masked]>
> wrote:
>> Dear all,
>> 
>> At our session in Stockholm we agreed to start the 2nd working group
>> last call on the mediation problem state as soon as a new version
>> of it would be available. The new version is
>> 
>> http://www.ietf.org/internet-drafts/draft-ietf-ipfix-mediators-problem-state
>> ment-06.txt
>> 
>> The call starts today and will last until Friday October 30.
>> 
>> Please read the draft!
>> Please send your comments to this mailing list!
>> Please also send a message if you are fine with the draft as it is!
>> 
>> Thank you,
>> 
>>    Juergen
>> 
>> _______________________________________________
>> IPFIX mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ipfix
>> 
>>

---

From: sujay gupta <[email-masked]>
Date: Tue, 3 Nov 2009 23:44:55 +0530

Hi,

I am overall fine with the doc.

small changes however would help such as;
section 4.1, last para mentions the need of system not relying on
data reduction techniques, section 4.4 contradicts it.

section 1, first para, between first and second line could mention
that "traffic monitoring is taxing on the resources" and hence the need
for optimization( ie the 2nd line).
last line in the para says "platform", is it required?

perhaps having a figure showing the position of ipfix-med amongst
other layers( section 2)
would be a nice addition.

BR,
-Sujay

---

From: Atsushi Kobayashi <[email-masked]>
Date: Tue, 10 Nov 2009 20:14:16 +0900

Hi Sujay,

Thank you for your feedback.
Please see in-line.

On Tue, 3 Nov 2009 23:44:55 +0530

> data reduction techniques, section 4.4 contradicts it.

I will change section 4.4 last para. Is it OK?

4.4.  Summary

   In adjusting some parameters to the resources of a measurement
   system, it is important to use traffic data reduction techniques as
   early as possible, e.g., at the Exporter.  However, this
   implementation is made difficult by heterogeneous environment of
   exporting devices.  On the other hand, keeping data accuracy and flow
   granularity to meet the requirements of different monitoring
   applications requires a scalable and flexible collecting
   infrastructure.

> last line in the para says "platform", is it required?

I will change as follows. Is it OK?

1.  Introduction

   One advantage of Flow-based measurement results from easily offering
   the traffic monitoring of a huge amount of traffic.  While the usage
   is applied to any networks and to multiple measurement applications
   taxing on the resources of the measurement system, network
   administrators need to adjust some parameters of metering devices and
   of multiple measurement applications to these resources.  IP traffic
   growth and a wide variety of measurement application make the
   adjustment further difficult.  To make a measurement system flexible
   and scalable, an intermediate device can generally be applied to the
   system.

> would be a nice addition.

Does your suggestion imply the Figure B in framework draft?
http://tools.ietf.org/html/draft-ietf-ipfix-mediators-framework-04

Regards,
Atsushi
> > On 31.10.09 08:27 ?"sujay gupta" <[email-masked]> wrote:
> >
> >> Hi,
> >> A few comments.
> > ? ?Juergen
> >>> ? ?Juergen

--- 
Atsushi KOBAYASHI  <[email-masked]>
NTT Information Sharing Platform Lab.
tel:+81-(0)422-59-3978 fax:+81-(0)422-59-5637

---

From: sujay gupta <[email-masked]>
Date: Tue, 10 Nov 2009 21:31:40 +0530

Hi Atsushi,

I am fine with the changes, Yes I was suggesting the figure in .04
version, but it
seems it was removed for a good reason in the later drafts.
The description text is also sufficient to visualize it.

BR,
-Sujay