Subject: [IPFIX] review of draft-ietf-ipfix-mediation-protocol-05

From: Paul Aitken <[email-masked]>
Date: Mon, 01 Jul 2013 11:33:50 +0100

Here's a review of draft-ietf-ipfix-mediation-protocol-05.

The comments are all editorial.

>     However, thanks to its Template mechanism, the IPFIX protocol can
>     export any type of information, as long as the relevant Information
>     Element is specified in the IPFIX Information Model
>     [I-D.ietf-ipfix-information-model-rfc5102bis], registered with IANA,
>     or specified as an enterprise-specific Information Element.  The
>     specifications in the IPFIX protocol
>     [I-D.ietf-ipfix-protocol-rfc5101bis] have not been defined in the
>     context of an IPFIX Mediator receiving, aggregating, correlating,
>     anonymizing, etc... Flow Records fromthe one or multiple  Exporters.

Say, "from one or more Exporters".

>     IPFIX has a formal description of IPFIX Information Elements, their
>     name, type and additional semantic information, as specified in the
>     IPFIX Information Model
>     [I-D.ietf-ipfix-information-model-rfc5102bis].  The IPFIX Information
>     Element registry [iana-ipfix-assignments]registry  is maintained by

Remove the second "registry".

>                 Figure 3: Template Mapping example: templates
>
>     The Template Mapping corresponding tofigure 3  is displayed infigure
>     4:

Capitalise "Figure 3" and "Figure 4" for consistency.

Can you prevent the line break in "Figure 4" ?

>                 Figure 4: Template Mapping example: mappings
>
>     Alternatively, the Template Mapping may be optimized as infigure 5:

Capitalise "Figure 5" for consistency.

> 4.1.1.  Template Mapping and Information Element Ordering
>
>     In the situation where Original Exporters each export an (Options)
>     Template to a single IPFIX Mediator, and the (Options) Template
>     Record contains the same Information Elements but in different order,
>     should the IPFIX Mediator maintain a Template Mapping with a single
>     Export Template Record (seefigure 6) or should the IPFIX Mediator
>     maintain multiple independent Template Records (seefigure 7) before
>     re-exporting to the Collector?

Capitalise "Figure 6" and "Figure 7" for consistency.

>     o  Any combination or list of Information Elements representing
>        Observation Points.  For example:
>     o

Remove the additional bullet point.

>     Any combination of the above representations is possible.  An example
>     of an Original Observation Point for an Intermediate Aggregation
>     Process is displayed infigure 8.

Capitalise "Figure 8" for consistency.

>     The most generic way to export the Original Observation Point is to
>     use a subTemplateMultiList, with the semantic "exactlyOneOf".  Taking
>     the previous example, the encoding infigure 9  can be used.

Capitalise "Figure 9" for consistency.

>     Analogous to the Metering Process Reliability Statistics Options
>     Template, also specified in [I-D.ietf-ipfix-protocol-rfc5101bis],
>     Mediators SHOULD implement the Intermediate Process Reliability
>     Statistics Options Template, specified inthe  Section 10.1.

Remove "the".

> 10.1.  Intermediate Process Reliability Statistics Template

Name this "... Option Template" since it contains scope IEs, and for 
consistency with 10.2.

> 13.  IANA Considerations
>
>     This document specifies new IPFIX Information Elements,
>     originalExporterIPv4Address in Section 5.1,
>     originalExporterIPv6Address in Section 5.2,
>     originalObservationDomainId in Section 6.1, intermediateProcessId in
>     Section 10.3, and ignoredFlowRecordTotalCount in Section 10.4, to be
>     added to the IPFIX Information Element registry
>     [iana-ipfix-assignments].  [IANA NOTE: please add the five
>     Information Elements as specified in the references subsections,
>     change TBD1, TBD2, TBD3, TBD4, and TBD5 in this document to reflect
>     the assigned identifiers, put the Status as current, insert THISRFC
>     into theReuquester  entry, insert 0 for the Revision, and use the
>     current date for Date.]

Typo, "Requester".

>     Atsushi Kobayashi
>     NTT Information Sharing Platform Laboratories
>     3-9-11 Midori-cho
>     Musashino-shi, Tokyo 180-8585
>     Japan
>
>     Phone: +81 422 59 3978
>     Email: [email-masked]

Check whether this is still correct.

P.

---

From: Brian Trammell <[email-masked]>
Date: Thu, 4 Jul 2013 17:48:06 +0200

hi Paul,

Many thanks for the review; these have all been applied to the working copy of revision -06, which will be published post-WGLC.

Cheers,

Brian

On 1 Jul 2013, at 12:33 , Paul Aitken <[email-masked]> wrote:

>>    The Template Mapping corresponding to 
>> figure 3 is displayed in 
>> figure
>>    4
>> :
> 
>>    Export Template Record (see 
>> figure 6
>> ) or should the IPFIX Mediator
>>    maintain multiple independent Template Records (see 
>> figure 7
>> ) before
> Name this "... Option Template" since it contains scope IEs, and for consistency with 10.2.
> 
> 
> 
>> 13.  IANA Considerations
>> 
>>    into the 
>> Reuquester
>>  entry, insert 0 for the Revision, and use the
>>    current date for Date.]
>> 
> 
> Typo, "Requester".
> 
> 
>>    Atsushi Kobayashi
>> 
>>    Email: 
>> [email-masked]