Subject: [IPFIX] review of draft-ietf-behave-ipfix-nat-logging-00 - IPFIX Information Elements for logging NAT Events

From: Paul Aitken <[email-masked]>
Date: Fri, 02 Aug 2013 10:01:20 +0100

[resending due to an apparent IETF email outage?]

Senthil,

Here's a quick review of your draft from an IPFIX perspective:

* The [NAT-EVENT-LOG-IANA] reference is not referenced in the text, and 
the URL doesn't exist.
     If it's not needed, then remove the reference. If it's needed, then 
fix the URL :-)

* Where the tables include sizes of 1, 2, and 3 digits, the alignment is 
wrong (centralised?). Please right-align all the numbers.

* Terminology: define "IE" / "IE's" before section 2. eg, reference the 
terminology from 5101bis.

* Please be consistent about your usage of "IE" versus "Information 
Elements".

* Briefly introduce IPFIX in the Introduction section. eg:

    The IPFIX Protocol [RFC5101bis] defines a generic push mechanism for exporting information and events.
    The IPFIX Information Model [IANA-IPFIX] defines a set of standard Information Elements (IEs) which can be carried by the IPFIX protocol.
    This document details the IPFIX Information Elements that are required for logging by a NAT device and all the optional fields.
    The fields specified in this document are gleaned from [RFC4787  <http://tools.ietf.org/html/rfc4787>] and [RFC5382  <http://tools.ietf.org/html/rfc5382>].

* Note that 5101 and 5102 are both being updated by -bis drafts which 
are soon to be RFCs - so your Informative References should be updated.

* [IANA-IPFIX] == http://www.iana.org/assignments/ipfix/ipfix.xhtml
     This is now the definitive reference, rather than 5102 / 5102bis.

* Please write "NetFlow v9" rather than "Netflow 9" (ie, with a capital 
'F' and a 'v').

* IANA Considerations: if there are none, then say "there are no IANA 
considerations."

P.

---

From: "Senthil Sivakumar (ssenthil)" <[email-masked]>
Date: Fri, 2 Aug 2013 14:19:10 +0000

Paul,
Thanks for the review, I will incorporate the comments in the next revision.

Thanks
Senthil

From: "Paul Aitken (paitken)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, August 2, 2013 5:01 AM
To: Senthil Sivakumar <[email-masked]<mailto:[email-masked]>>
Cc: IETF IPFIX Working Group <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: review of draft-ietf-behave-ipfix-nat-logging-00 - IPFIX Information Elements for logging NAT Events

Senthil,

* The [NAT-EVENT-LOG-IANA] reference is not referenced in the text, and the URL doesn't exist.
    If it's not needed, then remove the reference. If it's needed, then fix the URL :-)

* Where the tables include sizes of 1, 2, and 3 digits, the alignment is wrong (centralised?). Please right-align all the numbers.

* Terminology: define "IE" / "IE's" before section 2. eg, reference the terminology from 5101bis.

* Please be consistent about your usage of "IE" versus "Information Elements".

   The IPFIX Protocol [RFC5101bis] defines a generic push mechanism for exporting information and events.
   The IPFIX Information Model [IANA-IPFIX] defines a set of standard Information Elements (IEs) which can be carried by the IPFIX protocol.
   This document details the IPFIX Information Elements that are required for logging by a NAT device and all the optional fields.
   The fields specified in this document are gleaned from [RFC4787<http://tools.ietf.org/html/rfc4787>] and [RFC5382<http://tools.ietf.org/html/rfc5382>].

* Note that 5101 and 5102 are both being updated by -bis drafts which are soon to be RFCs - so your Informative References should be updated.

* Please write "NetFlow v9" rather than "Netflow 9" (ie, with a capital 'F' and a 'v').

* IANA Considerations: if there are none, then say "there are no IANA considerations."

P.