Subject: [IPFIX] IPFIX at IETF 89, London

From: Nevil Brownlee <[email-masked]>
Date: Mon, 03 Feb 2014 21:08:50 +1300

Hi IPFIXers:

Back when session scheduling for IETF 89 started, I requested a
slot for IPFIX, "just in case."

Since then the Link-Layer Attributes and Mediation Protocol drafts
have been sent to the RFC Editor, and the text-adt draft is in WGLC.

We expect a new revision of the MIB Variable export draft shortly,
so that would be the only agenda item for London.  I feel that
version can be reviewed and discussed on the IPFIX list, so we
don't now need to have a formal IPFIX meeting in London.

If you believe that a meeting is needed, please email the list
telling us what that is, and why we need meeting time for it.
If I don't see such email(s) within the next week, we'll cancel
the meeting.

Cheers, Nevil

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: Paul Aitken <[email-masked]>
Date: Mon, 03 Feb 2014 10:39:54 +0000

Nevil,

I updated a couple of drafts. If the WG is to close, then I'll be 
looking for a new home for these, because this is important work which 
does need addressed:

aitken-ipfix-equivalent-ies 
<http://tools.ietf.org/html/draft-aitken-ipfix-equivalent-ies>

    This document specifies a method for an Exporter to inform a
    Collector of equivalence between different Information Elements, so
    that the Collecting Process can understand the equivalence and be
    enabled to process data across a change of Information Elements,
    which allows a seamless transition from Enterprise-specific to
    IANA-standard elements.

aitken-ipfix-unobserved-fields 
<http://tools.ietf.org/html/draft-aitken-ipfix-unobserved-fields>

    This draft discusses several methods for reporting when fields are
    unavailable, reviews the advantages and disadvantage of each, and
    recommends methods which should be used.
    Cisco has already implemented some of the mechanisms in this draft.

P.

---

From: Andrew Feren <[email-masked]>
Date: Mon, 3 Feb 2014 10:40:10 -0500

Hi All,

+1.  Those drafts need to be addressed.

-Andrew

On 02/03/2014 05:39 AM, Paul Aitken wrote:
>     Collector of equivalence between different Information Elements,
>     so that the Collecting Process can understand the equivalence and
>     be enabled to process data across a change of Information
>     Elements, which allows a seamless transition from
>     Enterprise-specific to IANA-standard elements.
>
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix

---

From: Nevil Brownlee <[email-masked]>
Date: Mon, 10 Feb 2014 12:14:18 +1300

Hi Paul, Andrew and IPFIXers:

Looking back at the IPFIX minutes for IETF-88 (Vancouver), we
said that "the WG will close when the current charter items are
complete."  The only remaining charter item is the MIB Variable
Export draft, current version is -03, 21 Oct 2013.  It's
disappointing that we haven't seen a revision of that draft in 2014;
when we have a new version, we should be able to start its WGLC.

Paul and Andrew were the only two who responded to my 2 Feb email.
Neither of the the two drafts they mentioned have been updated
since January 2014, and there's been no discussion of them on the
IPFIX list.  The same goes for the Cisco IEs draft, current version
-09, 15 Jan 2014.

Therefore, IPFIX will not hold a formal meeting in London, I'll
inform the secretariat that we're cancelling the IPFIX meeting.

Going forward from this ...

- of course we can have an informal get-together of IPFIX people
   in London - any volunteers to organise such a gathering?

- the IPFIX mailing list will remain open for quite some time,
   please use it to discuss anything relevant to IPFIX

Cheers, Nevil

-- 
---------------------------------------------------------------------
  Nevil Brownlee                          Computer Science Department
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: Paul Aitken <[email-masked]>
Date: Mon, 10 Feb 2014 10:32:21 +0000

Nevil,

> when we have a new version, we should be able to start its WGLC.

We're working on the next version.

> since January 2014,

Oh come on Nevil! One's dated Dec 27th, the other Dec 31st. How fresh do 
they need to be?

So I have these two drafts which I believe are important to IPFIX, and 
an independent second-opinion concurs. How can these drafts be progressed?

> and there's been no discussion of them on the IPFIX list.

I've presented these ideas in previous WG meetings, where the consensus 
was to wait for the next re-charter.
I'm sure they've been discussed on-list too.

P.

> The same goes for the Cisco IEs draft, current version -09, 15 Jan 2014.
>

---

From: Brian Trammell <[email-masked]>
Date: Mon, 10 Feb 2014 16:31:09 +0100

There are a couple of questions here: (1) do we close / lay dormant / recharter the working group (and what do we do with these two drafts)? and (2) do we have a meeting in London?

From my point of view I can say that both drafts are important, have clearly had a good deal of discussion, and are probably at this point of a quality that they could be adopted as WG items. We had an idea in Vancouver that further work could be AD sponsored if the IPFIX WG closed. Recent experience in trying to AD sponsor other IPFIX-related drafts were not appreciated by the IESG, so I don’t think that’s an option for these two. OPSAWG would be an option, but only if we definitively close IPFIX (otherwise the question is “why not recharter IPFIX”).

Separate is the meeting-in-London question. At least here I can say I will not attend the currently-scheduled IPFIX meeting in London as it conflicts with a BoF I’m co-chairing; we’ve already tried to de-conflict this with no luck.

Cheers,

Brian

On 10 Feb 2014, at 11:32, Paul Aitken <[email-masked]> wrote:

> Oh come on Nevil! One's dated Dec 27th, the other Dec 31st. How fresh do they need to be?
> 
> So I have these two drafts which I believe are important to IPFIX, and an independent second-opinion concurs. How can these drafts be progressed?
> 
> 
> I've presented these ideas in previous WG meetings, where the consensus was to wait for the next re-charter.

---

From: joel jaeggli <[email-masked]>
Date: Mon, 10 Feb 2014 07:47:28 -0800

On 2/10/14, 7:31 AM, Brian Trammell wrote:
> There are a couple of questions here: (1) do we close / lay dormant /
> recharter the working group (and what do we do with these two
> drafts)? and (2) do we have a meeting in London?

> From my point of view I can say that both drafts are important, have
> clearly had a good deal of discussion, and are probably at this point
> of a quality that they could be adopted as WG items. We had an idea
> in Vancouver that further work could be AD sponsored if the IPFIX WG
> closed. Recent experience in trying to AD sponsor other IPFIX-related
> drafts were not appreciated by the IESG, so I don’t think that’s an
> option for these two. 

Was not appreciated by some members of the IESG. under the circumstances
and for the document in question I think the method applied was entirely
apprpiate and that the results will speak for themselves.

> OPSAWG would be an option, but only if we
> definitively close IPFIX (otherwise the question is “why not
> recharter IPFIX”).
> 
> Separate is the meeting-in-London question. At least here I can say I
> will not attend the currently-scheduled IPFIX meeting in London as it
> conflicts with a BoF I’m co-chairing; we’ve already tried to
> de-conflict this with no luck.
> 
> Cheers,
> 
> Brian
> 
>>> disappointing that we haven't seen a revision of that draft in
>>> 2014; when we have a new version, we should be able to start its
>>> WGLC.
>> 
>>> Paul and Andrew were the only two who responded to my 2 Feb
>>> email. Neither of the the two drafts they mentioned have been
>>> updated since January 2014,
>> 
>> So I have these two drafts which I believe are important to IPFIX,
>> and an independent second-opinion concurs. How can these drafts be
>> progressed?
>> 
>> 
>> I've presented these ideas in previous WG meetings, where the
>> consensus was to wait for the next re-charter. I'm sure they've
>> been discussed on-list too.
>> 
>> 
>> P.
>> 
>> 
>>>> I updated a couple of drafts. If the WG is to close, then I'll
>>>> be looking for a new home for these, because this is important
>>>> work which does need addressed:
>>>> 
>>>> 
>>>> Collector of equivalence between different Information
>>>> Elements, so that the Collecting Process can understand the
>>>> equivalence and be enabled to process data across a change of
>>>> Information Elements, which allows a seamless transition from
>>>> unavailable, reviews the advantages and disadvantage of each,
>>>> and recommends methods which should be used. Cisco has already
>>>> implemented some of the mechanisms in this draft.
>>>> 
>>>> 
>>>> P.
>>>> 
>>>> 
>>>>> Back when session scheduling for IETF 89 started, I requested
>>>>> a slot for IPFIX, "just in case."
>>>>> 
>>>>> Since then the Link-Layer Attributes and Mediation Protocol
>>>>> drafts have been sent to the RFC Editor, and the text-adt
>>>>> draft is in WGLC.
>>>>> 
>>>>> We expect a new revision of the MIB Variable export draft
>>>>> shortly, so that would be the only agenda item for London.  I
>>>>> feel that version can be reviewed and discussed on the IPFIX
>>>>> list, so we don't now need to have a formal IPFIX meeting in
>>>>> London.
>>>>> 
>>>>> If you believe that a meeting is needed, please email the
>>>>> list telling us what that is, and why we need meeting time
>>>>> for it. If I don't see such email(s) within the next week,
>>>>> we'll cancel the meeting.
>>>>> 
>>>>> Cheers, Nevil
>>>>> 
>>>> 
>>>> 
>>> 
>>> 
>> 
>> _______________________________________________ IPFIX mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/ipfix
>

---

From: Brian Trammell <[email-masked]>
Date: Mon, 10 Feb 2014 17:41:33 +0100

hi Joel, all,

> apprpiate and that the results will speak for themselves.

Would like to make clear I’m not complaining in any way about the outcome. :) But it is less clear to me that shuttering the WG and AD-sponsoring the equivalent-ies and unobserved-fields work is an acceptable way to move forward than it was in Vancouver.

Cheers,

Brian

---

From: Nevil Brownlee <[email-masked]>
Date: Tue, 11 Feb 2014 10:01:17 +1300

Hi again Paul, Andrew and IPFIXers:

First, oops, I confused the publication year of your two drafts,
sorry about that.

Second, thanks for the news on the MIB Variables draft.  I realise
that we're all deadline-driven, but having draft updates only close
to the IETF meeting deadlines makes me nervous about the energy level
in the WG - which is why I didn't think there was much point in having
a WG meeting in London.

That said, I agree with Brian (below), the remaining question is how
best to proceed with your two drafts.  At this stage, I suggest that
  - We need to get the MIB variables draft submitted to IESG (or at
      least clearly on the path to submission), so as to comple our
      current charter.
  - Having done that, we can explore the question of whether the WG
      can take on any new drafts.

Had the MIB Variables draft update been published back in, say, January
this year, things would have looked a lot different now, sigh.

Cheers, Nevil

---

From: Benoit Claise <[email-masked]>
Date: Mon, 10 Feb 2014 13:22:20 -0800

On 10/02/2014 02:32, Paul Aitken wrote:
> consensus was to wait for the next re-charter.
Consensus, sure?
I checked the meeting minutes and I don't see that.
What I recall is that two different proposals were discussed 
(draft-aitken-ipfix-equivalent-ies and draft-inacio-ipfix-penie-00), 
with no clear winner.

Regards, Benoit

> .

---

From: Paul Aitken <[email-masked]>
Date: Mon, 10 Feb 2014 22:49:09 +0000

Benoit,

>> consensus was to wait for the next re-charter.

Yes: the work was interesting, but not relevant to the current charter. 
So, bring it up at the next recharter - which hasn't happened yet.

> (draft-aitken-ipfix-equivalent-ies and draft-inacio-ipfix-penie-00), 

Sure; each of these drafts has different merits. It would be up to the 
WG to decide on the best solution.

Look, here's a real problem in IPFIX which has resulted in not one but 
*two* different drafts trying to solve it in different ways. Do you 
propose to ignore it?

P.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 10 Feb 2014 16:50:21 -0800

Paul,

At this point, I will be listening to the chairs to see  ...
     if this is really "interesting",
     if there is enough support from the IPFIX community,
     if there is enough discussion on it,
     and if this work could be done in the decent time.

(*) I guess that I'm so much involved in IPFIX that I have strong 
opinions about your drafts. That's the price you pay for an AD who knows 
IPFIX by heart.

Regards, Benoit
> Yes: the work was interesting, but not relevant to the current 
> charter. So, bring it up at the next recharter - which hasn't happened 
> yet.
>
>

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 11 Feb 2014 09:01:42 +0000

Hi all,

> -----Original Message-----
> From: IPFIX [mailto:[email-masked]] On Behalf Of joel jaeggli
> Sent: Montag, 10. Februar 2014 16:47
> To: Brian Trammell; Paul Aitken
> Cc: [email-masked]; Nevil Brownlee; IPFIX Working Group; ipfix-
> [email-masked]
> Subject: Re: [IPFIX] IPFIX at IETF 89, London
> 
> > recharter the working group (and what do we do with these two drafts)?
> > and (2) do we have a meeting in London?
> 
> > of a quality that they could be adopted as WG items. We had an idea in
> > Vancouver that further work could be AD sponsored if the IPFIX WG
> > drafts were not appreciated by the IESG, so I don't think that's an
> > option for these two.
> 
> Was not appreciated by some members of the IESG. under the
> circumstances and for the document in question I think the method applied
> was entirely apprpiate and that the results will speak for themselves.

As far as I understood this issue, it was not appreciated by all IESG members, because there still was an IPFIX WG in place. If IPFIX is closed, I do not see how they could still have any problem.
    Juergen

> > OPSAWG would be an option, but only if we definitively close IPFIX
> > (otherwise the question is "why not recharter IPFIX").
> >
> > conflicts with a BoF I'm co-chairing; we've already tried to
> >>> Looking back at the IPFIX minutes for IETF-88 (Vancouver), we said
> >>> that "the WG will close when the current charter items are
> >>> Neither of the the two drafts they mentioned have been updated since
> >>> January 2014,
> >>
> >> consensus was to wait for the next re-charter. I'm sure they've been
> >> discussed on-list too.
> >>
> >>
> >> P.
> >>
> >>
> >>> - of course we can have an informal get-together of IPFIX people in
> >>> London - any volunteers to organise such a gathering?
> >>>
> >>>> looking for a new home for these, because this is important work
> >>>> which does need addressed:
> >>>>
> >>>>
> >>>> recommends methods which should be used. Cisco has already
> >>>>> telling us what that is, and why we need meeting time for it. If I
> >>>>> don't see such email(s) within the next week, we'll cancel the
> >>>>> meeting.
> >>>>>
> >>>>> Cheers, Nevil
> >>>>>
> >>>>
> >>>>
> >>>
> >>>
> >>

---

From: Andrew Feren <[email-masked]>
Date: Tue, 11 Feb 2014 21:43:57 +0000

Hi Benoit,

I think both topics are interesting, but if I had to pick one to put some work into it would be the unobserved fields draft.  There is a need to communicate this information (or lack of information ;-).  I am already starting to see exports where different vendors are choosing different ad hoc methods to communicate N/A for the same IEs.

As for draft-aitken-ipfix-equivalent-ies and draft-inacio-ipfix-penie, I'm mostly interested in anything that encourages exporters to "publish" info about the IEs they export.  Given the lack of uptake for 5610 I'm not optimistic that an alternate/updated version of 5610 will get any more traction.  Most of the time I'd be happy to get a text file with 7013 style Information Element Specifiers.

Just my 2 cents,
-Andrew
________________________________________
From: Benoit Claise [[email-masked]]
Sent: Monday, February 10, 2014 7:50 PM
To: Paul Aitken; Nevil Brownlee; Andrew Feren; IPFIX Working Group
Cc: [email-masked]; [email-masked]
Subject: Re: [IPFIX] IPFIX at IETF 89, London

Paul,

Regards, Benoit

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 12 Feb 2014 14:51:05 +0000

Dear all,

As technical contributor, I send my view on the two drafts from Paul:

The equivalent-ies draft is targeted at several use cases and with some of them I see need for discussion. I would have no problem with a standard that restricted to be only applied if an exporter changes the IE identifier without any other technical change, for example, after registering an enterprise-specific IE at IANA with a new number. But if this feature is used for other use cases as listed in the draft, I see a lot of issues that should be investigated. Two example issues are (1) exporters declaring "similar" IEs to be equivalent and (2) conflicting equivalence declarations from different exporters. There are more issues like these. Most of them can reduced to the core problem that the draft only defines a message format and not under which condition two IEs may or must not be declared equivalent.

For the unobserved-fields draft I see similar issues. The semantics is not fully clear and the same holds for implications on collectors. Does unobserved mean: I did not observe the IE, because there was no instance in any observed packet, because observation failed, because there is no instrumentation to observe the IE, or for any other reason. These are all different use case and there are more of them, maybe with more subtle differences, that need discussion.

My conclusion is, that I see both drafts addressing valid issues, but not as drafts to be finished soon. The both drafts look like good candidate an "experimental" RFCs, because "equivalence" of measurements and "unobserved" flow properties are concepts that may need time and operational experience to define them well.

Cheers,
    Juergen

> From: Benoit Claise [mailto:[email-masked]]
> Sent: Dienstag, 11. Februar 2014 01:50
> (*) I guess that I'm so much involved in IPFIX that I have strong opinions
> about your drafts. That's the price you pay for an AD who knows IPFIX by
> heart.
> 
> Regards, Benoit
> > Benoit,
> >

---

From: Benoit Claise <[email-masked]>
Date: Fri, 14 Feb 2014 14:49:41 -0500

Hi Andrew,
> As for draft-aitken-ipfix-equivalent-ies and draft-inacio-ipfix-penie, I'm mostly interested in anything that encourages exporters to "publish" info about the IEs they export.  Given the lack of uptake for 5610 I'm not optimistic that an alternate/updated version of 5610 will get any more traction.
You nailed it. This is my argument against 
draft-aitken-ipfix-equivalent-ies.
RFC 5610 is a nice mechanism for all the Exporters to send some IPFIX 
information (the  type of  enterprise(specific IEs) to the Collector, to 
basically plan nice.  In practice, do you see any implementation of it 
in your Collector?
I'm afraid that draft-aitken-ipfix-equivalent-ies would fall in the same 
category.

> Most of the time I'd be happy to get a text file with 7013 style Information Element Specifiers.
Yes, received a single time from the different vendors (as opposed from 
all the Exporters) and hard-coded in collectors. Note that some 
automation is possible if the format is agreed upon.

Regards, Benoit (as a contributor)