Subject: [IPFIX] I-D Action: draft-ietf-ipfix-mib-variable-export-05.txt

From: [email-masked]
Date: Tue, 04 Mar 2014 06:43:51 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IP Flow Information Export Working Group of the IETF.

        Title           : Exporting MIB Variables using the IPFIX Protocol
        Authors         : Paul Aitken
                          Benoit Claise
                          Colin McDowall
                          Juergen Schoenwaelder
	Filename        : draft-ietf-ipfix-mib-variable-export-05.txt
	Pages           : 80
	Date            : 2014-03-04

Abstract:
   This document specifies a way to complement IPFIX Data Records with
   Management Information Base (MIB) objects, avoiding the need to
   define new IPFIX Information Elements for existing Management
   Information Base objects that are already fully specified.

   An IPFIX Option Template and method are specified, which are used to
   export the extra information required to fully describe Simple
   Network Management Protocol (SNMP) MIB Objects.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipfix-mib-variable-export/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ipfix-mib-variable-export-05

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-ipfix-mib-variable-export-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Colin McDowall <[email-masked]>
Date: Tue, 04 Mar 2014 16:40:17 +0000

Hi All,

This is the latest version of the IPFIX MIB Export Draft that should resolve all the open
Todo items and review comments.

The structure or the document is now much improved and the architecture clarified.

The exporting of Sequence MIB Objects is now clear and unambiguous.

While it is still possible to specify the index for an individual field, exporting using
the mibObjectValueSequence structured data field is much simpler and efficient for sending
a complete or partial table.

The following are new examples added to the draft:
   5.3.  Exporting A Sequence Table: The OSPF Neighbor Sequence
   5.4.  Exporting Augmented Sequence Table: The IF-MIB id to name mapping
   5.8.  Exporting With Multiple Contexts: The OSPF Neighbor Sequence Revisited

This draft also calls out that the exporting process might not have an underlying SNMP
implementation or worry about indexing, and that the MIB Objects can be used purely as
extra types for IPFIX.

Thanks,
colin

On 04/03/2014 14:43, [email-masked] wrote:
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix
>