Subject: [IPFIX] I-D Action: draft-ietf-ipfix-mib-variable-export-08.txt

From: [email-masked]
Date: Sun, 04 Jan 2015 04:04:43 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IP Flow Information Export Working Group of the IETF.

        Title           : Exporting MIB Variables using the IPFIX Protocol
        Authors         : Paul Aitken
                          Benoit Claise
                          Colin McDowall
                          Juergen Schoenwaelder
	Filename        : draft-ietf-ipfix-mib-variable-export-08.txt
	Pages           : 76
	Date            : 2014-12-31

Abstract:
   This document specifies a way to complement IPFIX Data Records with
   Management Information Base (MIB) objects, avoiding the need to
   define new IPFIX Information Elements for existing Management
   Information Base objects that are already fully specified.

   An IPFIX Options Template and method are specified, which are used to
   export the extra information required to fully describe Simple
   Network Management Protocol (SNMP) MIB objects in IPFIX.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipfix-mib-variable-export/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ipfix-mib-variable-export-08

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-ipfix-mib-variable-export-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Paul Aitken <[email-masked]>
Date: Mon, 5 Jan 2015 10:57:17 +0100

Dear IPFIX experts,

The -08 version of this draft addresses Juergen Schoenwaelder's feedback in http://www.ietf.org/mail-archive/web/ipfix/current/msg07271.html

Please review the updated draft, or at least the diff ;-)

It'd be super if someone could independently verify the figures, to prevent me from opening further errata in future!

With this update, I have no further actions for this draft.

A summary of the changes is:

* use of "Scope Field" as a defined term per errata 4216.
  (This was used, though not defined, in RFC 7011.)

* changed mibObjectValueBits to octetArray with the following additional text:

	The flags or bits are encoded as per the standard IPFIX	
	Abstract Data Type of octetArray, with sufficient length to	
	accomodate the required number of bits. If the number of bits is	
	not an integer multiple of octets then the most significant bits	
	at end of the octetArray MUST be set to zero.

* corrected Length in many of the figures.
* renamed SNMPtotalCounter to snmpCounter
* renamed SNMPgauge to snmpGuage
* changed my affiliation.
* many small editorial corrections and improvements to the text.

Thanks,
P.

> -----Original Message-----
> From: IPFIX [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: 04 January 2015 12:05
> To: [email-masked]
> Cc: [email-masked]
> Subject: [IPFIX] I-D Action: draft-ietf-ipfix-mib-variable-export-08.txt
> 
> 
> _______________________________________________
> IPFIX mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipfix