Subject: [IPFIX] Question regarding packet capturing with IPFIX

From: Prashant Upadhyaya <[email-masked]>
Date: Fri, 10 Apr 2015 05:33:05 +0000

Hi,

We can sample an IP flow with IPFix.
My question is that when a packet is picked up in the sampling in IPFix, can I take that full packet out and export it outside for analysis or only a certain number of bytes of that packet as an upper limit.
Eg. when using sFlow, the sampled packet's maximum number of bytes captured is 256.

Regards
-Prashant

"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: Paul Aitken <[email-masked]>
Date: Fri, 10 Apr 2015 10:18:30 +0200

Prashant,

Refer to RFC2804, "IETF Policy on Wiretapping". Several of the IPFIX and PSAMP RFCs (7013, 7014, 7133, 5474, 5476, 5477) refer to that.

Some of the Information Elements also specifically call out RFC2804 - eg, 313 ipHeaderPacketSection:

With sufficient length, this element also reports octets from the IP payload. However, full packet capture of arbitrary packet streams is explicitly out of scope per the Security Considerations sections of [RFC5477] and [RFC2804].

P.

From: IPFIX [mailto:[email-masked]] On Behalf Of Prashant Upadhyaya
Sent: 10 April 2015 06:33
To: [email-masked]
Subject: [IPFIX] Question regarding packet capturing with IPFIX

Hi,

Regards
-Prashant