Subject: Re: [IPFIX] [sfc] FW: I-D Action: draft-kumar-ipfix-sfc-extension-00.txt

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 26 Apr 2015 18:39:34 -0400

I am wondering if the nextSFF fields really belong here?
I see several problems with them.  If the observation is being made 
before the SF, or between multiple local SF, then the information does 
not exist.  Even if the observation is being made after the last local 
SF, the identification of the next SFF, as understood by this SFF, may 
well not be an IP address.  What the local SFF knows may be an IP 
address, and Ethernet Address, an MPLS label, etc.  So I am not sure 
this makes sense as a reportable.

Otherwise, it looks quite reasonable and useful.

Yours,
Joel

On 4/26/15 4:35 PM, Nagendra Kumar Nainar (naikumar) wrote:
> Hi,
>
> Below is the draft proposed on IPFIX information elements for SFC.
>
> We welcome any comments/feedbacks.
>
> Regards,
> Draft Authors.
>
> On 3/9/15, 8:49 AM, "[email-masked]" <[email-masked]>
> wrote:
>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>>
>>
>>         Title           : IPFIX Information Element extension for SFC
>>         Authors         : Nagendra Kumar
>>                           Carlos Pignataro
>>                           Paul Quinn
>> 	Filename        : draft-kumar-ipfix-sfc-extension-00.txt
>> 	Pages           : 11
>> 	Date            : 2015-03-09
>>
>> Abstract:
>>    Service Function Chaining (SFC) is an architecture that enables any
>>    operator to apply selective set of services by steering the traffic
>>    through an ordered set of service functions without any topology
>>    dependency.
>>
>>    This document defines the required Information Elements to represent
>>    the details about service flows over any Service Function Path.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-kumar-ipfix-sfc-extension/
>>
>> There's also a htmlized version available at:
>> http://tools.ietf.org/html/draft-kumar-ipfix-sfc-extension-00
>>
>>
>> Please note that it may take a couple of minutes from the time of
>> submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> I-D-Announce mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/i-d-announce
>> Internet-Draft directories: http://www.ietf.org/shadow.html
>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Sun, 26 Apr 2015 20:35:59 +0000

Hi,

Regards,
Draft Authors.

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 29 Apr 2015 01:39:31 +0000

Hi Joel,

Thanks for the comments. Please see inline..

>not exist.  

<Nagendra> I think unobserved field by metering process while generating
flow record is not specific to SFC scenarios. This is discussed in below
draft,

https://tools.ietf.org/html/draft-aitken-ipfix-unobserved-fields-03

I think the consensus can be applicable for SFC scenarios as well.

>Even if the observation is being made after the last local

<Nagendra> Good point. I will check this and will include the update in
next revision.

>Otherwise, it looks quite reasonable and useful.

Thanks,
Nagendra