Subject: [IPP] IPP JPS2 - Error in Prototype templates and Spec (Table 2 operations)

From: Ira McDonald <[email-masked]>
Date: Tue, 26 Jan 2010 17:39:58 -0500

Hi Tom,

I just realized that the descriptions of Reprocess-Job [RFC3998]
and Resubmit-Job [IPP-JPS2] are exactly REVERSED in Table 2
(Operations requirement summary) in draft-16:

- says Reprocess-Job can modify the Retained Job (wrong)
- says Resubmit-Job is defined in RFC 3998 (wrong)

Please fix the Prototype template ASAP and also your editor's
working copy of JPS2.

Cheers,
- Ira

PS - The filename of your Prototype template totally violates
the PWG Naming Policy (see attached) which forbids any
uppercase letters and requires an 8-digit date (yyyymmdd)
at the end of *all* filenames (to avoid ambiguity when they
are copied out-of-context).

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
email: [email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Tom Hastings" <[email-masked]>
Date: Tue, 26 Jan 2010 16:39:29 -0800

Ira,

Good catch.  I had found some errors in the IANA section while preparing the
templates.  I had corrected the IANA template file before posting yesterday.
I've also made the fixes in a v17 editor's draft that I'm using to catch
typos, but haven't uploaded et.  

So it was good to make the separate template table files.

I've uploaded both templates with the corrected info and corrected file name
and deleted the older template versions to:

ftp://ftp.pwg.org/pub/pwg/ipp/prototyping/jps2-prototyping-template-from-int
ro-tables-20100126.doc

ftp://ftp.pwg.org/pub/pwg/ipp/prototyping/jps2-prototyping-template-from-ian
a-section-20100126.doc

Thanks,

Tom

-----Original Message-----
From: Ira McDonald [mailto:[email-masked]] 
Sent: Tuesday, January 26, 2010 14:40
To: [email-masked]; Tom Hastings; Michael R Sweet; Ira McDonald
Subject: IPP JPS2 - Error in Prototype templates and Spec (Table 2
operations)

Hi Tom,

working copy of JPS2.

Cheers,

- Ira

winter:

  734-944-0094

summer:

  906-494-2434

---

From: Ira McDonald <[email-masked]>
Date: Tue, 26 Jan 2010 20:32:09 -0500

Hi Tom,

Thanks.

There's still a typo in your corrected Intro tables file:
- you wrote RFC 2998 when you meant RFC 3998.

Cheers,
- Ira

On Tue, Jan 26, 2010 at 7:39 PM, Tom Hastings <[email-masked]> wrote:
> templates.  I had corrected the IANA template file before posting
> yesterday.  I’ve also made the fixes in a v17 editor’s draft that I'm using
> to catch typos, but haven’t uploaded et.
>
>
>
> ftp://ftp.pwg.org/pub/pwg/ipp/prototyping/jps2-prototyping-template-from-intro-tables-20100126.doc
>
> ftp://ftp.pwg.org/pub/pwg/ipp/prototyping/jps2-prototyping-template-from-iana-section-20100126.doc
>
>
>
> Thanks,
>
> Tom
>
>
>