Subject: [IPP] Add Close-Job to JPS2

From: Ira McDonald <[email-masked]>
Date: Tue, 9 Feb 2010 12:49:14 -0500

Hi,

The MFD WG has identified that a first class Close-Job
operation (as opposed to hiding it in Create-Job and
Send-Document with a boolean flag) is desirable for
many Services (to allow clean streaming, for example).

We should add Close-Job (which triggers Validate-Job
internally) to JPS2.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
email: [email-masked]
winter:
  579 Park Place  Saline, MI  48176
  734-944-0094
summer:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Tom Hastings" <[email-masked]>
Date: Tue, 09 Feb 2010 11:17:15 -0800

Ira,

Sounds like we should add to the IPP f2f agenda for tomorrow:

1. Whether or not to add Close-Job operation to JPS2.
2. Whether or not to add "job-delay-output" and "job-delay-output-until" Job
Template attributes to JPS2.

Should I make a separate straw horse draft of just these additions so we can
talk about them at the f2f?

Tom

-----Original Message-----
From: Ira McDonald [mailto:[email-masked]] 
Sent: Tuesday, February 09, 2010 09:49
To: [email-masked]; Tom Hastings; Michael R Sweet; Ira McDonald
Subject: Add Close-Job to JPS2

Hi,

Cheers,
- Ira

[TH> ] 
-----Original Message-----
From: Ira McDonald [mailto:[email-masked]] 
Sent: Tuesday, February 09, 2010 09:53
To: Michael Sweet; Ira McDonald
Cc: [email-masked]; Tom Hastings
Subject: Re: Add job-delay-output(-until) to JPS2

Hi Mike,

We are NOT even in WG last call - we are in Prototype status,
waiting for evidence of prototyping BEFORE entering WG last
call.

And yes, we are allowed to add functionality in either WG last
call or PWG Last Call (but NOT during PWG Formal Vote).

Cheers,
- Ira

On Tue, Feb 9, 2010 at 12:39 PM, Michael Sweet <[email-masked]> wrote:
> We certainly can, although I'm not sure of the process issues - are we
> allowed to add new content during WG last call?
> On Feb 9, 2010, at 9:30 AM, Ira McDonald wrote:
>
> Hi,
>
> The MFD WG has defined a new pair of attributes
> similar to job-hold-until(-time), but with somewhat
> different semantics.
>
> The new attributes ALLOW Job processing (e.g.,
> interpreting the Job) but DELAY any actual output.
>
> They are currently the only NEW attributes that are
> defined only in the MFD Overall spec.
>
> However, Pete Zehler confirms that Xerox already
> has implementations of this delay functionality.
>
> So we should add them to JPS2, right?
>
> Cheers,
> - Ira (IPP/2.0 co-editor)
>
> ___________________________________________________
> Michael Sweet, Senior Printing System Engineer
>
>
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 9 Feb 2010 11:20:59 -0800

I can update the slides accordingly, and include a high-level "this is what they are and do" slide.

Ira, why would Close-Job internally do a Validate-Job operation, given that IPP's Validate-Job is deprecated for 2.0?

---

From: Ira McDonald <[email-masked]>
Date: Tue, 9 Feb 2010 14:22:37 -0500

Hi Tom,

We are very short of time for mainstream IPP WG topics
tomorrow (3:45 MST Introductions through 5:00 MST end).

I think we should talk about Close-Job and "job-delay-xxx"
tomorrow, but not look at mockups - the MFD Overall spec
already defines "job-delay-xxx", so we should cohere with
those definitions (to be removed and replaced with a mere
reference to JPS2).

---

From: Ira McDonald <[email-masked]>
Date: Tue, 9 Feb 2010 14:24:21 -0500

Hi Mike,

Because Validate-Job is restored (for functionality) at IPP 2.1
and IPP 2.2 and is the required internal behavior part of Print-Job
of the close flag in Send-Document.

Gone for a walk with my dog and lunch...

Cheers,
- Ira

On Tue, Feb 9, 2010 at 2:20 PM, Michael Sweet <[email-masked]> wrote:
> Ira, why would Close-Job internally do a Validate-Job operation, given that
> IPP's Validate-Job is deprecated for 2.0?