Subject: [IPP] RFC: printer-supply-info-uri (uri)

From: Michael Sweet <[email-masked]>
Date: Fri, 18 Mar 2011 16:38:49 -0700

All,

After some offline discussions I propose the following new attribute for JPS3:

printer-supply-info-uri (uri)

The RECOMMENDED "printer-supply-info-uri" Printer attribute provides a "http:" or "https:" URI referring to a human-readable web page describing the current supply levels, part numbers, and other information, controls, and hyperlinks relevant to the Printer's supplies. The URI MUST use the “http” or “https” scheme with the printer as the destination host - external URIs are not allowed.

The ultimate purpose is to allow a client to display a printer's supply levels in a web browser (or other web-enabled UI) and (potentially) find or order replacement supplies. It can also provide remediation instructions (i.e. how to replace/refill/empty) a supply, etc.

Thoughts?

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Sun, 20 Mar 2011 12:42:31 -0400

Hi Mike,

I like this new attribute, but...

I think that the remediation info belongs locally in existing
"printer-state-message" and "printer-alert-description"
(mapped from Printer MIB remediation info), i.e., can be
found without fetching an external web page.

While the how-to-order info may be appropriate in this new
attribute, though I have seen it put in "printer-more-info"
web page.

Or was your intent that this web page was served by the
printer itself?  I think that implementation would introduce
freshness problems, i.e., distributors for resupply change
over time.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Fri, Mar 18, 2011 at 7:38 PM, Michael Sweet <[email-masked]> wrote:

> The RECOMMENDED "printer-supply-info-uri" Printer attribute provides
> a "http:" or "https:" URI referring to a human-readable web page describing
> the current supply levels, part numbers, and other
> information, controls, and hyperlinks relevant to the Printer's supplies.
> The URI MUST use the “http” or “https” scheme with the printer as the
> destination host - external URIs are not allowed.
>
>
> The ultimate purpose is to allow a client to display a printer's supply
> levels in a web browser (or other web-enabled UI) and (potentially) find or
> order replacement supplies. It can also provide remediation instructions
> (i.e. how to replace/refill/empty) a supply, etc.
>
> Thoughts?
>
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: Michael Sweet <[email-masked]>
Date: Sun, 20 Mar 2011 14:14:01 -0700

> found without fetching an external web page.

The simple instructions ("replace cyan ink") maybe, but the idea is that the printer can host a page that provides pictures, instructions, buttons to put the printer in "change ink mode" (many consumer inkjets have no physical buttons these days), print self-test pages, do head alignment, etc.

(This is traditionally stuff that is provided using vendor-specific software that is not easy to map to IPP operations and attributes.  On the Mac we call these Printer Utility programs...)

> attribute, though I have seen it put in "printer-more-info"

The idea is that this would be specific to supply information and management and not the printer as a whole. Also, printer-more-info often points to the vendor's product web page and not the printer itself.

> printer itself?

Yes, otherwise it would be useless for many of our use cases.

> I think that implementation would introduce 

Redirect pages are cheap (and probably necessary to handle regional differences), and I would expect vendors to direct customers to their own online stores and not to some third party anyways.

In any case, the primary purpose is to handle stuff on the printer that is normally done with vendor-specific UI that cannot be easily mapped to IPP attributes or operations.  Perhaps a better description would be:

    The RECOMMENDED "printer-supply-info-uri" Printer attribute provides a URI
    referring to a human-readable web page that provides controls for managing
    the Printer and its supplies, e.g., supply replacement, head alignment,
    self-test pages, and so forth.  The web page MAY also provide supply part
    numbers, links for ordering supplies, and detailed instructions for
    replacing supplies.

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Ira McDonald <[email-masked]>
Date: Mon, 21 Mar 2011 11:44:08 -0400

Hi Mike,

Thanks - with your clarifications and revised attribute description,
I'm in favor of this new attribute.

Cheers,
- Ira

On Sun, Mar 20, 2011 at 5:14 PM, Michael Sweet <[email-masked]> wrote:

> The simple instructions ("replace cyan ink") maybe, but the idea is that
> the printer can host a page that provides pictures, instructions, buttons to
> put the printer in "change ink mode" (many consumer inkjets have no physical
> buttons these days), print self-test pages, do head alignment, etc.
>
> (This is traditionally stuff that is provided using vendor-specific
> software that is not easy to map to IPP operations and attributes.  On the
> Mac we call these Printer Utility programs...)
>
> The idea is that this would be specific to supply information and
> management and not the printer as a whole. Also, printer-more-info often
> points to the vendor's product web page and not the printer itself.
>
> Redirect pages are cheap (and probably necessary to handle regional
> differences), and I would expect vendors to direct customers to their own
> online stores and not to some third party anyways.
>
> In any case, the primary purpose is to handle stuff on the printer that is
> normally done with vendor-specific UI that cannot be easily mapped to IPP
> attributes or operations.  Perhaps a better description would be:
>
> a URI