Subject: [IPP] JPS3: subscription-uuid vs. notify-subscription-uuid?

From: Michael Sweet <[email-masked]>
Date: Sat, 13 Sep 2014 10:15:50 -0400

All,

As I finish up my IPPINTRA prototype, I noticed that we (I) defined the UUID for subscriptions as "subscription-uuid" instead of "notify-subscription-uuid".  The corresponding integer subscription ID is "notify-subscription-id", so it would make more sense for us to use "notify-subscription-uuid".

I also checked and (for some reason) I never implemented subscription-uuid in CUPS...

Any objections to changing the registration to be "notify-subscription-uuid"?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Sat, 13 Sep 2014 11:15:11 -0400

Hi Mike,

I favor the name change.  Consistency in names of similar attributes
is important.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Sat, Sep 13, 2014 at 10:15 AM, Michael Sweet <[email-masked]> wrote:

> All,
>
> As I finish up my IPPINTRA prototype, I noticed that we (I) defined the
> UUID for subscriptions as "subscription-uuid" instead of
> "notify-subscription-uuid".  The corresponding integer subscription ID is
> "notify-subscription-id", so it would make more sense for us to use
> "notify-subscription-uuid".
>