Subject: [IPP] High North has reviewed the IPP Finishings 2.0 specification and has comments

From: Ira McDonald <[email-masked]>
Date: Thu, 11 Sep 2014 23:55:38 -0400

Hi,

These three comments are from the 8 September draft of JDFMAP
- names are PWG SM names (but map one-to-one to IPP names):

(1) Coating.CoatingType
Comment [i11]:
06/16/14 – IPP WG – Maybe import JDF coating types?
Mike will review.  08/25 – TBD by Mike

(2) Folding -> add FoldingType?
Comment [i12]:
06/16/14 – IPP WG – This will require some calculation since
all folds are from the top or left in JDF (Mike).
08/25/14 – Rainer says can be achieved in with
FoldingParamsLink/@Matrix (which can do rotations and flips).
Rainer says JDF folding for digital will be FoldingParams/@FoldCatalog

(3) Punching -> add PunchingType?
Comment [i13]:
08/25/14 – Rainer says JDF has @HoleType that gives you a
catalog of standard hole type names – should PWG add
PunchingType to IPP Finishings 2.0?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 12 Sep 2014 11:45:53 -0400

Ira,

Thanks, some quick feedback (which I'll include in the lcrc file as well...)

> Mike will review.  08/25 – TBD by Mike

Looks like the only coating types that cannot be directly mapped now are "Aqueous" (whatever that is) and "Protective" (again, no definition...)  No objection to adding them as long as we can define them.

> Rainer says JDF folding for digital will be FoldingParams/@FoldCatalog

I don't see a FoldingType or FoldingParamsLink/@Matrix in JDF 1.5.

I see a BoxFoldingType, but that's not the same.

Right now we follow JDF's FoldingParams/Fold/@{From|To|RelativeTravel|Travel}.

But as for @FoldCatalog, that is the equivalent to the fold-xxx values we have (just more values than we currently define).

> PunchingType to IPP Finishings 2.0?

There is a "HoleType" in HoleMakingParams.  But we already have the punch-dual-xxx, punch-triple-xxx, and punch-quad-xxx keywords and enums so I'm not sure it would be much use beyond those (i.e. use "finishing-template='punch-xxx'" as the equivalent of @HoleType...)

> Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair