Subject: [IPP] Fwd: [TLS] [Technical Errata Reported] RFC2817 (4187)

From: Ira McDonald <[email-masked]>
Date: Fri, 21 Nov 2014 11:55:14 -0500

Hi,

BEWARE - they're changing the product token (TLS/1.0 --> TLS)
in RFC 2817 - I can't imagine how this will be backward compatible.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

---------- Forwarded message ----------
From: RFC Errata System <[email-masked]>
Date: Thu, Nov 20, 2014 at 6:17 PM
Subject: [TLS] [Technical Errata Reported] RFC2817 (4187)
To: [email-masked], [email-masked], [email-masked],
[email-masked], [email-masked], [email-masked]
Cc: [email-masked], [email-masked], [email-masked]

The following errata report has been submitted for RFC2817,
"Upgrading to TLS Within HTTP/1.1".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=2817&eid=4187

--------------------------------------
Type: Technical
Reported by: Roy T. Fielding <[email-masked]>

Section: 7.2

Original Text
-------------
   The Draft Standard for HTTP/1.1 [1] specifies that these tokens obey
   the production for 'product':

      product         = token ["/" product-version]
      product-version = token

[...]

   This specification defines the protocol token "TLS/1.0" as the
   identifier for the protocol specified by The TLS Protocol [6].

Corrected Text
--------------
   The Draft Standard for HTTP/1.1 [1] specifies that these tokens obey
   the production for 'product':

      product         = token ["/" product-version]
      product-version = token

[...]

   This specification defines the product token "TLS" as the
   identifier for the protocol specified by The TLS Protocol [6].
   When a specific version of TLS is desired, it is indicated by
   appending a slash ("/") and the TLS version number as the
   product-version (e.g., "TLS/1.0").

Notes
-----
This erratum clarifies that "TLS" is the product token and any TLS version
number (currently DIGIT "." DIGIT) is the product-version token.  This has
already been corrected in the Upgrade Token Registry.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary.

--------------------------------------
RFC2817 (draft-ietf-tls-http-upgrade-05)
--------------------------------------
Title               : Upgrading to TLS Within HTTP/1.1
Publication Date    : May 2000
Author(s)           : R. Khare, S. Lawrence
Category            : PROPOSED STANDARD
Source              : Transport Layer Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Sun, 23 Nov 2014 21:29:08 -0500

Ira,

The issue here is that before they registered TLS/1.0 as the protocol name instead of just "TLS".  In practice implementations have needed to support "TLS/1.0", "TLS/1.1", and "TLS/1.2" anyways so this change is just fixing the registration and making it clear what the reality is...

> On Nov 21, 2014, at 11:55 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> To: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
> This erratum clarifies that "TLS" is the product token and any TLS version number (currently DIGIT "." DIGIT) is the product-version token.  This has already been corrected in the Upgrade Token Registry.
> 
> Instructions:
> -------------

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair