Subject: [IPP] about ipp-features-supported attribute

From: Walter Zhou <[email-masked]>
Date: Wed, 10 Dec 2014 17:22:59 +0800

Hi Michael

According to section 8.1 ipp-features-supported (1setOf type2 keywork) 
in [PWG5100.15-2014], I think it is appropriate for return the attribute 
value:

IPP:     ATTRIBUTE: ipp-features-supported
IPP:       VALUE: Syntax=KEYWORD, Data=airprint-1.4
IPP:       VALUE: Syntax=KEYWORD, Data=faxout

But APVT 1.4 complained,

_Get all printer attributes using ja language code._FAIL

EXPECTED: ipp-features-supported WITH-ALL-VALUES 
/^([^f]|f[^a]|fa[^x]|fax[^o]|faxo[^u]|faxou[^t])+$/ GOT: 
ipp-features-supported="airprint-1.4" GOT: ipp-features-supported="faxout"

{

Errors = (

"EXPECTED: ipp-features-supported WITH-ALL-VALUES 
/^([^f]|f[^a]|fa[^x]|fax[^o]|faxo[^u]|faxou[^t])+$/",

"GOT: ipp-features-supported=\"airprint-1.4\"",

"GOT: ipp-features-supported=\"faxout\""

);

What's wrong with my returned attribute value ? I think I obey the rule 
in section 8.1 ipp-features-supported (1setOf type2 keywork) in 
[PWG5100.15-2014].

Regards

Walter

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Wed, 10 Dec 2014 12:57:44 -0500

Hi Walter,

Subtle error here.

"ipp-features-supported" is of type "keyword" (which means only PWG and
IANA registered standard values can be used).

It is *not* "keyword | name" (which would have allowed "airprint-1.4", but
you
should not put version numbers into a feature name).

Apple would have to register the "airprint" with a publicly available spec
for
you to use it in "ipp-features-supported".

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Dec 10, 2014 at 4:22 AM, Walter Zhou <[email-masked]> wrote:

>  Hi Michael
>
> According to section 8.1 ipp-features-supported (1setOf type2 keywork) in
> [PWG5100.15-2014], I think it is appropriate for return the attribute
> value:
>
> *Get all printer attributes using ja language code.* FAIL
>
> What's wrong with my returned attribute value ? I think I obey the rule in
> section 8.1 ipp-features-supported (1setOf type2 keywork) in
> [PWG5100.15-2014].
>
> Regards
>
> Walter
>
>
>
>
>