Subject: [IPP] RFC: "printer-terms-of-use-uri" attribute for IPP INFRA?

From: Michael Sweet <[email-masked]>
Date: Thu, 18 Dec 2014 12:17:15 -0500

All,

It occurred to me while reviewing the current Cloud Imaging Model document that we might want to have a way for a service to point a Client to a web page providing legal terms of use for the service or system.  A short proposal:

    7.4.x printer-terms-of-use-uri (uri)

    This Printer attribute provides a URL to a human-readable web page providing the legal terms of use for the Printer, such as an End-User License Agreement or service agreement. If supported, the value MUST refer to a cacheable resource [RFC7234] to allow a Client to know when the terms of use change.

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Thu, 18 Dec 2014 13:45:30 -0500

Hi Mike,

I like this new attribute, but I'd like to be able to use it in (non-infra)
ordinary
campus or enterprise network, to inform people of their
rights/responsibilities
in using a Printer.

I'd like to be able to recommend it in IPP 2.0 next year.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Dec 18, 2014 at 12:17 PM, Michael Sweet <[email-masked]> wrote:
>
> All,
>
> It occurred to me while reviewing the current Cloud Imaging Model document
> that we might want to have a way for a service to point a Client to a web
> page providing legal terms of use for the service or system.  A short
> proposal:
>
>     This Printer attribute provides a URL to a human-readable web page
> providing the legal terms of use for the Printer, such as an End-User
> License Agreement or service agreement. If supported, the value MUST refer
> to a cacheable resource [RFC7234] to allow a Client to know when the terms
> of use change.
>
> Thoughts?
>

---

From: Michael Sweet <[email-masked]>
Date: Thu, 18 Dec 2014 15:04:58 -0500

Ira,

Absolutely, but it definitely applies to IPP INFRA and avoids an extra spec if we add it there... :)

We can still recommend it in the IPP/2.0 update.

> On Dec 18, 2014, at 1:45 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 
> I like this new attribute, but I'd like to be able to use it in (non-infra) ordinary
> campus or enterprise network, to inform people of their rights/responsibilities
> in using a Printer.  
>

---

From: Ira McDonald <[email-masked]>
Date: Thu, 18 Dec 2014 15:14:46 -0500

Hi Mike,

Then I'm a happy camper - thanks.

Cheers,
- Ira

On Thu, Dec 18, 2014 at 3:04 PM, Michael Sweet <[email-masked]> wrote:
> > It occurred to me while reviewing the current Cloud Imaging Model
> document that we might want to have a way for a service to point a Client
> to a web page providing legal terms of use for the service or system.  A
> short proposal:
> >

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 18 Dec 2014 21:17:41 +0000

Hi there,

Can you imagine any need for the Client to “prove” to the Printer or any other entity that the user has actually seen the offered terms of use content and has accepted it?  Or is that burden just on the Client and the Client’s implementation to “do the right thing”?  Not trying to add needless complexity and I’m no lawyer but this seems somewhat flimsy.

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Hewlett-Packard Co.
*/

> On 2014-12-18, at 1:14 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Thu, Dec 18, 2014 at 3:04 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
> Ira,
> 
> > On Dec 18, 2014, at 1:45 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Hi Mike,
> >
> > http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> > http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> > mailto: [email-masked] <mailto:[email-masked]>
> > Winter  579 Park Place  Saline, MI  48176  734-944-0094 <tel:734-944-0094>
> > Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434 <tel:906-494-2434>
> >
> >
> > On Thu, Dec 18, 2014 at 12:17 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
> > All,
> >
> > [email-masked] <mailto:[email-masked]>
> > https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>

---

From: Ira McDonald <[email-masked]>
Date: Thu, 18 Dec 2014 16:50:33 -0500

Hi Smith,

It's not advice to the IPP Client, but advice to the human user, just like
"job-charge-info" in PWG 5100.16.  No enforceable legal implications.

Cheers,
- Ira

On Thu, Dec 18, 2014 at 4:17 PM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:
>
> Hi there,
>
> Can you imagine any need for the Client to “prove” to the Printer or any
> other entity that the user has actually seen the offered terms of use
> content and has accepted it?  Or is that burden just on the Client and the
> Client’s implementation to “do the right thing”?  Not trying to add
> needless complexity and I’m no lawyer but this seems somewhat flimsy.
>
> Smith
>
> /**
>     Smith Kennedy

---

From: Michael Sweet <[email-masked]>
Date: Thu, 18 Dec 2014 17:02:42 -0500

Smith,

> On Dec 18, 2014, at 4:17 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi there,
> 

The referenced web page could provide a service sign-up/account setup link in order to establish credentials and enforce the terms of use, but I was not thinking of this as an enforcement mechanism but a standard way for a Printer to advise a Client that there are specific terms of use (vs. a regular printer that anyone can use...)