Subject: [IPP] "pwg-raster-document-type-supported" issue

From: Walter Zhou <[email-masked]>
Date: Mon, 1 Dec 2014 17:17:19 +0800

Hi Michael

Could you give more detail description for 
"pwg-raster-document-type-supported" attribute [PWG5102.4] or give a 
sample ?

Regards

Walter

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 01 Dec 2014 07:12:33 -0500

Walter,

> On Dec 1, 2014, at 4:17 AM, Walter Zhou <[email-masked]> wrote:
> 
> Hi Michael
> 
> Could you give more detail description for "pwg-raster-document-type-supported" attribute [PWG5102.4] or give a sample ?

This attribute just lists the color spaces and bit depths your printer supports. For example, a B&W printer might list the values 'black_1' and 'sgray_8' to indicate that it accepts 1-bit B&W and 8-bit grayscale raster data.

Similarly, a color printer might list 'black_1', 'cmyk_8', 'sgray_8', and 'srgb_8' to indicate suppport for 1-bit B&W and 8-bit per component grayscale and color raster data (8 bits total for grayscale, 24 bits for sRGB, and 32 bits for CMYK).

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Walter Zhou <[email-masked]>
Date: Thu, 4 Dec 2014 17:14:05 +0800

Hi Michael

Thanks for your comments.

Could you comment on "input-attributes-actual" attribute ? According to 
[PWG5100.15], the attribute could be as both Job Description Attribute 
and Document Description Attribute.

When I implement Add-Document-Image (AddFaxOutHardCopyDocument) 
operation, should I return the attribute in Group 3 (Document 
Description Attributes) ?

And how could I understand it is a Job Description Attribute ? I mean 
under what circumstances, I should return the Job Description Attribute ?

Regards

Walter

---

From: Michael Sweet <[email-masked]>
Date: Thu, 04 Dec 2014 07:52:58 -0500

Walter,

For implementations that support the document object, input-attributes-actual is reported as a Document Description attribute in response to a Get-Documents or Get-Document-Attributes request.

All implementations can report input-attributes-actual as a Job Description attribute in response to a Get-Jobs or Get-Job-Attributes request.

> On Dec 4, 2014, at 4:14 AM, Walter Zhou <[email-masked]> wrote:
> 
> Hi Michael
> 
> Could you comment on "input-attributes-actual" attribute ? According to [PWG5100.15], the attribute could be as both Job Description Attribute and Document Description Attribute.
> 
> When I implement Add-Document-Image (AddFaxOutHardCopyDocument) operation, should I return the attribute in Group 3 (Document Description Attributes) ?
> 
> And how could I understand it is a Job Description Attribute ? I mean under what circumstances, I should return the Job Description Attribute ?
> 
> Regards
> 
> Walter
>

---

From: Walter Zhou <[email-masked]>
Date: Thu, 4 Dec 2014 16:48:38 -0800

Hi Michael

Thanks for your comment. Your comments are very valuable for my work.

Do you mean I should not return "input-attributes-actual" attribute as Document Description Attribute in Add-Document-Image response ?

Regards

Walter Zhou
________________________________________
发件人: Michael Sweet [[email-masked]]
发送时间: 2014年12月4日 20:52
收件人: Walter Zhou
抄送: [email-masked]
主题: Re: "pwg-raster-document-type-supported" issue

Walter,

---

From: Walter Zhou <[email-masked]>
Date: Thu, 4 Dec 2014 22:46:18 -0800

Hi Michael

If a job contains two documents, one is created by Send-Document, the other is created by Add-Document-Images. I want to know how could I handle "input-attributes-actual" in the response of Get-Job-Attributes ?

Because I think job attributes are general for all documents in the same job, and the document attributes are for the specific document. I feel a little confused for "input-attributes-actual".

Regards

Walter Zhou
________________________________________
发件人: Walter Zhou
发送时间: 2014年12月5日 8:48
收件人: Michael Sweet
抄送: [email-masked]
主题: 答复: "pwg-raster-document-type-supported" issue

Hi Michael

Regards

Walter Zhou

Walter,

---

From: Michael Sweet <[email-masked]>
Date: Fri, 05 Dec 2014 08:53:55 -0500

Walter,

> On Dec 4, 2014, at 7:48 PM, Walter Zhou <[email-masked]> wrote:
> 
> Hi Michael
> 

Correct, the definition of the operation only returns the document-number.

---

From: Michael Sweet <[email-masked]>
Date: Fri, 05 Dec 2014 09:16:33 -0500

Walter,

> On Dec 5, 2014, at 1:46 AM, Walter Zhou <[email-masked]> wrote:
> 
> Hi Michael
> 

For a single document job, or when there is a single hardcopy document in the job, you can return the input-attributes-actual Job Description attribute without ambiguity.  For multiple hardcopy documents, I would only report the attribute in a response to Get-Documents/Get-Document-Attributes.