Subject: [IPP] The owner of the ipp request

From: Walter Zhou <[email-masked]>
Date: Wed, 10 Dec 2014 10:38:42 +0800

Hi all

If there is no "print-uri" attribute in IPP request, how could I know 
the owner of IPP request ?

For example, there are 2 objects (/ipp/print and /ipp/faxout) in the IPP 
printer. When the ipp request arrive, and it contains no "print-uri" and 
access resource path is "/", how could I know the owner for the request ?
It is for "/ipp/print" or "/ipp/faxout" ?

Regards

Walter
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 10 Dec 2014 09:12:37 -0500

Walter,

> On Dec 9, 2014, at 9:38 PM, Walter Zhou <[email-masked]> wrote:
> 
> Hi all
> 
> If there is no "print-uri" attribute in IPP request, how could I know the owner of IPP request ?

The "printer-uri" operation attribute is required by all standard IPP requests.

> For example, there are 2 objects (/ipp/print and /ipp/faxout) in the IPP printer. When the ipp request arrive, and it contains no "print-uri" and access resource path is "/", how could I know the owner for the request ?

You MUST return a client-error-bad-request status code.  Please read RFC 2911 and RFC 3196, look at the CUPS ippserver sample code, and use the CUPS ipptool program to validate your implementation.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair