Subject: [IPP] Request for new "finishings" keywords for Swedish hole punch pattern

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 6 Jul 2016 17:12:01 +0000

Greetings,

HP Inc. requests the addition of 4 "finishings" keywords to support the Swedish "Triohålning" de-facto hole punch standard, as described here:

https://en.wikipedia.org/wiki/Hole_punch#Sweden <https://en.wikipedia.org/wiki/Hole_punch#Sweden>
https://sv.wikipedia.org/wiki/Hålslagsapparat#Svensk_trioh.C3.A5lning <https://sv.wikipedia.org/wiki/H%C3%A5lslagsapparat#Svensk_trioh.C3.A5lning>

We propose the addition of 4 keywords:

"punch-triohalning-top"
"punch-triohalning-left"
"punch-triohalning-right"
"punch-triohalning-bottom"

Even though the "-top" and "-bottom" are likely not necessary for standard letter-type (i.e. A4) media sizes, it is conceivable that a user might want this punch pattern on the short edge of an A3 or larger media size, so that is why I'm suggesting we define these 4.

Cheers,

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 07 Jul 2016 09:27:58 -0400

Smith,

> On Jul 6, 2016, at 1:11 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Greetings,
> 

I have a few comments about this:

1. "finishings" is an enum attribute, "finishing-template" is a keyword (or name) attribute.  I assume you want both registered?

2. Keywords are supposed to be US English; looks like "trio binder" is the English equivalent of triohålning.

3. We already have punch-quad-{bottom,left,right,top}, and there are numerous 4-hole punch patterns (four specifically listed on the linked page). In the past we have opted for the enum/keyword to specify an implementation-defined hole pattern, with "finishings-col" providing the explicit control, so I am not super happy about going down this road (I count 15 different hole patterns for 2-7 hole punching on the wikipedia page alone).

4. From a practical standpoint, will finishers needing this support arbitrary 4-hole punch patterns, or will this be specific to a finisher that is sold/marketed solely in Sweden and nearby countries? If the latter, it seems like keeping the current (generic) punch-quad-xxx is sufficient for "finishings", with "finishings-col" providing explicit intent.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 11 Jul 2016 15:56:20 +0000

> On 2016-07-07, at 7:27 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 

That is correct - apologies for not being precise.  (And if we don't have anything in place currently to make sure that the set of enum values and keywords match, we probably ought to, since they are strongly related.)

> 3. We already have punch-quad-{bottom,left,right,top}, and there are numerous 4-hole punch patterns (four specifically listed on the linked page). In the past we have opted for the enum/keyword to…

Let me preface by saying I would have preferred to only pursue a solution that uses finishings-col, but unfortunately there seem to be quite a few laggards in this space that still depend on "finishings".  When "finishings-col" is employed, you can give the "finishings-template" value any value you want, because it becomes simply an identifier to be used to look up a string out of the strings catalog.

> 4. From a practical standpoint, will finishers needing this support arbitrary 4-hole punch patterns, or will this be specific to a finisher that is sold/marketed solely in Sweden and nearby countri…

I understand and sympathize with your worry about needless enum / keyword definitions.  But it struck me that the current keywords  definitions ("punch-quad-left") are really ambiguous as far as intent. Is that not a concern?

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Tue, 12 Jul 2016 19:12:53 +0000

Greetings,

I'm going to echo back the plan we discussed today in the IPP WG.  From what I took to understand, the plan was like so:

- No new enum value 'punch-triohalning-top' etc. to be defined for "finishings"
- Define a keyword / name "variant extension convention" for "finishing-template" names to allow variants to be created for defined keywords

Thus, to support Swedish Trio Binder (Triohålning) punch pattern, the Printer would list an entry in "finishings-col-database" and possibly "finishings-col-ready" where "finishing-template" would be set to something like 'punch-quad-left_trio-binder', with an appropriate localized string corresponding to that, and with all the "finishings-col" member attributes describing the appropriate punch locations. Below is an example of how the Trio Binder and European 4 ring patterns would be represented in discrete "finishings-col-ready" listings:

finishings-col-ready=
{
  finishing-template=punch-quad-left_trio-binder
  media-size-name=iso_a4_210x297mm
  media-size={x-dimension=21000 y-dimension=29700}
  punching=
  {
    punching-reference-edge=left,
    punching-offset=1200
    punching-locations=9250,11350,14850,16950
  }
},
{
  finishing-template=punch-quad-left_a4-european-4-ring
  media-size-name=iso_a4_210x297mm
  media-size={x-dimension=21000 y-dimension=29700}
  punching=
  {
    punching-reference-edge=left,
    punching-offset=1200
    punching-locations=2850,10850,18850,26850
  }
},

The naming convention proposed is to separate the "keyword" or "base name" from the "subtype name" with an underscore.  Reading even the latest revision of 2911 (https://tools.ietf.org/html/draft-sweet-rfc2911bis-09), it isn't clear to me that there is precedent for this convention.  If such conventions are used in other contexts, please share so that I can leverage that / those conventions in my updates to Finishings 2.1.

Cheers,

Smith

/**
    Smith Kennedy

> On 2016-07-11, at 9:56 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
>

---

From: Ira McDonald <[email-masked]>
Date: Tue, 12 Jul 2016 17:38:24 -0400

Hi Smith,

A precedent for use of "_" (underscore) to separate base and
extension names is section 3.4 Derived Media Type Names of
MSN2 (PWG5101.1-2013) [1], which begins with the following:

"Media Type Names MAY be locally extended from existing standard,
vendor, or custom media names by prefixing the names with the string
"derived-" and appending the existing name with a leading underscore,
e.g., "derived-xyz-photo_photographic-glossy".  The format is defined
by the following ABNF [STD68]:

    derived-type-name = "derived-" base-name "_"
                      ( base-name / vendor-type-name /
                        custom-type-name )

Cheers,
- Ira
[1] ftp://ftp.pwg.org/pub/pwg/candidates/cs-pwgmsn20-20130328-5101.1.pdf

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Jul 12, 2016 at 3:12 PM, Kennedy, Smith (Wireless Architect) <
[email-masked]> wrote:

> Greetings,
>
> I'm going to echo back the plan we discussed today in the IPP WG.  From
> what I took to understand, the plan was like so:
>
> - Define a keyword / name "variant extension convention" for
> "finishing-template" names to allow variants to be created for defined
> keywords
>
> Thus, to support Swedish Trio Binder (Triohålning) punch pattern, the
> Printer would list an entry in "finishings-col-database" and possibly
> "finishings-col-ready" where "finishing-template" would be set to something
> like 'punch-quad-left_trio-binder', with an appropriate localized string
> corresponding to that, and with all the "finishings-col" member attributes
> describing the appropriate punch locations. Below is an example of how the
> Trio Binder and European 4 ring patterns would be represented in discrete
> "finishings-col-ready" listings:
>
> finishings-col-ready=
> {
> The naming convention proposed is to separate the "keyword" or "base name"
> from the "subtype name" with an underscore.  Reading even the latest
> revision of 2911 (https://tools.ietf.org/html/draft-sweet-rfc2911bis-09),
> it isn't clear to me that there is precedent for this convention.  If such
> conventions are used in other contexts, please share so that I can leverage
> that / those conventions in my updates to Finishings 2.1.
>
> Cheers,
>
> Smith
>
> /**
>     Smith Kennedy
> >>> HP Inc. requests the addition of 4 "finishings" keywords to support
> the Swedish "Triohålning" de-facto hole punch standard, as described here:
> >>>
> >>> https://en.wikipedia.org/wiki/Hole_punch#Sweden <
> https://en.wikipedia.org/wiki/Hole_punch#Sweden>
> >>> https://sv.wikipedia.org/wiki/Hålslagsapparat#Svensk_trioh.C3.A5lning
> <
> https://sv.wikipedia.org/wiki/H%C3%A5lslagsapparat#Svensk_trioh.C3.A5lning
> >
> >>>
> >>> Even though the "-top" and "-bottom" are likely not necessary for
> standard letter-type (i.e. A4) media sizes, it is conceivable that a user
> might want this punch pattern on the short edge of an A3 or larger media
> size, so that is why I'm suggesting we define these 4.
> >>
> >> 1. "finishings" is an enum attribute, "finishing-template" is a keyword
> (or name) attribute.  I assume you want both registered?
> >
> > That is correct - apologies for not being precise.  (And if we don't
> have anything in place currently to make sure that the set of enum values
> and keywords match, we probably ought to, since they are strongly related.)
> >
> >>
> >> 3. We already have punch-quad-{bottom,left,right,top}, and there are
> numerous 4-hole punch patterns (four specifically listed on the linked
> page). In the past we have opted for the enum/keyword to specify an
> implementation-defined hole pattern, with "finishings-col" providing the
> explicit control, so I am not super happy about going down this road (I
> count 15 different hole patterns for 2-7 hole punching on the wikipedia
> page alone).
> >
> > Let me preface by saying I would have preferred to only pursue a
> solution that uses finishings-col, but unfortunately there seem to be quite
> a few laggards in this space that still depend on "finishings".  When
> "finishings-col" is employed, you can give the "finishings-template" value
> any value you want, because it becomes simply an identifier to be used to
> look up a string out of the strings catalog.
> >
> >>
> >> 4. From a practical standpoint, will finishers needing this support
> arbitrary 4-hole punch patterns, or will this be specific to a finisher
> that is sold/marketed solely in Sweden and nearby countries? If the latter,
> it seems like keeping the current (generic) punch-quad-xxx is sufficient
> for "finishings", with "finishings-col" providing explicit intent.
> >
> > I understand and sympathize with your worry about needless enum /
> keyword definitions.  But it struck me that the current keywords
> definitions ("punch-quad-left") are really ambiguous as far as intent. Is
> that not a concern?
> >
> >